Support » Fixing WordPress » Visual editor not working – no labels on buttons – no action on clicking "link"

  • Until 3.2.1 I have not been using visual editor and used HTML with no difficulty. When I upgraded to 3.2.1 “Links” button quit working for posts but still worked for comments in both visual and HTML editor.

    My visual editor buttons for posts do not show labels but hovering reveals which button is which. “Link” has no action when clicked.

    My HTML editor shows button labels but “Link” does not have any action when clicked.

    I am using Debian Squeeze stable and Google Chrome browser 12.0.742.124 (Official Build 92024)

    http://www.debian.org

    The “link” button is working here for this message entry with the same browser and OS.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Thanks for the new topic 🙂

    Okay, step one is doing the standard debugging.

    Have you tried:

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). Don’t forget the ones in mu-plugins. If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    – manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.2 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    Deactivating plugins has no effect.

    Switching to Twenty Eleven has no effect.

    Will try a manual upgrade. I recall at one time we had file-permissions problems so the automatic upgrade may have messed up.

    I found some file-permissions were wrong. The server could not read /wp-admin/images/arrows.png and several other image files (600 permissions). That seems to have prevented the TinyMCE editor for posts from working. Changing the permissions to 644 made things work again.

    Thanks.

    I have the exact same issue after upgrading to 3.2.1
    I deactivated all plug-ins and still no fix.

    My php is uptodate and the json is enabled.

    I even re-installed the wp files and still no fix.

    If nothing works try removing your htaccess file to see of that helps. gzip of this js has some issues

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Visual editor not working – no labels on buttons – no action on clicking "link"’ is closed to new replies.