Support » Fixing WordPress » Visual Editor not working in WordPress 4.6 on my laptop

Viewing 15 replies - 46 through 60 (of 84 total)
  • And i do not have a wp-config.php file, is that an error?

    Check your adblock plus disabled for wordpress

    Possible Fix
    for just about everybody

    Test of the visual editor;
    1) on a test page, see if you can type in some text or use an page that is known to already have text.
    2) though the Visual Editor window shows nothing, try to select from top to bottom in the WYSIWYG area, copy, then paste into a text editor like notepad.
    If you see text, then you know there is text in that area.
    It is probably just white fonts on a white background.

    This appears to be a problem with style sheets.
    The styles for this window seem to be effected by Aqua Page Builder, the editor, and the “Visual Editor” tab.

    I tried all the more elaborate methods, but narrowed it all down to Aqua Page Builder, and found turning that off meant that the Visual Editor worked well.
    It needs to be turned back on again after editing, otherwise it won’t fully render pages that have widgets included by Aqua Page Builder.

    Diagnosis at;
    https://wordpress.org/support/topic/aqua-page-builder-causes-missing-or-broken-visual-editor-display/

    It would be really handy to have a button in the editor, that would provide an option to deactivate Aqua Page Builder during the particular edit session, or by default.

    It would also be handy to have a similar button that would over-ride the style in the WYSIWYG display, so that fonts could be viewed (say by making a background color that it a different lightness/darkness to the font).

    In my case I could see all editors when running a local version of the website.

    When I login to the live (remotely hosted site), I could not see the same. I even imported the non-working live website locally, and all editors worked fine again. This however seem to work on a second computer in my house!!!

    After playing around, I found my issue was to do with the AV I was running. The one I have has a firewall module with ‘stealth mode web browsing’ feature . If this feature is enabled, all editors in the remote wordpress stop working. With it disabled, all work just fine.

    Try this and see how you get on.

    Hi dmulunda,
    That is a good diagnosis.
    Good work.

    Possible Difference;
    There may be a difference between what you have observed and what I have observed;
    Did you see the editor, but it had an apparently blank window (like I do)?
    or
    Did you not see the editor at all? (Tab, buttons, window?)

    Discussion;
    We are narrowing down on the problem.
    Stealth mode in the firewall is a method to make the connection to the internet difficult to find by any party that is part of the communication (not sender or receiver, or intermediate server). This helps reduce being compromised if a scan is done of the network or internet to look for open connections.
    Stealth mode, is a very sensible method to connect to the internet.
    In dialup connections, this method would need to have been set using a firewall (e.g. ZoneAlarm, or AVG firewall, or others), but in broadband connections this can often be done with the router which has firewall functions built in.

    Your diagnosis shows that the Visual Editor problem is solved by adjusting the settings of your firewall. That solves one problem, by creating a potentially far more destructive problem – not just for your computer, but also for your website and the server it is on at the other end.

    The Visual Editor needs to know that it is the user that is editing its pages, and your diagnosis implies that it “might” be doing this by using the information that “stealth mode” switched off reveals.
    But stealth mode switched off will release that information to the world.

    Two alternative fixes to try;

    1) Have nothing on WordPress that requires stealth mode to me switched off, so all interactions with wordpress hosting servers can be done at maximum security.
    Use cookies or some other method, to coordinate between the user and the server.

    2) The user could try “Trusted Zones” in browser, firewall, and router. It would need to be set in all three, as any one of those could block it.

    Still yet to be understood;
    Why does the visual editor works fine when the page builder is turned off?
    Maybe it is the page builder which is dependent on the stealth mode.

    But the visual editor clearly works without needing to adjust any firewall settings, if the page builder is deactivated. So this shows a connection with page builder.

    I have the same problem and like everybody here I tried all the steps stated above… Still can’t see my articles/pages…
    MKSnMKS I think have your problem: “Did you see the editor, but it had an apparently blank window (like I do)?”
    I see the buttons of both Backend and Frontend editors but nothing appear underneath.

    Hi Emma_USA,
    Sounds very similar to my experience.
    Please read my comment above,
    and go to the link it refers to;

    Diagnosis at;
    https://wordpress.org/support/topic/aqua-page-builder-causes-missing-or-broken-visual-editor-display/

    That should help diagnose and hopefully help you with a “work-around” for the problem.
    What page builder (see in plugins. e.g. “Aqua”) are you using?
    Please let us know how you get on.

    Hi all,
    I am having a really bad time with this issue for the last week.

    I have tried 5 devices on multiple browsers to ensure not a caching issue and all have a blank visual editor and when I go into text again it disappears.

    I have tried server rewinds with my host as far back as the 18th April before the new update on both wordpress and my Genenis Tasteful theme.

    I’ve also checked with multiple user accounts all the same, tried creating new ones and no difference.

    Unable to find any errors from the many suggestion on here and now at a loss. Has anyone been successful in correcting this issue?

    Thanks

    Hi Emma_USA (@emma_usa),
    Sounds similar, possibly the same.
    The tab is visible, the editor buttons are not, and the text box is blank.
    Read my diagnosis, and look for other comments/articles by us on this.
    Follow the diagnosis I have described elsewhere.
    But in brief;
    I now just deactivate my “page builder” plugin (which is “Aqua Page Builder”).
    While I am editing using the visual editor.
    Then re-Activate it after I have finished.

    While it is de-Activated, it may not serve up fully correct pages to the visitors if using certain widgets. But after the editing, everything is fine.

    We have tried to get this message through, but get a systemic response.
    To us it seems an interplay of of a few things.
    But not one of those teams seems to think it warrants looking in to.

    So try that fix and lets see if it works.

    Hi CrystalMcC (@crystalmcc),

    Read our diagnosis just above, previous to now, and elsewhere.

    In brief;
    I now just deactivate my “page builder” plugin (which is “Aqua Page Builder”).
    While I am editing using the visual editor.
    Then re-Activate it after I have finished

    A handy tool for narrowing down plugins that may be causing problems is a plugin group manager. See ;

    https://en-gb.wordpress.org/plugins/plugin-grouper/

    You can make a group and call it something like “Visual Editor Diag”
    And add every plugin that you think may be causing a problem.
    So you can very quickly select them all (by group), and de-activate, and re-activate them.
    Then you can selectively choose which ones to de-activate, till you have narrowed down the problematic plugins.

    But cut the long story short. Try de-activating what ever page builder plugin you are using, and see if you get you visual editor to work. Remamber to re-activate the pagebuilder afterwards, especially if you want to see the results of your editing.

    Let us know.

    Hi MKSnMKS,

    Thanks, but I do not have a page builder so it can’t be that. In addition;
    I have disabled all plugins without effect.
    I have turned off the firewall.
    I have disabled all child internet protections.
    I have reinstalled the newest WP update.
    All plugins are up to date.
    I have done server rewinds through my host, going back a month.
    Blog caches have been cleared, as well as from the devices.
    I have added a new profile without change.
    My profile has a nickname.
    I have also tried every other thing mentioned in several threads (going back 68 pages on the forum).
    Still no luck.

    When logging in on 2 pcs, 2 laptops, and a tablet, and using 3 different browsers, it’s all the same. The weird thing is I can access it fine from the public library using their pcs (but it has only part-time hours and I’m a full-time mom and virtual assistant so I can’t sit there all day to work). I’m about at my wits’ end as it’s been 6 days and I have deadlines that are being missed.

    Is there anything else I can try?

    Hi CrystalMcC (@crystalmcc),

    From what you have said, there are two approaches that may be used to narrow down the problem. Since time is of the essence for you, we can try one then the other (which ever one you want first), or we can do the two at the same time.

    1) Method (1) – Narrow down the problem on your gear at home

    Thanks for info on all the things you have tried.
    Of particular interest is – when you view the tab for Visual Editor, and you see nothing in the text box, have you tried to select non visible text in the text box, and copy it, to paste in to a text editor?
    If it is an empty new page, then type in some text (even though you won’t see it).
    Or you can switch to the text tab and type it in there, then switch back to the visual editor tab.
    This test shows that the editor is working to the extent that text is able to be used. And therefore it is a problem with “being seen” rather than “not-being” at all.

    Can you also supply a list of the plug-ins you are using please?

    2) Method (2) – Narrow down the problem on your gear at the library or some other internet connection.
    Your tests at home have checked out your gear, your website server’s setup, and been done through your home internet connection.
    Your use of the library gear, shows that their internet connection , their PCs, and your website server work ok.
    So it looks like your website server, at least under some circumstances can be seen to work. This suggests that something which is not working is either your gear at home, or your internet connection, or an interplay of the combination of those and possibly your server.
    So we can do a swap in/out test, if you are allowed to take some of your home gear to the library, and attempt to use your webserver through their internet connection with your gear (maybe try more than one device).
    If that works, then it points to your internet connection as the problem (could be their firewall system or their caching system).
    It is not likely that the library will let you take one of their PCs home, to try to use your website server through your home connection.
    But, if you know somebody that you can do similar test as you have done at the library, then you may be able to do these additional tests with them also.
    If your gear does not work through the library internet connection, then you will know that the problem is with you gear, and may or may not also include your home internet connection as well.

    Additional Asides;

    a) Caching systems – It is important to set caching systems so that when there are admin connections to the server, that they bypass cache, so the admin can see the latest updates of their pages. Somewhere in WP there is a setting that does this. If you use an additional caching plugin, then the setting should be in there.

    b) Your ISP may not formally confirm they are using a cache or firewall system, but there may be ways to test for these in your connection. If your connection turns out to be the possible cause of the problem, then you will need to chat with your ISP to find out this information, and see if there are any settings that can be adjusted.

    c) Your internet connection settings on your home gear
    Which browsers (and versions) are you using?
    What operating systems are your devices using?
    We can do a quick check on the “security” settings for the internet connection, which may be blocking some script. This can possibly be done by comparing to settings on gear which is known to work with you website server. But we will leave this for later if other more likely causes are found to be ok.

    d) Your router settings on your home network.
    We can check any settings in this that may be limiting some scripts.
    This is least likely of all, but may still be possible.

    In any case.
    As the “get go” for now, the use through the library works, and there is currently no other way. Work on getting the website running well (latest everything), so at least the website visitors get to see it.
    That should mean that your website server can with a good level of confidence, be regarded as a least probable cause of the problem (even though it is probable that the WP server software could be improved to detect problem conditions and avoid the problem behaviour).

    Hello.

    I think I’m experiencing a variant of this issue as well. Anytime I’m trying to edit a post, it just redirects me to a weird looking screen (see the image).

    http://imgur.com/a/Rq5O5

    I narrowed it down to the following plugin: Page Builder by SiteOrigin.

    This didn’t use to be a problem. Any idea of what might have caused it?

    Thanks a lot!

    Hi razvanimal (@razvanimal),
    The image is a bit blurry.
    Could you please point out what you think is weird in the picture,
    or explain what the relevance of the arrow pointing to the facebook right margin area is?

    Could you describe any tests you have done, or what the symptoms are?

    Are you able to provide a picture of your visual editor?

    But now that you have narrowed it down to Page Builder;

    1) When Page Builder is activated, in the Visual Editor, Can you select and copy from the visual editor text area, and paste in to a text editor and see the resulting text?

    2) Does your visual editor work while Page Builder is de-activated?

    3) Things that might have changed;
    a) Did it happen after an update of anything on your website server?
    b) Did anything change with your inhouse network, internet connection or ISP.

    Thanks

    Hi MKSnMKS, thanks for you quick reply!

    What I’m trying to show via the initial screenshot is that, upon clicking a post in order to edit it, I’m re-directed to the weird page on the right side of the image (the arrow points to it).

    With the Page Builder plugin deactivated, I’m seeing the following, as I should:

    http://imgur.com/a/nP4bx

    To answer your questions:
    1. There is no Visual Editor, the right part of the initial attachment is what I’m getting with the Page Builder plugin activated.
    2. It does, see the image above.
    3.
    a) Not that I know of, no. Last email I got from my web hosting company was on the 20th of April, regarding a back-up of my blog.
    b) Nope, nothing of the sorts.

    Hope this helps!

    Razvan

Viewing 15 replies - 46 through 60 (of 84 total)
  • The topic ‘Visual Editor not working in WordPress 4.6 on my laptop’ is closed to new replies.