Support » Fixing WordPress » Visual Editor not working in WordPress 4.6 on my laptop

Viewing 15 replies - 31 through 45 (of 84 total)
  • I deactivated all plugins and reactivated them 1 by 1. The culprit for my issue was “Shortcode Reference”

    http://www.screencast.com/t/O1G3wb5oHSD

    I finally found my problem. I use Guru as my theme to manage my education website. In the settings for Guru, you can select a switch on/off for a page builder. The page builder was on for pages, off for courses and lessons. My issue was only with pages and posts. Well I do not use the page builder so I turn all the switches off and off I go.. There seems to be a bug with Guru and WP 4.6.1

    Just want to add that the solution provided by @brand-rocket worked for me and that it was happening for a user that I had created through phpMyAdmin as @david_treblig indicated might be the cause.

    TO be sure the steps that worked for me were:
    – access the user profile
    – “Disable the visual editor when writing” was unchecked so I checked it and selected “Update User”
    – An Error about not having a nickname was displayed, so I added a nickname for the user
    – I then checked the box to “Disable the visual editor…” and clicked “Update User”
    – and finally I unchecked the box and saved again

    And the editor was back!

    I checked the wp_usermeta table and can see that the “rich_editing” row and about 20 other rows were the most recent additions to the table, so I think it is safe to assume that the rich_editing value was not present until some point in the process above – saving with the “nickname” may have been the step that created the row for “rich_editing” in the table which then allowed the editor to show.

    Anyways, thanks @brand-rocket and @david_treblig for the push in the right direction.

    Your welcome @samcouture I’m glad it helped! Merry christmas

    I had the same problem after updating WordPress and moving to a new server.

    My solution that worked was switching off all plugins and enabling them one-by-one.

    I found out that the problem with the disappeared visual und non-working text editor was due to an outdated All in One SEO plugin. After updating the plugin, everything worked again.

    Thank you @brand-rocket, I can’t believe it was something so simple! Adding my nickname brought back the editor.

    i see this , no buttons , facing lot of issue while editimg post any clue any help

    chk- http://99likes.com/files/2017/01/bug.jpg

    • This reply was modified 2 years, 9 months ago by  Vishnu.

    I had the same problem as Vishnu after updating WordPress to 4.7.1 and the only fix that worked for me was to open wp-config.php file and add the following line at the very top after the PHP opening tag.

    define(‘CONCATENATE_SCRIPTS’, false);

    Now everything is back to normal.
    Thanks.

    I am also having the same problem and I tried all the above solutions.
    What can we do more?
    Thanks!

    Hi,
    I just saw this video on youtube.
    It didn’t work for me because when I go to see the htaccess is empty for me.
    Which is very strange.
    But I want to share it with you.
    Maybe it can help somebody else.
    Paddy

    I’ve tried all of the above and none of it has worked.

    – Disabling all plugins.
    – Changing my theme.
    – Changing settings in my theme.
    – Checking .htaccess
    – Changing my nickname.
    – Multiple changes to current username.
    – Activating and deactivating the visual editor option.
    – Creating a new username.
    – All of the other possible fixes mentioned in this thread.

    None of it has worked. It is insane that this is still a problem that hasn’t been fixed. The only thing that shows on the visual editor is the Add Media button.

    I just fixed it. I have no idea how but I did a couple of things in a row:

    1. I added the code from this thread (https://wordpress.org/support/topic/visual-editor-tab-not-working-5/) to my wp-config.php file.

    Then realised I had blocked access to wp-config in iThemes security and couldn’t upload the file in Filezilla. So,

    2. I went into the iThemes plugin and disabled the block, along with a few other blocks I had in place under “System Tweaks”.

    3. Reuploaded wp-config.php and it worked.

    I then went back and removed the code from wp-config and reset all of the security plugin features to its original state and it is still working.

    Very odd. But at least it’s working for me now.

    I think I spoke too soon.

    I was logged in with the new username when I did all of the above. And now it works with the new username login but not with the original username I created when installing WordPress – so it does seem like it is a username issue.

    However, with whatever I did, now my theme is broken and I can’t seem to get it right again. 🙁

    Ok. I have FINALLY worked it out and hopefully this will be my last post fingers crossed. I am only posting this in the hopes it will help someone.

    I had to do multiple logins and logouts with my old username and new username to figure this out, ensuring I cleared my cache every single time. Here’s the order in which I fixed it, including my broken theme which I now have a feeling has to do with iThemes security – mind you this wasn’t a problem before changing things with the usernames.

    1. I created a new username in the WordPress dashboard using my existing login.
    2. I made sure the “Disable PHP in Plugins” under “System Tweaks” in iThemes security box was unchecked.
    3. I logged out.
    4. Cleared my cache ensuring no browser windows with my website page were open.
    5. I entered the code from the thread I stated above into my wp-config.php file and uploaded it using Filezilla.
    6. I logged in with my new username and voila! – my theme was fixed and visual editor was working.
    7. I then tried logging in with my old username and it was still working.

    And I hope it stays this way!! 🙂

    I am getting the same problem ,but is not able to solve with any of the above suggestions .
    Can you suggest me something else?

Viewing 15 replies - 31 through 45 (of 84 total)
  • The topic ‘Visual Editor not working in WordPress 4.6 on my laptop’ is closed to new replies.