Support » Fixing WordPress » Visual Editor not working in WordPress 4.6 on my laptop

Viewing 15 replies - 16 through 30 (of 84 total)
  • Did you try the Permalinks solution?

    Wow, Mlapoint64, that worked. You’re a genius! Thanks so much.

    YEAHHHH.. glad it worked!
    I was just lucky to find this the first time it happened (a year+ ago?). I forgot about it the 2nd time it happened, spent hours without being able to fix it. The client got fed up with the hosting company & moved the site, and it “fixed” itself (their servers were slow anyhow). Then last week, out of the blue, someone replied to the older post about this issue, and it “enlightened” me 😛
    Hope it works for all others!

    I finally fixed mine!!! I had to deactivate the “TinyMCE” plugin. It gives me more features in the visual editor. I deactivated it first because it seemed like a likely culprit. I don’t have the extra options in the editor, but I’ll take it vs. having to write my posts in HTML! Hopefully the plugin comes out with an update soon!

    Okay mlapoint64, you’re a genius, me, not so much. I tried the permalinks change and it worked. Then my seo plugin didn’t like it so I switched it back. I’ve tried and tried, but I haven’t been able to get it to work again.

    @hmrissler
    Try the Permalink solution.
    If TinyMCE is your culprit, try WP Edit. Not as many functions but not bad.
    https://wordpress.org/plugins/wp-edit/

    @tonyseel
    I first changed the permalinks to “plain”. Once I saw that it worked, I changed it back to “post name” and it was still working. Not so genius 😛
    Try this:
    1) Install WP Super Cache: https://wordpress.org/plugins/wp-super-cache/
    2) Put the Caching On (Recommended)
    3) Change permalinks to “plain”
    4) Delete cache
    5) Delete cache on all blogs
    6) Check if your editor is working. If so,
    7) Change permalinks to “posts”
    4) Delete cache
    5) Delete cache on all blogs
    6) Check if your editor is working. If so, Yeah… if not, maybe deactivate all of your plugins, delete all caches again, see if it works, then reactivate the one by one and test.

    If all fails, try another hosting company?
    Good luck.

    @hmrissler
    1-Please try to change your Current PHP version from cPanel
    OR
    2- Deactivate recently activated plugins
    3- Change your current theme
    And
    4- Clear your browser cookies data

    Chillax 🙂

    I am having the same issue. I have tried ALL of the above steps and processes but to no avail. If anyone can help at all, it would be greatly appreciated!

    A few additional symptoms of the issue:

    The editor, by default, starts on text, not visual. This is the same withing Visual Composer’s text module as it is within just the default wordpress text edit zone.

    When I click visual, it shows a white space and then ends up reverting back to text. Then when I click visual again, it doesn’t load the white space.

    At no point when I click visual, does the actual visual tab look like it’s been selected.

    Just to clarify a few things about my particular case

    -I have tried all previously mentioned fixes
    -I have disabled all plugins and that did not help
    -I have changed themes and that did nothing
    -I have tried several changes that were recommended to make in wp-config and those did not help
    -Every other website on my host and subdomain works fine.

    Thanks to anyone who is able to help. I really appreciate it!

    Did you try changing the permalinks?

    As I stated twice, I tried ALL previously mentioned fixes or solutions. nothing helped. Permalinks was one of those.

    I had to take control over one of my new client’s website, and I did so by creating an admin user through phpMyAdmin. I only fill out the essential information for me to access and I didn’t thought that would cause me this problem.

    In my particular case the solution was also filling out the nickname.

    I am having the same issue ever since I updated to WP 4.6.1 I have also tried all of the above with no avail. I cannot add media or links.

    Easy but weird fix guys:

    The issue is with the User creation. Please follow these steps:

    1. Go to Users and Edit whichever user is having the issue
    2. Delete First Name, Last Name
    3. Change “Display name publicly as” to your Nickname
    4. Save.

    You should have Visual Editor back!!!

    Here is the funny thing.. The WP editor works fine in my Learning management system by Senei, but anytime I use the editor in a page or post, the visual stops working. I can’t even switch to text and save the work. If I write the code in HTML with the text, it will not save it and I lose the changes.. I cannot seem to shake the bug..

    • This reply was modified 2 years, 10 months ago by  randybtx.

    Thank you for your help, but your suggestion did not help.. I have check all my plugins and still no fix.. Could it be a PHP thing?

Viewing 15 replies - 16 through 30 (of 84 total)
  • The topic ‘Visual Editor not working in WordPress 4.6 on my laptop’ is closed to new replies.