Support » Fixing WordPress » Visual Editor not working in WordPress 4.6 on my laptop

Viewing 15 replies - 1 through 15 (of 84 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    I do not see the visual editor as shown here:

    At Users -> Your Profile in your site’s Dashboard, make sure that “Disable the visual editor when writing” is *not* checked.

    If it’s not checked, try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Sixteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    I actually just noticed that in writing this post I am not seeing the visual editor right here either:

    We’ve never had a visual editor in the forums here, so that’s to be expected. 🙂

    Thanks for the prompt response James.

    I actually just checked to make sure that the “disable visual editor” was not checked:

    http://screencast.com/t/RDBLpsNez0D5

    If it’s not checked, try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Sixteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    I had done that prior to posting this thread.

    Any other ideas maybe?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Sure, so with those ruled out, it could be something browser-specific.

    First, please make sure that your browser is up to date by visiting https://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    I am experiencing the same problem as John, tried deactivating theme and plugins and ofcourse checking my user settings.

    The Visual Editor is not working in either Chrome, Firefox or Edge.

    Looking forward to finding a solution for this.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Right, so now try the browser steps above, including testing with all add-ons and extensions disabled, and letting us know which versions of the browsers you’re using.

    So I found the solution to the problem on my own installation at least.

    Under “Users” I tried to disable the editor because I wanted to try to enable it again but got the notice that my nickname was missing. After filling out the nickname and saving I disabled the Visual Editor and then enabled it again and it worked!

    Hope this helps someone 🙂

    I had the exact same problem and it was because I had added the user through phpMyAdmin after making a local copy of an existing website. Users created with commands probably don’t fill all the meta informations that a user needs to work properly and thus didn’t have the option “don’t show visual editor” in the users meta database table.

    If not found, this option probably resolves to “true” instead of its supossed default value which is “false” or “unchecked” and that creates the bug that many of us have had this week.

    I am sorry to be showing up here too with the same issue…
    I have tried just all of the above solutions (even reinstalling 4.6.1 and using FF and Chrome’s latest versions – I did not deactivate about four plugins (Jetpack, Akismet and a couple more) because it takes too long to set them back
    AND

      I called my host tech

    support who tried it on her Windows Linux system and had NO problem seeing both tabs.

    As I run a few sites,

      from the same server

    , I tried a few of them and some of them work normally:
    http://nowlearnfrench.com
    For some reason your site does not show up this other site of mine:


    while others have problems:
    – ONLY Visual Editor (not Text Editor)
    http://ervinmarton.com
    http://stlouisfrenchtutoring.com
    – ONLY Text Editor (not Visual Editor) BUT in my previous login it was the reverse!
    http://piermarton.info

    Thank you.

    • This reply was modified 3 years, 1 month ago by PierM. Reason: clarify my text
    • This reply was modified 3 years, 1 month ago by PierM. Reason: Updating & Clarity

    I’m having the same issue with only 1 of my 8 websites.
    I’ve deactivated all plugins, activated a default template, reinstalled WP 4.6.1, editor is NOT disabled, etc.
    I do not see the text editor, cannot switch between visual/text and my text is “white” (when I highlight it, it appears as it highlights in black).
    Tried in chrome, in IE, on my laptop, on my desktop, no luck.

    Like @brand-rocket, when I added a nickname, the visual editor reappeared.

    Hi PierM and mlapointe64

    Have you tried creating a brand new user through the Dashboard and logging in with that instead?

    It appears that the problem might be related to users created through phpmyadmin which might have missing metadata like david_treblig is mentioning.

    Best of luck,
    Steffen

    • This reply was modified 3 years, 1 month ago by Brand Rocket.

    Thank you @brand-rocket but it does not work.

    I cloned the site onto my server and the editor works, so I believe there is now something incompatible in the new WP version with some servers.

    On the live site, I changed the PHP version to older, newer and no luck, still cannot edit anything unless I create the content in Dreamweaver, then paste the html in 🙁

    tonyseel

    (@tonyseel)

    I am having the same problems as the others. I’ve deactivated my plugins, cleaned out my cache, contacted my hosting company (who said it wasn’t their problem) and I don’t understand why this is still happening with so many people having the same problem.

    mlapointe64

    (@mlapointe64)

    Try settings, permalinks, change to “plain” or another, save changes, then try back. You can then change the permalinks back to your original settings.
    Let me know if that works… My client changed server after all but I realized that I had this issue before on another site and this trick worked.

    hmrissler

    (@hmrissler)

    Also having this same issue and feel like I’ve tried everything. I’m having to write my posts in HTML, which is not so fun. Really looking forward to a solution. :\

Viewing 15 replies - 1 through 15 (of 84 total)
  • The topic ‘Visual Editor not working in WordPress 4.6 on my laptop’ is closed to new replies.