Support » Fixing WordPress » Visual Editor Not Working in WordPress 4.5

  • I have WordPress 4.5 installed on my website. I am using the Lotus Theme 3.7.0. When I open a page in the backend of wordpress, nothing appears in my Visual Editor. If I click on the text editor, then go back to the visual editor, I see the content. I can make edits, but when I click “update”, the new edits don’t take.

    Everything was working until I installed WordPress 4.5.

    Any recommendations on how to resolve this issue?

    Thank you

Viewing 15 replies - 16 through 30 (of 52 total)
  • Same issue here.
    ReferenceError: tinymce is not defined

    GET http://myserver.com/folder/wp-includes/js/tinymce/wp-tinymce.php 403 Forbidden

    Works fine with script_debug. Not without.

    Other WP installs on the same server updated without issue, so not hosting related.

    I contacted my hosting company and my WP 4.5.1 issue is resolved. The file permissions on the folders in the WordPress manual install were incorrect. My FTP program may have set them incorrectly. Once the permissions on the folders and subfolders were corrected to 755, my visual editor works normally again.

    Hope this helps others with the same issue.

    Thank you, tmweb. Glad you got it working!
    Unfortunately, my wp-includes/js/tinymce folder, and all subfolders, are already set at 0755. The php files are 0644. Still not working.

    My folder- and file- permissions are all set to 777,
    but no help.

    I can confirm that my folder/file permissions are set to 755 and the problem is still occurring.
    Is anyone doing anything about this?

    Either check you’re running Wordfence as it adds firewall rules to your .htaccess and can block that file from running regardless of dir/file permissions or add this to your wp-config.php file

    define(‘CONCATENATE_SCRIPTS’, false ); // <———- ADD THIS LINE

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    basshsw – as I posted in my other thread, that absolutely fixed this issue for me. THANK YOU!

    Brilliant!

    Thanks basshsw, that’s solved the problem for me too.

    I didn’t suspect wordfence as deacitvating the plugin made no difference.

    basshsw,
    Thank you!
    To add that command line to wp-config.php resolved this big problem!

    Word Press!
    I think that this kind of wp-config.php adjutments
    should be noticed by the upgrade.

    basshsw,

    Thanks ever so much!!! Modified the wp.config exactly as you said – now all is good with the world!

    THANK YOU!!

    Hi, I’m having the same issue. I’d like to try Basshsw’s fix, but I’m not sure where in the wp-config.php to place the line.

    Should it go right toward the end? And do I need to include the 2 slashes?
    So that it would look like this:

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    define(‘CONCATENATE_SCRIPTS’, false ); //

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    Hello All,

    Rayrob, I feel your frustration; I tried all of your steps, including adding the snipet of code in the wp-config.php file but still no luck. I cleared my cache several times.

    I did notice a weird issue, might be browser related.

    My older computer using Windows 7 and most likely an older browser did not experience this problem. My brand new laptop with Windows 10 is experiencing this issue. Could it be a browser thing?

    Any help would be appreciated; It’s a very frustrating issue.

    Tks,

    Hello Again,

    I noticed 4.5.2 came out today. I figured this is something they would fix, but unfortunately, I still have the white text in the white background.

    Very frustrating. Anyone have the same problem???

    i confirm the bug in my version 4.5.2.

    Still having this trouble.

    Added define(‘CONCATENATE_SCRIPTS’, false ); // to the config file. Disabled Wordfence firewall … still nothing doing.

    currently at 4.5.2

Viewing 15 replies - 16 through 30 (of 52 total)
  • The topic ‘Visual Editor Not Working in WordPress 4.5’ is closed to new replies.