Support » Fixing WordPress » Visual Editor Not Working in WordPress 4.5

  • I have WordPress 4.5 installed on my website. I am using the Lotus Theme 3.7.0. When I open a page in the backend of wordpress, nothing appears in my Visual Editor. If I click on the text editor, then go back to the visual editor, I see the content. I can make edits, but when I click “update”, the new edits don’t take.

    Everything was working until I installed WordPress 4.5.

    Any recommendations on how to resolve this issue?

    Thank you

Viewing 15 replies - 1 through 15 (of 52 total)
  • Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    You’re probably getting the jQuery error outlined here: https://wordpress.org/support/topic/read-this-first-wordpress-45-master-list?replies=7

    You’re using a premium/paid theme. It’s best to go to the support site where you bought the theme – http://themeforest.net/ – for help with customizations and issues. You paid for support when you bought the theme, so you should contact the people who sold you the theme. These forums are for free themes available in the WordPress theme directory at http://wordpress.org/themes/. See http://codex.wordpress.org/Forum_Welcome#Commercial_Products

    I have a similar problem – there seem to be countless instances of 4.5 breaking visual editor – on my installation VE shows white text on white background, no editing tools & can’t switch to “Text”.

    I’ve tried disabling all plugins – no difference.

    I’ve tried changing theme, switching to twenty sixteen – no difference.

    If it’s not a plugin or theme issue I don’t know what to try next.

    As suggested here http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Enabling script-debug in wp-config appears to fix it.

    What do I do now?

    Thanks,

    Moderator Steve Stern

    (@sterndata)

    WordPresser, Third Class

    Rayob:

    You could try WordPress 4.5.1. There’s a release candidate available. See https://make.wordpress.org/core/2016/04/22/4-5-1-release-candidate/ for more information

    In the future, please start your own threads here as your problem is probably not the same as the OP’s.

    Hi,

    Same problem with WP 4.5 and Freelancer version 0.5.
    I can’t use visual edit with my pages.
    Edit-windows are empty ?!

    What do I do?
    Thanks

    Moderator Mark Ratledge

    (@songdogtech)

    Forum Moderator

    Rayob, did you fix the problem?
    I have same issue, editor works only with wp_debug “true”

    steamn,

    I haven’t tried it yet. My site front end is working fine so I don’t want to risk screwing up something else by carrying out a manual update – I’ll wait until the official release is available for auto update.

    Mark,

    thanks for the pointer to the above info.

    If my problem is caused by the jQuery error then I’m probably screwed anyway as the them that the site uses is no longer supported so I guess I’ll have to use a different theme with all the work that will entail getting it to fit the site and look half-decent.

    What is the downside in just leaving script-debug enabled?

    Thanks

    Hi,

    Scribt_Debug is setting “true”, but have no effect.

    The following error messages are displayed:

    …/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=4308-201603232
    – Failed to load resource: the server responded with a status of 404 (not Found)

    The resource -file (wp–tinymce.php) is still there and has no security restrictions?!

    Before the 4.5 upgrade all this work fine!

    Can you help me?

    Thanks

    Moderator Steve Stern

    (@sterndata)

    WordPresser, Third Class

    well, that would explain why tinymce isn’t working! Check via FTP to see if that file is there or is missing.

    file is there and with no security-restriction to use.

    I’m having the exact same problem as shunter1976.
    I’m using WP 4.5 and theme twenty ten
    I just updated to 4.5.1 and no fix for the blank visual screen

    In my visual screen when editing a page it shows a word count but nothing in the edit window, i have to click on text then go back to visual to see the words. I can edit in the window but when i go to update nothing happens….and anything new i’ve added is gone.

    I’m not techy at this so scripts ect don’t help me. This started after my last WP udate.

    Well, I’ve updated to 4.5.1 and it’s made no difference – visual editor still doesn’t work (no toolbar, white text on white background and can’t switch to text mode).

    Any ideas what I can do next?

    No help with v 4.5.1

    I have tried also with other themes, but visual editor does not work
    any more!!!
    Window is blank, but the word count is however there.

    Below the full file-address and error message.

    http://www.konkordanttiset.fi/wp-includes/js/tinymce/wp-tinymce.php?c=1&ver=4310-20160418

    Failed to load resource: the server responded with a status of 404 (Not Found)
    post.php:3138 Uncaught ReferenceError: tinymce is not defined

    The file:
    ftp://konko352@ftp.konkordanttiset.fi/public_html/wp-includes/js/tinymce/wp-tinymce.php
    is still there and with no security restrictions (also available);
    with modification date 1.3.2016.
    The other files in that directory are:
    -tiny_mce_popup.js
    -tinymce.min.js
    -tinymce/wp-tinymce.js.gz
    all with mod date 27.4.2016 (upgrade date)

    Resolve the problem, please

    I have avada, latest version of it – both Post and pages in editing mode, are blank. They can appear when going to Visual version of it, but cant do anything in Fusion at all….really not good…..

    I did a manual install of WordPress 4.5.1- the pages and posts are blank in editing mode.
    Visual page editor is blank on posts and pages.
    Cannot switch to text mode.
    text when typed is white on white so page is blank.
    Heres what I’ve tried so far, any tips on how to fix this?

    Tried the latest version of Avada- same issue
    Tried the 2016 theme- same issue.
    Deactivated and deleted all plugins- same issue.
    Tried Safari, Chrome and Firefox- same issue.
    Set SCRIPT- DEBUG, true- same issue

    Finally looked at error console:
    ReferenceError: can’t find variable tinyMCE
    Failed to load resource: 404 error- points at domain/wp-includes/js/timymce/wp-tinymce.php

Viewing 15 replies - 1 through 15 (of 52 total)
  • The topic ‘Visual Editor Not Working in WordPress 4.5’ is closed to new replies.