WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor: Not working in WordPress 3.5

Visual Editor: Not working in WordPress 3.5

  • Hello,

    Recently upgraded to WordPress 3.5 to see that the Visual Editor is not working. Luckily Media uploader is fine and HTML editor only works when set to open a new post.

    Is there any fix to this ASAP? Already added “define(‘SCRIPT_DEBUG’, true);” to WP.Config file but still no luck.

    Would appreciate support! Thank you!

Viewing 15 replies - 1 through 15 (of 24 total)
  • Status???

    I also recently upgraded to version 3.5 and just as Enlive said, my visual editor won’t work either! Although I’m not totally dependent on visual, it’s still a feature that I like to use at times. I thought that it had something to do with TINYMCE but it doesn’t that I can see. I’ve been using WP for years now and have never had this issue. I think it has something to do with 3.5. Furthermore, I didn’t manually upgrade it, I just logged into the dashboard and it was automatically updated! Guess I gotta double check my settings in my hosting panel.

    Please Help!

    visual editor works except cannot insert a link in text with visual or html editor. The icons just don’t function in IE, Chrome, Firefox. I did get more icon functionality with a tinymce plugin, but the problem existed before uploading. Also need suggestions. Using 3.5 My site is still under development but would be happy to share it if that makes a difference.

    Thanks!

    WPyogi

    @wpyogi

    Forum Moderator

    All of you need to start by going through the troubleshooting steps in this thread:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    Then, @757talent and @drgreen, please start your own threads per the forum guidelines. It’s really much better for people trying to help and for you to have one person/topic per thread.

    I took the advise of WPyogi, and this issues is not listed, and none of the generic fixes worked (I did try every one of them).

    I had the exact same issue, and I found a fix.

    Based on information from past forums of people struggling with this on old versions of WordPress, I installed the “Use Google Libraries” plugin, and then activated it (don’t forget to activate it, as it won’t activate automatically after installation).

    It worked!
    Apparently the plug-in “Allows your site to use common javascript libraries from Google’s AJAX Libraries CDN, rather than from WordPress’s own copies.” I’m not so sure about all that, but it fixed my issue with the Visual editor! (Giving me the feeling that my site is held together with my own sloppy coding/template adaptations, duct tape, shoe string and now plugins!)

    Thx Aaron Anfinson for the hint, it saved me!
    My Visual Editor was active but the icons disappeared and the HTML Editor (Text in 3.5) went inactive…
    I tried everything I could find on a number of forums with no success until finally your trick worked!

    I have no idea what javascript or AJAX libraries are but the “Use Google” Libraries plugin did the job.

    Thx again and have a great day!

    The fix that I found that worked on every borked WordPress site on which I tried, is just replace the core WordPress files with fresh WP 3.5 core files. It didn’t work at first, but I just had to clear my browser’s cache and cookies and it worked! Simple.

    [ Commercial link moderated. Please don’t use the support forums to advertise or promote your services ]

    +1 to Aaron’s tip. It worked immediately on my blog to restore the functionality of the visual (and text) editors.

    Thanks Aaron! Instant fix!

    Wow!

    I really struggled with this one for awhile but as promised, it instantly fixed my visual editor! Thanks for the advise Aaron!!!

    You are the MAN!

    Visual and Text Editor Bug also in MU installations: AJAX is busted. “Use Google Libraries” plugin corrected the issue multi user installation.

    Same problem – 3.5 – no Visual Editor – installed Google Library – all better now!!

    Thanks Aaron.

    Yay, it worked for me too! Thanks!!

    I had this same issue and fixed it by doing the following:

    1. Go to Users->”Username” and check the box that says “Disable the visual editor when writing”. Update Profile.
    2. Go to Post or Page and verify that the visual editor is disabled.
    3. Go back to Users and uncheck the box and save.

    After doing that when I went back to the Page/Post I was trying to edit everything was fixed.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Visual Editor: Not working in WordPress 3.5’ is closed to new replies.