WordPress.org

Support

Support » How-To and Troubleshooting » Visual editor not working in posts or pages

Visual editor not working in posts or pages

  • I am using WP 3.2.1 on OSX10.6.8

    When I upgraded to WP3.0 the visual editor in the posts/pages dashboard stopped working. When you open the posts/pages in dashboard the text in the box appears white. If you then select HTML editor the taxt appears, but when you return to the visual editor all is in HTML text.

    I have followed the instructions on other similar threads – I have checked the users/settings (on and off and restarted), I have deactivated all my plug ins and then reactivated them, checking the visual editor along the way.

    I have also added
    define(‘CONCATENATE_SCRIPTS’, false); to the wp-config.php file and re-uploaded this as suggested in another thread ..

    I am pretty novice at this back office stuff (hence needing the visual editor in the first place!!)…

    Any help please

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator kmessinger

    @kmessinger

    Pls upgrade to 3.2.1

    I have been having the same problem for a while now, with absolutely NO concrete fix. Once in a while de-activating a plugin will help, but only temporarily. The problem seems to come back. I have updated several times, and re-installed the update.

    I am also using WP 3.2.1 on OSX 10.6.8

    I thought I had said – I am using 3.2.1 on MAC 10.6.8 – also using firefox 3.6.18

    ALso I have made sure that the javascript is working in firefox and I have cleared the cache and cookies and restarted as suggested on other threads.

    I haven’t found even a temporary solution so far… hoping someone can help?

    Moderator kmessinger

    @kmessinger

    I thought I had said – I am using 3.2.1

    You did, sorry.

    Have you tried a different computer and a different browser?

    Ditto on all this. One bug showing up is entering a blank line. In visual mode it doesn’t show up but it’s in the code. This bug is weird as it depends where you try to insert the new line.

    There also seems to be a problem with live links in the visual mode. Mac osx 10.5.8 Firefox 3.6.19. Not tried it with Safari.

    Bill

    I had the same issue… for it was was my ad blocker that was preventing it from showing. I added my site to the exclusion list and it started working again.

    I was using simple ads manager and i think it thought it was an ad… perhaps…. who knows?

    Hi All,
    well… after a huge amount of searching and trying at least 10 different fixes:

    http://wordpress.org/support/topic/visual-editor-tinymce-not-showing-up-on-292-linux?replies=9

    http://wordpress.org/support/topic/25-visual-editortinymce-problems?replies=97

    http://www.spyontech.com/how-to/missing-your-visual-editor%E2%80%99s-icon-after-upgrading-your-wordpress-here%E2%80%99s-the-solution.htm

    Then – I found elsewhere on this site – as ever a really simple solution seemed to do the trick…

    Check in the General settings of WP dashboard – in the web address/URL lines – for some reason there was an additional colon added into the address – when I removed this and refreshed the cache everything was working again

    Halleluiah!

    @ brightgreenhomes

    I’ve been stuck for a few days and just found your comment about colons. Mine had the same, removed them and all is good.

    Thanks so much for your post.

    MC

    Thanks.

    I had the same problem but my solution was slightly different. THe Site Address URL was complete and OK. However the WordPress address URL was just the relative path form the main site domain. Once I put the full site address in both fields it worked OK (refreshed page as well).

    Oddly it worked fine with IE8 on my WinXP machine. However it would not work in Firefox on the same PC. I tested it on two other PCs running WIndows Vista and the problem was present in both IE9 and Firefox 6

    This is no fun – I really like to use chrome and visual editor but it does not work… Any new realeases with fixes in the works?

    Another strange glitch. When using Firefox to edit thumbnail images to a page do not show on internet explorer.

    here is an example – view in a different browsers. let me know your thoughts – a mystery to me… :

    Current Auctions

    Moderator kmessinger

    @kmessinger

    HCSdesigns:
    You will have better response starting a new thread. Many of us use the “No Replies” link at the bottom of the front page and your post won’t be seen.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Visual editor not working in posts or pages’ is closed to new replies.
Skip to toolbar