Support » How-To and Troubleshooting » Visual Editor not working in 2.2

Visual Editor not working in 2.2

  • Just upgraded to 2.2. When my user is switched to use the visual editor, I get tabs for Visual and Code on the edit pages, but no TinyMCE buttons show up, and the entry is displayed in Code format. Clicking on the tabs does nothing. If I switch to not using the visual editor, everything’s fine.

    I’m using a ton of plugins, but can’t imagine what might be interfering. Any suggestions?

Viewing 15 replies - 1 through 15 (of 28 total)
  • Log out clear your browser’s file and cookie cache, relog in and try again. 🙂

    Did you delete the tinymce folder in wp-includes/js?

    I have cleared cache and cookies, but the edit icons in the editor are still garbled as is the login screen. Are there any other suggestions?


    I am having the same problem of no TinyMCE buttons, everything in HMTL. FireFox Mac’s error console reports that “realtinyMCE is not defined” and similarly “switchEditors is not defined” when I attempt to swich by clicking the Code button.

    Here’s the interesting part: If I submit a comment to a post and then edit it, TinyMCE shows up, in all its useful splendor. I still get the “tinyMCE is not defined” error on line 147 of the page (/wp-admin/comment.php?action=editcomment&c=2), but at least it is functional.

    I am also missing the TinyMCE editor for the Visual tab. It almost appears that it might be hidden underneath the Text Box. In any event, it seems to work in IE7, but not Firefox.

    I am running Firefox on Windows XP.

    If you use the My Link Order, My Category Order or My Page Order plugins, there are new updates to the 2.1.3 versions that fix this problem.

    That makes sense. I have the My Page Order plugin installed. Thanks for the heads up.

    Hm. My problems show up on a new, bare bones installation, so it’s not likely to be a plug-in problem. The TinyMCE buttons do show for Comments, but they enter HTML markup into the text area, not rich text. In addition, my RSS feeds were broken–the first line of the XML doc was blank, with the XML header on the second line.

    In my installation there are several problems. Many seem to be related to how JavaScripts are loading and executing. I dialed back to 2.0.9 (keeping my 2.2 installation to see if I can eventually debug everything), where everything just works.

    Could be an issue with what hosting services support, too, though the PHP and MySQL installations on my host are very current. There are quite a few threads on this and simlar problems.

    I am still having problems as follows:

    Everything in the editor seems to work on IE. The login page image background is garbled.

    On Safari, the Visual/Code tabs are missing and it comes up in Code mode. The login page image background is garbled.

    In Firefox, the images for some of the editor buttons are not getting into the page (not there in the page info). (“More” through “help” are there; they live in a different directory than the missing ones—though the directories seem clean.) The introductory login in page has a garbled looking background.

    So it seems like a combination of problems.

    The good news is that as long as I can remember what’s what, I can work; but it’s not pretty. Still searching for a repair.


    I continue to experiment with WP 2.2, to no joy. Setting .js and .php file permissions to 755 has not helped (this was a solution for someone else, so it seemed worth a try).

    The fundamental issue appear to be that not all JavaScripts are loading or at least not loading at certain critical points.

    The visual editor has never worked for me. I just turn it off and don’t use it. I wish that was the default, that it’s off unless you choose to turn it on.

    In Firefox – no visual text editor TinyMCE- or edit tools in code view.
    In Safari- I get no tabs- but do see a row of buttons- but in code view.
    Both are on a Mac. No plugins, default theme.
    This was working in WP 2.1.2
    I’m nervous about changing any other installs now.
    On a PC- with Firefox and explorer- nothing.
    It’s not turned off in users.
    Any suggestions?

    Hope this helps- I cleared cache and cookies. Used control F5 (on a mac) to force it- again after doing it in Firefoxes prefs.
    Then hit refresh- while holding shift key.
    Problem solved.

    I have upgraded to WP 2.2 hoping I would get the rich editor this time but pb persists. When I check the rich editor at options, I get two tabs (visual and code) in the write area but nothing more.
    When I uncheck the rich text option, I get the code tab only with some of the functionalities but not all.
    I have tried the cache suggestion but nothing happened.

    Ok, so now I join the queue… just did the install of advanced TinyMCE, whatever as per instructions… now have only 2 buttons showing on write new post editor, the Visual and code!! lost what I had b4, at least some menu (alt+shift+V) Like others, using Wp v2.2 + Firefox… hmmm not a good day for many it seems. Any real suggestions or help from a tech would be great.

    PS: just did a login with IE… with some falty starts and stops… the editor loaded with the damn thing looking like its suppose to… so what gives? anyone? re the Firefox clanger? IE’s a hog… can’t stand the beast…

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘Visual Editor not working in 2.2’ is closed to new replies.