WordPress.org

Support

Support » How-To and Troubleshooting » Visual editor not working (for post or page)

Visual editor not working (for post or page)

  • I’ve done two things today that might have affected this:

    1. Installed (and then uninstalled) the google file embedder plug-in for WP

    2. update BPS security plug-in.

    I’ve now deactivated all my plug-in’s but still can’t use the visual editor for posts or pages. Also change edit the permalinks. Everything else seems fine.

    Any ideas please – or can you refer me to a WP programmer who could fix this for me as I’m not a techie. Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • If you want to hire someone, I would suggest finding someone local. If that fails, there is always jobs.wordpress.net.

    Did you try switching to the default 2012 theme or checking to see if your theme has an update?

    It’s not working on my new fresh install of 3.5 either. So I doubt it’s anything you’ve done.

    It works flawlessly on my new fresh install of 3.5.

    That is very strange that the visual editor works for one person, but for so many others it does not. I have perhaps 25 WordPress sites, all different themes, different plug ins, but after upgrading to WP 3.5 none of the them have a full compliment of editing tools as they previously did. I am stuck in the Text editing section and do not have a Visual tab.

    I found a fix for my sites in which the Visual Editor was not showing.

    I had been working on a posting and had the Visual Editor. I went back to the dashboard and saw the notice that there was a new WP upgrade so I upgraded. Immediately after upgrading, I went back to the same post and my Visual Editor was gone and I was stuck in the Text mode.

    Knowing the there was checkbox in my profile to disable the Visual Editor, I went there and lo and behold the box was checked.

    Apparently when I upgraded to WP3.5 it reset all of my users to “Disable the visual editor when writing”. I simply went to the profile of each user and unchecked the box at the top of each user’s page and voila the problem was resolved.

    The visual mode is not working after 3.5 update. All posts are stuck in text mode. I tried the profile “disable visual editor” button. And I’ve deactivated all plugins.

    Any other suggestions?

    I can’t click the visual editor either. Tried all the above fixes, nothing is working.

    WPyogi

    @wpyogi

    Forum Moderator

    @decroce and Mike – per the forum guidelines, please start your own threads and start reading through the troubleshooting post here:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Visual editor not working (for post or page)’ is closed to new replies.
Skip to toolbar