WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor not working after upgrading to WP 2.6.1

Visual Editor not working after upgrading to WP 2.6.1

  • I recently upgraded to WordPress 2.6.1 and have run into a couple of problems. One of them is that my Visual Editor is no longer working – I can only write and edit posts in HTML view. I’ve searched through the forums here and tried everything that past posts have suggested – clearing the cache, replacing the wp_includes and wp_admin directories, changing the compression in the tiny_mce_config.php file to ‘false’, installing and activating the TinyMCE Advanced plug-in – but so far nothing has worked. Can anyone here help? Thanks!

    Deb (Mom of 3 Girls)

Viewing 11 replies - 1 through 11 (of 11 total)
  • If you are trying to edit in Firefox, switch to Internet Explorer. I know that sounds crazy, but that’s what worked for me. My WP is on a Windows site and so maybe it only plays nice with the Windows browser.

    Nope – it’s the same way in IE (7) too. Nothing I’ve tried so far has worked… My site is http://www.momof3girls.net if that helps anyone.

    I had this problem, the Visual/HTML tabs were missing and the editor was stuck in Visual. I went into my user profile and unchecked the Use the visual editor when writing checkbox. And then it started working again. So I suggest trying to either check it or uncheck it and see if that does anything.

    Hey, that trick from rmmcclay worked for me. I’m using 2.6.2 and the visual editor wouldn’t work for me using IE 7, but I went into my profile, unchecked “use visual editor, etc.” and as soon as I went back to “write” it worked. thanks!!!

    CRAP! After I restarted IE 7, the visual editor didn’t work again. What is the problem???

    Same here – this really stinks –

    whooami

    @whooami

    Member

    i recently troubleshooted this on someone’s install, went through all the various fixes .. only to find that it was a permissions issue.

    Make sure that you can load tiny_mce_config.php in your browser. You can check this by pulling up you site and then adding this to it:

    /wp-includes/js/tinymce/tiny_mce_config.php

    that file should load up and look just like a text file.

    If it doesnt, make sure that its chmod 644 and that its parent directory and wp-includes are both 755 and NOT 777.

    Have a look at http://wordpress.org/support/topic/165449?replies=85

    almost certainly – wp-content/uploads/js_cache has an old dated file locked in there – check the date using ftp

    That old cached file will be the problem and needs to be cleared.

    As per step 4 – I had a look
    http://www.momof3girls.net/wp-includes/js/tinymce/tiny_mce_config.php

    loads Ok – did the ctl / clear cache so maybe it will be OK?

    when wp-includes/js/tinymce/tiny_mce_config.php shows
    Warning: Cannot modify header information – headers already sent by
    i just make sure end of the file :wp-config.php
    right after ?> have no space and enter. just ?> this helps me

    @whooami – Your suggestion worked like a dream. Thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Visual Editor not working after upgrading to WP 2.6.1’ is closed to new replies.
Skip to toolbar