Support » Fixing WordPress » Visual Editor Not Working after Upgrade to 4.0

Viewing 15 replies - 16 through 30 (of 48 total)
  • Ffgrf

    (@grouchyturtle)

    My problem as well as a lot of others turned out to be the Comprehensive Google Maps plugin.

    Hi Mike

    Thanks for the advice, i have deactivated all the plugins and have tested with default themes as well nothing is working. even tried the below suggestions by
    lavistayk. but nothing has solved my problem.
    1 Try replacing
    /wp-includes/js/tinymce/ with fresh copy

    if didn’t work

    2. try to edit wp-config.php and add
    define(‘CONCATENATE_SCRIPTS’, false);

    Manjusavanth, if you test with just WordPress and a WP default theme, and no plugins, and the Visual Editor is still broken, there has to be a problem with the WordPress installation itself.

    I think the next step (with all plugins deactivated and default theme activated) is to re-upload the full set of WordPress files. I’d recreate wp-config.php from scratch, in case it was somehow corrupted.

    Then see if the Visual Editor works, which it should. Then you can activate your theme, and check the Visual Editor. Then one plugin, and check again, etc.

    Hi, this is how I solved the issue. But first, in my case, seems like the editor that came with the theme simply doesnt work… I’m using a theme for a old WP version.

    1. As lavistayk said, I edited wp-config.php and added define(‘CONCATENATE_SCRIPTS’, false);

    With that the toggle between Text and Visual worked. But the toolbar in Visual mode and the initial content in the editor in Text mode were not visible. So…

    2. I added this to the end of the string in wp-includes/css/editor.min.css

    .mce-stack-layout{margin-top:20px}.wp-editor-container textarea.wp-editor-area{margin-top:67px;}

    Is working now.

    Hope it helps,
    Pablo

    Hello,

    I tried everything, ALL, the advices above,with no success.
    So, after several attempts, I gived up and I downgrade the wordpress, to ver.3.9.2 and now,all works perfect.

    [ Signature moderated ]

    “yiuannisdesp”, so the site didn’t work with ONLY WordPress 4.0 installed, nothing else? We know that WordPress 4.0 works by itself, so there had to be something wrong on your end – either the theme, a plugin, corrupted WP files, or a problem with the server.

    Hello again,

    as I said, I tryed everything,
    Deactivated, ALL the plugins,
    Deactivated the Theme and Activate the twentyfourteen theme … Nothing at all.
    I went one step more, and I delete all the plugins… Nothing again.
    I really don’t know what cause this issue, but all external back ends code, ( plugins – Themes etc) was deactivated and also deleted, and after all this the problem continues..
    I will try again to make the installation with new fresh copy, and to start from begging.

    I’m actually having the same exact problem. I’ve setup a test site with a clean install of WP4.0 and nothing else installed (literally no plugins or themes) and it behaves as described above.

    I’m happy to create an account for support to login and take a peak if you’d like to see if happening for yourselves.

    This, by the way, is running on a Windows host. I’d be curious to know if everyone else having this issue is on a Windows host.

    Let me know how I can help… this is intensely frustrating.

    Dan

    ..and yes, I’ve tried downloading a fresh copy of the zip file from WP. Same behavior.

    Dan

    I have the same problem in a new wordpress instalation, without any plugin active and the default template active. What is hapening? Have the wordpress guru another solution?

    The console return this message that I believe is the cause of the problem:

    GET http://www.dominio.com.br/blog/wp-includes/js/tinymce/tinymce.min.js?ver=4104-20140822 post.php?post=1&action=edit:1936
    Resource interpreted as Script but transferred with MIME type text/html: “http://www.dominio.com.br/blog/wp-includes/js/tinymce/plugins/compat3x/plugin.min.js?ver=4104-20140822”. post.php?post=1&action=edit:1937

    Hi all, here the same problem. I have seen that at post editor screen I have a lot of javascript errors, all them ‘TypeError: HomeMader(…) is not a function‘.
    If I disable all plugins and select a default instaled theme I get the same error but only once.

    Maybe this can help anybody to help us to solve it?

    It seems that my js files are hacked. There is a function in all them that try to write an iframe.
    It’s strange because before I update wordpress and plugin versions I hadn’t that code and updating it from bakcoffice they are corrupted!

    I will try to remove that code and try again.

    I have experienced exact same thing as JordiJV.. We discovered a malware code at the top of over 190 JS files on my site.. which is this iFrame thingy. It’s definitely happened WITH the 4.0 installation, and I’m sure this is what’s interfering with functions of the visual editor (which are heavily JS reliant).

    There is this blog post that discusses this malware: http://blog.lux-medien.com/2014/09/how-to-fix-actermoto-and-its-edited-javascript-files/

    If someone find how the malware is created please tell us to check our installations. I have removed malware code, it worked (visual editor), but suddenly malware code was inserted again.

    I’m searching how it is done.

Viewing 15 replies - 16 through 30 (of 48 total)
  • The topic ‘Visual Editor Not Working after Upgrade to 4.0’ is closed to new replies.