Support » Fixing WordPress » Visual Editor not working after upgrade to 2.8

  • Hi,

    After upgrading to 2.8 my edit window is behaving very strangely. None of the buttons for the visual editor ever load and when I try to edit an old post, none of the content is visible.

    Here’s a screen snap.

    Any ideas?

    <img src=””/>

Viewing 15 replies - 1 through 15 (of 20 total)
  • BTW, this happens in both Firefox and Internet Explorer.

    I am having the same problem on both of my blogs that I upgraded to 2.8. 🙁 Would love a solution.

    Andrew Ozz


    WordPress Dev

    Here are some troubleshooting steps

    I tried all of that. Nothing worked. It’s not a plugin conflict (I de-activated all).

    exact issue – tried reinstall, plugin deactivate, browser clear, and no button and no content shows…site itself is fine – anyone?

    Same issue here though it only happens on some old posts – really old posts and any new posts are fine. Pages are also fine. I recreated the posts that weren’t working and all is fine now.

    same deal here, I dont know if its because of shared hosting or somthing in that context, but what I have found is that
    2.7.1 works fine on my shared hosting solution.
    2.8.2 visual editor doesnt work.
    2.8.3 visual editor doesnt work.

    This is based on a new DB in each installation instance and only editing the default ‘about’ page.

    There is some, apparently common, configuration issue or a ligit bug in the 2.8.2/3 distros.

    hopefully this will help someone find a real solution or at least advise on some fix.

    I’m having a strange, related problem. The visual editor shows HTML when I access from home, behind an AirPort Extreme router (tested on multiple browsers and both OS X and Win 7).


    When I access from another Internet connection (I’m currently tethered through my iPhone), the visual editor works perfectly!

    So it would seem that there is something in my AirPort Extreme settings that is “blocking” the TinyMCE stuff. Any clues on how to solve this?

    Sometimes after update some settings are not set.

    Make sure that first, you uploaded all files.
    Second, that under your profile preferences you do not have the “disable the visual editor when writing” checked.

    Good luck

    If it always doesn’t work, go to Users -> Edit Profile, then check ‘Disable the visual editor when writing’, then update profile. Now go back and uncheck ‘Disable the visual editor when writing’, and resave your settings.

    This worked for Catherine under 2.8.5. I’ve never had this problem myself.



    I am having the same problem with the visual editor and I have tried EVERY suggestion I have found and nothing has worked…. Is there anyone who has something new (that will work)




    I’m also having the same problem 🙁



    Ohh me too. I have tried to use the standard themes thinking it was my custom themes causing the problem. I also realised that you link to edit the permalink on the post does not work too. I think it’s some java script causing the issue.

    Has anyone found a solution yet?




    Has the solution for those still search the web for solution.

    I am having the same issue. I haven’t updated anything or made any changes in the past few weeks. Last time I setup the site it was working fine, not all of a sudden it is not working and I haven’t changed hosts or anything drastic.

    But when I goto my tinyMCE link I get a 500 Internal Server Error. I have tried everything, I even had a backup that was 3 weeks old from when I first started setting up the site and restored that and the Visual Editor still doesn’t work. I attached a screen shot. This is kind of a pain for me since I am building this site for a client who needs it as easy as possible. I tried upgrading too in hopes it would correct it, but nothing. 🙁

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Visual Editor not working after upgrade to 2.8’ is closed to new replies.