Support » Fixing WordPress » Visual Editor Not Working After 3.3 Upgrade

  • My visual editor tab is not working on two WP installations. I can see the Visual and HTML tabs but only the HTML tab / pane is active. I can’t switch to the Visual tab.

    The first time I tried to edit a post the editor was on the Visual tab but the pane was blank except for some red underlines for misspelled words. I switched to the HTML tab to see what was happening and now I can’t get back to Visual tab.

    I’ve deactivated all plugins and switched to the twentyeleven theme, with no plugins activated. No difference.

    Not sure what else to do. Suggestions?

Viewing 15 replies - 106 through 120 (of 121 total)
  • This is total crap! I have the same problem and nothing works, im gonna sue all people answering solution, I just wanna die now.

    This is a wind-up, yes?

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Or is it a plaintive cry for help?

    Threatening to sue anyone who has posted a solution is hardly going to elicit further help.

    Realized that IE does not have this problem, only Google Chrome. Once installed “Use Google Library”, everything is fixed!

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    This is total crap! I have the same problem and nothing works, im gonna sue all people answering solution, I just wanna die now

    Rest in peace.

    Hi, Even I faced the same problem. So there are 3 checks you need to do.

    1. Disable all plugins and check. if works, activate one by one. If not step-2.

    2. Go to your hosting site, click on ftp and you will find the file called “wp-config.php”. download the file and add the following line in that, save it and upload it back.

    the line : define(‘CONCATENATE_SCRIPTS’, false );

    If works, fine, if not step-3

    3. ursite/wp-admin and access the dash board. click on users. select the username you are trying to post. there is an option called “deactivate visual editor while posting“. make sure its unchecked.

    The above options should work. if not there is some problem. may be u can reload the theme and check. Cheers !

    http://www.ivfox.com

    I was frustrated with the same issue and found that dotwebs’ solution of….

    “Go to ‘Users’ click on ‘admin’ make sure that ‘Disable the visual editor when writing’ is unchecked”

    ….was the answer to my frustration.

    Thanks.

    This has recently happened to a site of mine which needs to go to a client tomorrow. 🙁

    Anyway, I read all the messages in this thread. Downloaded the Google Libraries – no fix. I then disabled all plugins – no fix. Changed theme to Twenty Eleven – no fix. I then checked other Javascript settings etc – no fix.

    So, I hovered over Dashboard and chose ‘Updates’. I then chose ‘Reinstall now’. The version I am running is 3.4.2.

    My editors now work. I also noticed there was a bug with featured images section too.

    Hope this helps someone.

    Hey everyone.

    I have solved my issue. None of these solutions worked for me. I found a media file in ‘Media’ That was corrupt. I deleted it, now it all works.

    http://www.diigo.com/item/image/27qt1/pnta?size=o

    Solutions:
    http://support.goodlayers.com/editorpage-option-is-not-showing/

    Hope everyone works their issues out.

    I had a new install of 3.4.1 and was experiencing this problem. Tried all recommended fixes.

    What worked for me was to re-install WordPress from the Updates page. It said that I did not require any updates, but I did it anyway using the automatic update.

    The update took about 20 seconds and it came back up with the HTML/visual editors working and toggling fine.

    Disable magic_quotes_runtime. This seems to be causing the problem because it escapes the Javascript code and therefore creates syntax errors in the js Code.

    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off

    Step by step here

    Google Library update worked for me, not the ideal situation but at least it’s resolved.
    Thanks folks

    For me it was the plugin “Empty Paragraph in TinyMCE editor” which was causing the problem…

    Great to all who found the answer… me still looking 🙁

    I have done ALL and above, and i am done to this situation:

    did a local COMPLETE FRESH install, so downloaded the latest version 3.4.2
    Created an EMPTY db,
    installed WP
    opened the ‘new-post’ screen… and??? no VISUAL editor

    So, a complete fresh install, and STILL nothing? pfff…

    i then started to downgrade,
    3.4.1 nothing
    3.3.1 nothing
    3.3.0 nothing
    3.2.1 BINGO! “suddenly” the visual editor is back again. Happy, but actually not.

    Upgrading again got 3.3.0 and again nothing…

    So, now i am really in a weird situation. I need to start using the old version?

    What is the difference?

    Please advice.

    And again, this is a clean install. no plugins installed, no themes etc…

Viewing 15 replies - 106 through 120 (of 121 total)
  • The topic ‘Visual Editor Not Working After 3.3 Upgrade’ is closed to new replies.