Support » Fixing WordPress » Visual Editor Not Working After 3.3 Upgrade

  • My visual editor tab is not working on two WP installations. I can see the Visual and HTML tabs but only the HTML tab / pane is active. I can’t switch to the Visual tab.

    The first time I tried to edit a post the editor was on the Visual tab but the pane was blank except for some red underlines for misspelled words. I switched to the HTML tab to see what was happening and now I can’t get back to Visual tab.

    I’ve deactivated all plugins and switched to the twentyeleven theme, with no plugins activated. No difference.

    Not sure what else to do. Suggestions?

Viewing 15 replies - 61 through 75 (of 121 total)
  • bjobson,

    I am in the same boat. None of this worked for me. This is a new install I am having trouble with. Older installs that I have upgraded to the current version are fine. I can only conclude that there is a difference between the new version and the auto upgrade version.

    🙁

    I’m using the latest version of wp and yesterday I encountered this problem, so today it was resolve my my host CSA. What he did is he went into my
    1. admin area then
    2. users then
    3. your profile
    4. on my profile area he uncheck the box at the top of the page which says disable the visual editor when writing.

    and now its working fine. I hope this will help you.

    len7288
    http://www.healthandbeautypages.com

    No good Len7288, I’m afraid.The box was unchecked anyway! Maybe it works for others.

    In wp dashboard,try going to users, then profile, make sure the disable visual tab when writing is not checked.

    It seems like if any of the above mentioned suggestions doesn’t work you have no option left than to downgrade. It’s fascinating how it affects so many people, but nobody was able so far to figure out what the actual reason for this problem is, or even, if it’s only one issue or a handful of reasons

    Everything is working for me now again. What actually helped was the following change in the config file:

    define(‘WP_MEMORY_LIMIT’, ‘128M’);

    Yes , I have same problem but I just switch my theme to the default and back to my theme any visual editor back online.
    Thank you !!

    With 3.3.1 installed. Have Tiny MCE Advanced plugin installed and active

    Visual Editor was not working in Chrome or Firefox but was working in IE9.

    Tried deactivating all plugins – no difference.

    Installed and activated Google Libraries plugin, Visual Editor now functioning in all three browsers.

    Thanks to everyone for all the suggestions, esp re Google Libraries plugin!

    The following is how I fixed a site with the same issue, however this required digging into the database. Not for the ‘faint of heart’ … proceed with caution.

    I resolved this by viewing errors in a web inspector. Found there was some issues with the domain name pointing to an old host (this site was also migrated to a new host for this 3.3.1 upgrade). I search the database wp_options values for the incorrect domain name and changed them all to the correct domain name and all is working perfectly. I hope this helps someone.

    Navigate to Users => All Users => admin => untick the “Disable the visual editor when writing” box.

    That helped me.

    I’ve had good and bad experiences since downgrading. The good news is that the visual editor now works. The bad news is that it works when it wants to. The editor flips back and forth from working to not working. This is the best I can get so far. Nothing else even got me this far.

    i follow all suggestion..and it’s work in almost all browser but no with firefox(firefox version 11).. i test with firefox version 3.6 and its work..i don’t know how to fix this(browser problem ???)

    I’ve been having the same problem on and off for the last week or so, but it has been leaving of it’s own accord.

    Now however it’s stuck for hours and I’m unable to update my site. None of the solutions here have worked for me – and I’ve tried every single one, bar downgrading to an earlier version of WP.

    Hey guys. I was having the exact same problem and literally tried everything. – including the downgrade and re-install, google libraries plugin, new wp-includes, clear cache …
    none of it worked.

    SO I deleted my .htaccess file and it’s now working!!!!!!!!!!!!
    I am soo happy! SO delete your .htaccess and see if that fixes it!

    It should be in your cpanel public_html
    Make sure that the “Show hidden files (dotfiles)” is ticked.

    Then delete and the problem is fixed (at least, it was for me!)

    I have two desktops and one laptop. I’ve narrowed this “no visual editor” to just one desktop. I use IE8 solely all around. So, on the one desktop, I’ve followed all the “tick this on and off”, clear cache, reload browser with F5, go into edit/F5 come back in suggestions. Kill IE and use XP Pro’s Control Panel Internet Options to clear history, cache and cookies. Only on this one machine, it’s broken. It’s unfortunate as it’s my one main machine I use for this. I do not have server level access so no going to take out hta.access.

    Question please: Are we able to use another IDE like a Dreamweaver to edit our WP blogs? Anyone tried that? That would get me out of this silliness and on to more important things.

    H

Viewing 15 replies - 61 through 75 (of 121 total)
  • The topic ‘Visual Editor Not Working After 3.3 Upgrade’ is closed to new replies.