[closed] Visual Editor Not Working After 3.3 Upgrade (122 posts)

  1. MissOh
    Posted 4 years ago #

    After trawling this forum for ages looking for an answer, I found one via my hosting provider 123Reg and it worked for me. I doubt it will solve all problems, but I'm sharing just in case.

    1. In your WP admin, go to Settings - > General
    2. Delete any colons in the URL for your site except the one that should be in the usual address. e.g. I had to change "http://website:/home" to "http://website/home"
    3. Log back into wordpress when it kicks you out.
    4. Visual editor should be working.

    Please note, I had also disabled all plugins, installed the google libraries and changed the theme to no success. By the time this solution worked for me, I had my plugins and theme back on with just the addition of the Google library plugin.

    Good luck to others.

  2. janclifford
    Posted 4 years ago #

    You may have already solved this problem but this is what I did to easily get my visual editor back. On my first site I went to a post, clicked on the visual editor, clicked in the writing area - pressed F5 and voila the visual editor appeared.

    A couple of weeks later I went to my second site and tried the same thing but it did not work! Eventually I opened a new post, clicked on the visual editor, clicked on the writing area then hit F5 and once again it restored my visual editor. Thank you lewatson - I think it was your post that I read a couple of weeks ago but I decided to try the F5 button without changing the theme.

  3. RenaR
    Posted 4 years ago #

    I've tried all the solutions that you've suggested in this thread, but nothing has helped. If anyone can help me out, I would really appreciate it!

  4. janclifford
    Posted 4 years ago #

    The only other thing that I found before I fixed the problem was to download WP version 3.3 and manually upload it again. Hope you get there, you realize how much you rely on it once you lose it!!

  5. Domcole
    Posted 4 years ago #

    Very definitely not a resolved issue - tried everything mentioned above and then decided to press the nuke it button and restore the previous version of WP. Lack of visual editor something of an upgrade killer for me.

  6. tiagocgms
    Posted 4 years ago #

    Em Ingles

    I was friends with the same problem.
    so I decided
    I downloaded a new copy of wordpress 3.3 on my computer.
    and went up only the folder wp-admin and wp-includes, erasing From my blog / site via ftp

    note: it's just a manual update. worked perfectly here, do not Forget to clean the cookie to use

    Sorry do not speak English I'm using google translator

    Em Pt-BR
    Amigos eu estava com o mesmo Problema.
    resolvi assim
    baixei uma nova copia do wordpress 3.3 no meu computador.
    e subi apenas a pasta wp-admin e wp-includes , apagando as Do meu Blog/site via ftp

    obs: é apenas uma atualização manual. aqui funcionou perfeitamente,não esqueção de limpar os coockie

    Desculpe não falo ingles estou usando o google tradutor

  7. RenaR
    Posted 4 years ago #

    I downgraded to 3.2.1, and now everything is working again. I think that I'll wait for 3.4 to try upgrading again. It's way too much of a headache to try something that might work when I have the editor working right now. I hope this is resolved in the next release.

  8. thenatureschool.net
    Posted 4 years ago #

    I have tried every work around that has been suggested here and on other pages without any success. In fact, this issue has cost me an entire day and a great deal of energy.

    Please, someone fix this issue.

    I am not computer savvy. I find fighting with work arounds that don't work to be exhausting to the point that it affects my ability to do anything else. Is this a personal problem? Yes. Am I the only one with this issue? No, not by a long shot.

    I realize that a lot of the people who work on the site are volunteers. But, visual vs html is such a fundamental tool for us non-technical people that I find it flabbergasting that you would roll out a version with that big a flaw.

    This is why I never update anything unless I absolutely have to. I really regret the fact that I took the risk and updated to this version.

    Now, I have to spend I don't know how long trying to figure out how to roll back to the earlier version. Further more, you have lost a good bit of my trust in my ability to install future updates without issue.

    I am using both firefox and safari and none of the work arounds worked in either browser.

  9. jjackson@makeitcomplete.com
    Posted 4 years ago #

    MissOh's solution fixed me up.

  10. avinews
    Posted 4 years ago #

    Just for those who do not get the damned thing working...

    Update your JAVA!! should be updated or you will keep pulling your hairs out!

  11. avinews
    Posted 4 years ago #

    To be correct,

    I installed Google Libary, AND after many hours... Updated JAVA

    If you think about it its logical.. it's a JAVA problem, after the update I didn't even clear my chache .. just worked imediatly

  12. Pedro
    Posted 4 years ago #

    Hi all,

    I had the same issue and after trying everything in this thread, I realized that it was the FBLike plugin to crash the Visual Editor. After deactivating it, everything works just fine, even without "Use Google Libraries" plugin.

    Trying to install FBLike on a fresh WP install didn't crash the editor, so there must be some kind of issue with other plugins or with the theme. I'll post future updates on this directly on the plugin page.

    I hope this helps someone else besides me.

  13. sparklesperson
    Posted 4 years ago #

    Nope, nothing working here. Nothing explains why the installations would work for nearly a week - several days anyway - and then suddenly all go down.

    At first I was able to go with IE - I normaly use FF - but now nothing works. No plugins added or removed help. I updated my Java. I've refreshed till I'm blue in the face. Nothing.

    And the new 3.3.1 update? No idea what that fixes. Does it fix this?

  14. lernerleben
    Posted 4 years ago #

    Does anyone know if the Visual Editor problem has been added as a ticket?

    It most definitely hasn't been fixed for the 3.3.1 update.

  15. Anas
    Posted 4 years ago #

    Solution :
    Step 1 : Change the theme
    Step 2 : Clear the cache
    Step 3 : Go to your editor
    Step 4 : Change to 'HTML'
    Step 5 : Change to " Visual Editor'
    Step 6 : Now you can find the Visual Editor Options
    Step 7 : Change to your original theme

    If Problem Persists, Add ' WP-Super Edit / Use Google Library ' Plugins, then check it. :)

  16. lernerleben
    Posted 4 years ago #

    Cheers Anas,

    Surprisingly enough, it worked.

    However, nothing made any difference until I did the install Google libraries step. Super Edit didn't make a difference and I have uninstalled it and it still works. Might however reinstall Super Edit because it looks good.

    I am trying to figure out now why it worked because I had followed the "Use Google libraries" tip before and it didn't work. I think the mistake I made in the past was that I didn't want to switch theme because I was afraid I would lose all my plugin/widget settings. I forgot that the latest version of WP remembers the previous settings.

    Also, I didn't just clear my cache but reset all of settings in browser. Lost all stored passwords, etc, but it was worth it.

    This result works in my test site (which is a mirror of my normal site). Let's see if I get the same result in my normal site.

  17. lernerleben
    Posted 4 years ago #

    By the way, it also solved another problem, namely the "out of memory" problem for incoming links and WordPress blog. It must have been Google libraries!

  18. charricky
    Posted 4 years ago #

    Thanks @psmits!!! You're the man!

  19. lernerleben
    Posted 4 years ago #

    @ Anas,

    Had a little bit of a problem when tried to fix my site. The language set in my wp-config is German. Your solution only works if the define language command is set to English. Attempts, for example, to install WP Super Edit result in an error message.

    If I set the define to English, then it works a dream and even when I remove WP SE and Google libraries, it still works. But, the moment I change the language to German, it's back to where it was.

    As my language setting effects contact forms and newsletters, etc, I can't leave my language as English.

    I think your solution has identified the main problem. But, obviously, it's something that WordPress programmers need to sort out.

  20. lernerleben
    Posted 4 years ago #

    @ Anas

    Update: It is actually only "Use Google Libraries" that works. When deactivated, the error returns. This solution only works when language is defined as English.

  21. davemac
    Posted 4 years ago #

    I had the same issue, but setting the correct permissions on the wp-admin and wp-includes folder fixed it for me:

    find . -type d -exec chmod 755 {} \;
    find . -type f -exec chmod 644 {} \;

  22. davidbick01
    Posted 4 years ago #

    On the language issue, I have the same sort of problem as lernerleben. Our blog is in French, and since 3.3 things like "More" and "Continue reading" are all in English despite having the fr version installed. I'm not sure where one goes to rectify this. I've not installed 3.3.1 on the basis "once bitten twice shy".

  23. bjobson
    Posted 4 years ago #

    I've tried everything suggested here. Still no luck with this issue. How do I downgrade to the last working version?

  24. daisy8
    Posted 4 years ago #


    I'm glad to have found this thread. I've had most of the problems talked about here and have found most of the solutions here too.

    (Updated to twenty-eleven, added Google library plugin, updated Java, used etc). Image loader, html box and visual, all now work.

    What doesn't is the Menu setting.

    The header menu bar shows 35 pages, I want it to show about 8. I have used the menu settings to do this, but it still shows 35 pages. I deleted the old menu - with 8 pages, and re-set it to 8 pages. It still doesn't work.

    Any ideas?

    With thanks

  25. daisy8
    Posted 4 years ago #

    Have got it working! I cleared my browser cache twice, then under the 'theme locations' primary menu I chose the named menu I'd already created and saved it. I then 'saved' the created menu twice, one after each other.

    That fixed the problem.

  26. daisy8
    Posted 4 years ago #

    Hi Bjobson,

    The plugin Addthis is not compatible with 3.3.1 yet. Deleting it entirely solved a main problem for me.

  27. daisy8
    Posted 4 years ago #

    Hi All,

    I've just found this thread:


    It appears it wasn't a problem after all.

  28. bjobson
    Posted 4 years ago #

    So for now I've seemed to have solved my problem. I ended up downgrading to version 3.2.1. From now on I'll wait to update.

  29. Joan1911
    Posted 4 years ago #

    Moved from 3.2.1 and followed what psmits suggested...

    "I was able to fix the problem by using the following recommendations mentioned above:

    1. Install "use Google Libraries" plugin.
    2. Activate "Twenty Eleven" Theme.
    3. Clear browser cache.
    4. try the tabs, and everything worked.
    5. Switch back to my usual theme, everything still worked!

    I hope this helps."

    Yup thanks that worked for me - Thank You.

  30. ihavetoomany
    Posted 4 years ago #

    Works for Admin, fails for Editor...

Topic Closed

This topic has been closed to new replies.

About this Topic