• My visual editor tab is not working on two WP installations. I can see the Visual and HTML tabs but only the HTML tab / pane is active. I can’t switch to the Visual tab.

    The first time I tried to edit a post the editor was on the Visual tab but the pane was blank except for some red underlines for misspelled words. I switched to the HTML tab to see what was happening and now I can’t get back to Visual tab.

    I’ve deactivated all plugins and switched to the twentyeleven theme, with no plugins activated. No difference.

    Not sure what else to do. Suggestions?

Viewing 15 replies - 1 through 15 (of 121 total)
  • My I join your thread? I am having the same issue.

    Thread Starter lewatson


    I don’t have any buttons in the HTML pane at all.

    Same issue. The txt is in the window for me but it is all white. If I highlight the field I can see the HTML where the editor should be. The HTML Tab is grayed out and the Visual is there, but none of them do anything.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Advisor and Activist

    Make sure you’ve read the entire Master List post and the New Features in 3.3 Post.

    Go to your own install’s about page – http://domain.com/wp-admin/about.php – to see what’s new.

    And then make sure you’ve tried…

    – flushing any caching plugins you might be running, as well as server and/or browser caches.

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    – switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    – manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    Thread Starter lewatson


    I was able to get me visual editor back with the following:

    1) Switch theme to Twenty Eleven
    2) Edit a post (displays as white pane with red underlines)
    3) Clear cache (press F5)

    Visual editor, tabs and buttons returned at this point in edit post mode.

    4) Switch back to original theme.
    5) Edit post. (all returns to normal, do the happy dance!)

    I did not have to deactivate the plugins for this to work.

    @ipstenu, I have followed all the steps to included a manual reinstall. I still have the same issue. I switched to the Twenty-Eleven theme, edit a post, clear cahce, and still the same, no Visual editor.

    I even removed the one Google Chrome plug-in I had that was reported as giving issues.

    Any other suggestions sir?

    Thank you very much for your assistance.


    @kitllc Do you have IE9? If so, try compatibility mode.

    @robthecomputerguy I followed the advice of another thread and installed “Use Google Libraries” plug-in. Problem was then solved.

    Thank you for your assistance.


    the ‘use Google Libraries’ plugin restored the visual editor. but lightboxes still not working.

    so thanks for that hint.

    Add me to the list of people who’s editor when crazy after upgrading to 3.3. It seemed to work for like a day than then it started getting worse and worse. I can’t see the visual tab and I have having other problems with both Posts and Pages.

    I tried changing themes, I tried disabling all the plug-in but still no visual tab.

    On my current theme is zee_corporate, the box to enter text comes out gray when it should be white. I tried Twenty-Ten and the text box is white but still no tab for visual.

    Have you tried what worked for others above? Also, http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list?replies=5 especially the part about javascript.

    YIKES, I actually had the developer of my plugin (phpBay) look into this on my WP admin side and server side and he came back with:

    “I’m sorry, I couldn’t resolve this issue.”

    He also updated to the latest version (something in the WP sticky recommended) but still it didn’t solve my problem.

    For now I have to cut and paste the code in each page or go back to the older version. Go figure.

    I have the problem in IE but not in Chrome…

    did install the ‘Use Google Libary’ but before I tried Chrome on this..


    I have tried everything I can find on the fixes. I have done the manual install. Run the Hotfix 0.7.

    I have multiple administrators, but only the admin seems to work mostly correctly. If I login with admin, I see light blue dashboard buttons and I get the visual and html tabs when editing a page. If I login as a different administrator then I see gray dashboard buttons and lot of problems including not having the visual tab.

    I’m new to WordPress and kind of at a loss as to what to do.

    Things seem to have gotten slightly better but not totally fixed with Hotfix 0.8 which I just installed.

    Now when I login as an administrator on an ID other than Admin, the text boxes are white (where they were gray before). But there is still no “visual” tab when editing a page or a post.

    Before when I was editing comments even in admin with Akismet running, I would get a popup bar across the screen which blocked the top lines of the text. Hotfix 0.8 seems to have fixed this.

    Other than looking forward to hotfix 0.9, is there anything else I should do?

Viewing 15 replies - 1 through 15 (of 121 total)
  • The topic ‘Visual Editor Not Working After 3.3 Upgrade’ is closed to new replies.