Support » Fixing WordPress » Visual Editor Not Working

  • The visual editor is not working – there is no button for visual editor appearing and I simply see the html code box. I know this is a problem that has plagued others and some have been able to fix it using a variety of solutions. None of these have worked for me. Here is what I have tried:

    Disabling all plugins
    Reinstalling WordPress
    Changing the wpconfig.php script
    Using the Google Libraries plugin
    Using the Hotfix plugin
    And, yes, the ‘disable visual editor’ box is NOT checked and, yes, I have refreshed the cache multiple times.

    What else can I do to get this back up and running? Any help greatly appreciated.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Which theme are you using?

    It makes no difference – I have multiple sites – each with a different theme and all are experiencing the same problem.

    Forgot to mention that I also changed the theme to Twenty Eleven just to check – and no difference with the theme change.

    Really hoping someone can help with this…at a loss as to what to do next..

    Same thing happening on a few of my sites. I have also tried all of the above. Tested on OSX and Chrome OS. (No windows boxes around the house)

    Thanks
    TJ

    I have the same problem and I did the exact same steps….awaiting a response from WordPress.

    I am also facing same problem and done all things now what i can do..

    Are you not seeing a tab for the visual editor at all? The error that I am experiencing still shows a tab for it but you simply can not select it.

    If you don’t see the tab for it at all you may want to make sure your enabled for the visual editor under your user account on the wp dashboard. I’ve read sometimes it has to be turned off and back on to work correctly. It may not be the solution but sometimes it is the simply thing we forget. Hope you get it this fixed soon.

    Sorry just saw you already did that.

    OK – the problem is isolated to the laptop I am using – the same one I used to install the download. When using another laptop, I experience no issues and visual editor is working fine.

    I have cleared the caches on the original laptop, even installed Opera and cannot get access to the visual editor in any browser – Firefox, IE, Chrome or Opera. Clearly the problem is with this laptop, not with the install, plugins, etc. Any suggestions as to how I can get this laptop functioning again in regard to visual editor?

    Can you show me a screenshot of what you are seeing on the laptop which displays the editor incorrectly? Upload it to your server or a free photo sharing site.. and post the link here.

    You don’t have the visual editor active in your user profile.

    Go to users… then click “edit” on the user account you are using to log into your website.

    On that user profile page… at the very top of the page… is an option to “disable” the visual editor.

    Make sure this option is NOT checked. Then… save.. and reload the editor page.

    I see you checked this… but check again 🙂 Make SURE you are on the correct user profile.

    If it still isn’t working… what browser are you using?

    It is absolutely UNCHECKED. I just checked it again for the umpteenth time. I am using Firefox but I have tried using Chrome, Opera and IE as well – no difference. And again – this is working on fine on any other computer – just not my primary laptop that I want to use.

    I also am having this issue on about 6 different sites. I’ve done everything mentioned. I’ve tried different computers, IP addresses, web browsers – it makes no difference. My host spent 3 days trying to figure out if it was something on his end. The ONLY thing these sites have in common is WordPress. They are on different themes, some are brand-new and others have been around. I finally reverted back to 3.4.2 because no one can figure what is going on. Any help would be appreciated so I can update back to 3.5.1.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Visual Editor Not Working’ is closed to new replies.