[resolved] Visual Editor Not Working (11 posts)

  1. pl2prosperity
    Posted 4 years ago #

    My Issue:
    The Visual option under Posts is not working and I am not able to get the Bold, Italics, etc. buttons to format my posts.
    Also when I clicked "Screen Options" and selected "Number of Columns" as "1", all the options went off from the right-side to below the text box. However, when I switched it back to "2" again the options never came back to the right-side; it stayed below the text box.

    My current configuration in brief:
    1. WordPress 3.2.1
    2. PHP 5.2.17
    3.SQL version 5.0.92-community
    4. Theme "Mainstream" 1.7.1 Framework 4.0.0 from Woo themes (http://www.woothemes.com/2009/07/mainstream/)

    Here's a list of things that I had done to restore the Visual Editor for the last 5 days:

    1. Disabled all the plugins by bulk.
    2. Checked whether it's disabled in my user's profile. It's not as the option " Disable the visual editor when writing" is unchecked.
    3. Re-installed the WP-admin and WP-includes folder as advised in the WordPress forums.
    4. Tried to insert the line - Define('CONCATENATE_SCRIPTS', false ); - in WP-config as advised at http://www.techiecorner.com/1656/wordpress-visual-editor-not-working/ and elsewhere. I kept getting an error whenever I tried doing so and couldn't even login to the wordpress. So changed back to the original file and I could login again.
    5. Reinstalled wordpress by clicking on "Re-install Now" from Dashboard -> Updates.
    6. Checked on different browsers like Internet Explorer, Firefox and accesing the page on other computers.
    7. Contacted my hosting provider to check the current PHP versions which they say is 5.2.17, which I think is fine. They can't seem to solve the issue at their end.
    8. Changed and tried theme Twenty Ten.

    Nothing worked. However, I caught some errors in the WordPress -> Add New Post page (the place where the Visual Editor is supposed to be working) as delivered by the "Firebug" plugin in Firefox. Here are the 4 errors:

    1. Syntax error: If(!v)window.addEventListener('load',a...it:function(l){var m='checkspell',n=l. Ckedit...r=3.2.1 (line 159)
    2.Missing ) after argument list: (function(d){var a=/^\s*|\s*$/g,e,c="B...e_colors_title:j.getLang("more_colors" Wp-tin...0110630 (line 1)
    3.TinyMCE is not defined: TinyMCE.addI18n({en:{common:{edit_conf...tion:"Caption",alt:"Alternate Text"}); Wp-LAN...0110630 (line 1)
    4. Tinymce is not defined: Load_ext : function(URL,lang){var sl=...kDone(URL+'/langs/'+lang+'_dlg.js');} Post-new.php (line 1019)

    Now, I thought all these errors must be because of a corrupted WP-Included folder, where TinyMCE resides, as TinyMCE is responsible for the Visual Editor. However, inspite of reinstalling the WP-Includes folder and even the TinyMCE folder there, didn't help.

    Please help me resolve this as I am trying it for the last 5 days and making a post is so much difficult for me without the Visual Editor, as I don't know HTML and other technicals much.


  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. pl2prosperity
    Posted 4 years ago #

    I did as mentioned by me above in my "list of things that I had done". Didn't work.

  4. pl2prosperity
    Posted 4 years ago #

    Finally I solved it. I was having an issue with the cloudflare auto-minify option. This striked me, when everything else failed. Disabled it in cloudflare settings and the issue was resolved. This was also suggested at http://wordpress.org/support/topic/visual-and-html-editor-are-missing?replies=16.

  5. indysmith82
    Posted 4 years ago #

    hi there, where do you find the settings in wordpress to disable auto minify?

  6. pl2prosperity
    Posted 4 years ago #

    Hi indysmith82,

    The auto minify option is not in wordpress, it is in Cloudflare (https://www.cloudflare.com/), which I use. If you use Cloudflare, you can try it.

  7. indysmith82
    Posted 4 years ago #

    okie dokie, thanks. I thought maybe Cloudflare was something automatic;y added in to the newest update of WordPress and it was something I could fix. Looks like I've tried everything you've tried as well and that Cloudflare won't be the issue. This is really annoying.

  8. Carlos Rivero Siri
    Posted 4 years ago #

    Same problem.
    Turned off the autominify option in cloudflare.
    Worked for me too.

  9. Kathy_Goss
    Posted 4 years ago #

    Same problem. Although just deactivating the Java Script option in auto minify resolved the issue

  10. Technology Blog
    Posted 4 years ago #

    If nothing works try removing your htaccess file to see of that helps. gzip of this js has some issues

  11. Donquiweb
    Posted 4 years ago #


    I fixed this issue on WP 3.3.1 when I deactivated the deflate_module on my Wamp installation. I activated it to test a PHP application few days before and remember this when I found the error :

    Erreur : missing ) after argument list
    Fichier Source : http://www.mysite.com/wp-admin/load-scripts.php?c=1&load=admin-bar,hoverIntent,common,jquery-color,thickbox,theme-preview,theme&ver=2bb4e45d240f389d99fab9f4c89db532
    Ligne : 3, Colonne : 3942

    Hope it will help you.


Topic Closed

This topic has been closed to new replies.

About this Topic