Support » Fixing WordPress » Visual Editor not showing

  • There’s been many posts on this and none of them are having the same problems as I, and none of the solutions offered have worked.

    I have a website with two users, both admin accounts.
    I can login as both users on my 2009 imac using Chrome and everything works fine, no issues.

    The client logs into her account on her laptop using Chrome and she does NOT see the visual editor in either Chrome or Explorer. Considering she does not know much about code she obviously needs more help creating posts and needs to see this.

    HP Laptop running Windows 8
    Chrome is Up to date
    Explorer is up to date
    Wordpress and plugins all up to date
    Other WP websites on same server running fine

    Yes, I’ve tried all these things, NONE had any affect.

    – disabled all and reactivated plugins
    – changed from theme back to the WP2017 theme
    – checked that USER profile settings has viewing of the visual editor unchecked
    – used different browsers Chrome and Explorer with no changes
    – cleared cache and cookies on both machines (and all browsers)
    – logged out and back in to our both accounts
    – re-installed latest version of WordPress 4.9.4
    – added define(‘CONCATENATE_SCRIPTS’, false); to our wp-config
    – tried define( ‘WP_DEBUG’, true );

    The fact that everything works fine on one machine but not another is what confuses me even more.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 31 through 39 (of 39 total)
  • @spectacula Thank you very much.

    Your solution worked !!

    I was struggling to solve this issue from last 11hrs and really gonna mad.

    I have AWS server with cloudfront activ.

    Thank you very much !!

    Hi, for me was the “WordPress Media Category” plugin.
    Deactivated it and all works.

    I’ve had this problem too.

    My solution;

    In the visual editor area in my WordPress profile; Check the box for using the visual text editor while typing and save. Then come back to the box and deactivate it. Save it again now. Your problem will be fixed.

    I had tried all the steps suggested by most of my searches as I was trying to find the solution.

    Based on the comment by @temmes about the value rich_editing in the users_meta table I was able to solve it.

    INSERT INTO [TABLEPREFIX]_usermeta (umeta_id, user_id, meta_key, meta_value) VALUES (NULL, ‘[YOUR_ID]’, ‘rich_editing’, ‘true’);

    Here is the link to his comment

    • This reply was modified 6 months, 3 weeks ago by Armando Duran.

    I had the same problem, but I solved it by downgrading my WordPress version

    @kelwin17 Thank You it worked for me you are champ <3

    blackeater

    (@blackeater)

    I have read all the solutions here and elsewhere but nothing works. Some solutions have worked but that is if he has cloud on the hosting and I don’t have it. However I managed to solve this solution, I found this by comparing 3 site files namely Main site, similar copy site, and new site with similar plugins.

    especially the confiq file which is the source of the problem, thanks to @spectacula for narrowing the range of files that need to be checked. the way like this;

    Open and edit c-panel in the wp-config.php file if you see text like the one below in the wp-confiq.php file:

    // Disable File Edits
    define (‘DISALLOW_FILE_EDIT’, true);

    delete the text, in me it is visible at the bottom, maybe at the bottom you will change its position.

    I think the text appears automatically when you have installed a plugin and you have deleted it and during the plugin setup you have activated a button that triggers the text to be generated automatically. That’s just a guess but it seems right because when I create a new sub site, the plugins that I’m currently using the visual editor are still showing up and that’s what makes me think like this.

    Maybe you managed to come up with a wordpress visual editor my way. Hope this helps for others.`

    coconutcoder

    (@coconutcoder)

    @vtrav for the win. I almost always only use USB tethering. My rich_text=true, and disable visual editor was unchecked. As soon as I switched from USB tether to Wi-Fi, my rich text / visual editor magically appeared. This is especially important if you’re using Elementor, where the text editor only uses the rich text editor.

    I had the same problem after connecting the website to AMAZON CDN and updating the FireWall.
    @spectacula solution solved the probelm.
    Thank you.

Viewing 9 replies - 31 through 39 (of 39 total)
  • You must be logged in to reply to this topic.