Support » Fixing WordPress » Visual Editor not showing

  • There’s been many posts on this and none of them are having the same problems as I, and none of the solutions offered have worked.

    I have a website with two users, both admin accounts.
    I can login as both users on my 2009 imac using Chrome and everything works fine, no issues.

    The client logs into her account on her laptop using Chrome and she does NOT see the visual editor in either Chrome or Explorer. Considering she does not know much about code she obviously needs more help creating posts and needs to see this.

    HP Laptop running Windows 8
    Chrome is Up to date
    Explorer is up to date
    Wordpress and plugins all up to date
    Other WP websites on same server running fine

    Yes, I’ve tried all these things, NONE had any affect.

    – disabled all and reactivated plugins
    – changed from theme back to the WP2017 theme
    – checked that USER profile settings has viewing of the visual editor unchecked
    – used different browsers Chrome and Explorer with no changes
    – cleared cache and cookies on both machines (and all browsers)
    – logged out and back in to our both accounts
    – re-installed latest version of WordPress 4.9.4
    – added define(‘CONCATENATE_SCRIPTS’, false); to our wp-config
    – tried define( ‘WP_DEBUG’, true );

    The fact that everything works fine on one machine but not another is what confuses me even more.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 33 total)
  • Just created an account to say that @spectacula is 100% right.

    The issue comes from the ‘user_can_richedit’ check.

    Even if the value is set to true in the user profile or database, WordPress will ignore it based on the user agent string (and probably lots of other undocumented cases).

    The solution is to add a filter function in wp-config.php like the example @spectacula posted.

    Thanks!

    I had the same problem and this solved the it. Thanks man.

    Sir, My Visual Editor not working! Please help me. Only TEX code feature are working but visual not work.!

    I have Deleted my Browser Cache, And i try to fixed wp-config.php with
    “define(‘CONCATENATE_SCRIPTS’, false);” And Also TinyMCE Advanced plugin, And also deactivate all of the installs plugin and change my theme but still not work any of these. Can you please tell me how can it fixed?

    I’m having these same issues yet can’t find the coding you guys are mentioning. I’m using godaddy for hosting and cpanel access. I have no clue what I’m doing, can’t find the tables and files mentioned above, HELP!

    Thanks in advance

    Paul

    (@paul-m-uk)

    Had this on a bunch of my sites when I went https

    I installed: https://wordpress.org/plugins/really-simple-ssl/ and that fixed the issue.

    There are as many causes as posters, by the look of it, and I have another.

    I manage four separate sites, all on WordPress 4.9.something (the upgrade does not work!) and only one has this problem. I have not got anything wayward ticked, I do not use Cloudflare (whatever that is), I have few plug-ins. I even inserted a line of code in the config.sys file as recommended by one site, to no avail.

    It happened when I was doing some heavy Text editing: I had to finesse some links (‘<a href=’ etc) and table formats. Having done that in Text editor, the Visual editor remained permanently greyed-out for all pages, and nothing has been able to revive it.

    I had the same problem. Neither the Visual or Text tabs were visible, and the editor window showed only Text mode.

    jake2071 led me to the answer that worked.

    In my profile, the “Disable the visual editor when writing” check box was NOT checked. But I checked the box, saved, unchecked it and saved again. Walah! Both tabs are now present.

    Hope this helps someone else.

    • This reply was modified 1 year, 6 months ago by Heavy Si.
    • This reply was modified 1 year, 6 months ago by Heavy Si.

    Alas, no – I have tried that; no change.

    I would reload WordPress from the start, but that wipes out all the content (as I learned once before).

    OMG @kelwin17 you nailed it!! tried cloudflare page rule for user agent, tried name and last name for profile… none of that worked. YOUR SOLUTION DID WORK! you are the man.

    I was also banging my head on wall..but after all troubleshooting..I did step by step customization I did previously before I broke visual editor..and find out that “It breaks when I changed my site URL. in my case I installed wordpress on https://mysite.blabla and when I changed it to https://www.mysite.blabla it breaks.” <– well that was my case.
    I do not know reason for this to happen but for my site that was the reason.
    I use aws EC2 and RDS

    • This reply was modified 1 year, 5 months ago by Shailaabh.
    • This reply was modified 1 year, 5 months ago by Shailaabh.

    In your DASHBOARD in WordPress….
    Click > DIVI
    Click > Plugin Options
    Click > Advance
    Click > ENABLE Classic Editor

    This comes grayed out !

    After two hours of reading and searching and frustration—
    Kelly

    meyerdev.ch

    (@meyegui)

    Hi,

    I’ve just encountered the same issue and found an easy fix:

    1. Go to your profile.
    2. Check the first checkbox (about the visual editor) and save the settings.
    3. Uncheck the very same checkbox and save again.
    4. It should work, now.

    In my case, I was unable to save my settings at first because my profile’s nickname wasn’t set, so when I tried step 2, I got an error message saying just that. After I typed in a nickname for my profile, I was able to make the procedure work.

    Hope this helps someone some day.

    hi guys,

    same problem here, I have just secured the site through plesk.

    https://prnt.sc/oo91ep

    Not working nothing 😭

    I had these same symptoms, simply went into the users profile and added a checked “Disable the visual editor when writing”, clicked save, WP gave me an error as no nickname was set. I set a nickname and saved. Then visual/text toggle began working.

Viewing 15 replies - 16 through 30 (of 33 total)
  • You must be logged in to reply to this topic.