Support » Fixing WordPress » Visual Editor not showing

  • There’s been many posts on this and none of them are having the same problems as I, and none of the solutions offered have worked.

    I have a website with two users, both admin accounts.
    I can login as both users on my 2009 imac using Chrome and everything works fine, no issues.

    The client logs into her account on her laptop using Chrome and she does NOT see the visual editor in either Chrome or Explorer. Considering she does not know much about code she obviously needs more help creating posts and needs to see this.

    HP Laptop running Windows 8
    Chrome is Up to date
    Explorer is up to date
    Wordpress and plugins all up to date
    Other WP websites on same server running fine

    Yes, I’ve tried all these things, NONE had any affect.

    – disabled all and reactivated plugins
    – changed from theme back to the WP2017 theme
    – checked that USER profile settings has viewing of the visual editor unchecked
    – used different browsers Chrome and Explorer with no changes
    – cleared cache and cookies on both machines (and all browsers)
    – logged out and back in to our both accounts
    – re-installed latest version of WordPress 4.9.4
    – added define(‘CONCATENATE_SCRIPTS’, false); to our wp-config
    – tried define( ‘WP_DEBUG’, true );

    The fact that everything works fine on one machine but not another is what confuses me even more.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 26 total)
  • Is there a security plugin installed?

    I suggest checking the Disable the visual editor when writing checkbox and saving the profile then unchecking it and re-saving the profile.

    Have you tried creating a “New” user account and trying it?

    There is Wordfence installed. But I’ve tried deactivating all the plugins (there’s only 6) and even tried the 2017 theme with no plugins activated. no changes

    Disabled the visual editor in the user profile saved and reverted, no change.

    Created a new user account and logged in, no change.

    The weird thing is also that it doesn’t show the “Visual” tab OR the “Text” tab. Simply opens the new post page with the only option being the text editor.

    Thanks for the suggestions though, they’re appreciated.
    Wayne

    Plugin data could be stored in the database regardless if the plugin is running or not – I suggest deleting wordfence and its DB tables

    I had clean new install no plugins or other themes installed and the same problem.

    I compared 2 different sites’ tables. One site with a working Visual Editor (and updated to new WP version) and the new one not.

    In table <usermeta> of the “working site” I found record <rich_editing = true> for my user id.
    The new site did not have that one. After adding that record into the table the visual editor started showing up again.

    umeta_id > [new number]
    user_id > [my user id]
    meta_key > “rich_editing”
    meta_value > “true”

    INSERT INTO [TABLEPREFIX]_usermeta (umeta_id, user_id, meta_key, meta_value) VALUES (NULL, ‘[YOUR_ID]’, ‘rich_editing’, ‘true’);

    So I hope that might work out for you too.

    • This reply was modified 1 year, 1 month ago by  temmes.
    • This reply was modified 1 year, 1 month ago by  temmes.
    vtrav

    (@vtrav)

    Hey Waynard, You are describing the exact problem I’ve had for over a year now and sorry to say I don’t have a solution yet… The Visual & Text Editor TABS do not show up. This has happened twice on two different laptops THAT I USED TO DOWNLOAD WORDPRESS ON. In each case the very laptops used to do this The Visual & Text Editor TABS where not visible They only became visible if I USED ANOTHER DEVICE Laptop, P.C., Tablet, or Phone for that site so it seems to have something to do with whatever device you use to download WordPress on it creates a bug for that device with the editor… However I, after all, this time think I may have found a Post where the guy has our same problem and said he found a solution but for me, some things tech language he uses has me confused still a little. I was about to post a Question in regards to this before I stumbled across your post. If it works for you maybe you can help me understand it by breaking it down into simple language minus all the tech terminology good luck here’s the link please keep me posted… P.S. Scroll down towards the bottom of the page ignore the top…
    https://wordpress.stackexchange.com/questions/126110/visual-editor-missing-server-side-problem-how-would-you-debug-it/126156?utm_medium=organic&utm_source=google_rich_qa&utm_campaign=google_rich_qa

    I have the same problem: Visual Editor not showing. i’ve tried all things but not successful.

    Please, help!

    MY SOLUTION… I had been tethering the internet from my phone using a USB cable to my laptop as soon as I disconnected the cable and instead used my phones wifi for my laptop the video and text editor appeared and was fully functional. It took over a year for me to find this out on my own. My suggestion is to make sure your internet connection is not obstructed in any way whatsoever. The USB cable was not letting all the information thru in my case. Hope this helps someone else.

    Virender Singh

    (@virendrapalsingh5)

    I have tried a few things and fortunately found a very simple solution to this problem. You may check the details in this blog post Visual editor not showing in WordPress page or post editor.

    Rajiv Pandey

    (@raj860444)

    INSERT INTO [TABLEPREFIX]_usermeta (umeta_id, user_id, meta_key, meta_value) VALUES (NULL, ‘[YOUR_ID]’, ‘rich_editing’, ‘true’);

    This is working for me just open your admin pannel and in the user_meta table just update the rich_editing true for the user you want to enable visual editor.

    jake2071

    (@jake2071)

    You might already know this but if your go to your WordPress profile, there is a checkbox to ” Disable the visual editor when writing” be sure it is unchecked. However, I am still having a problem with only a little bit of the editor showing like in this comment box im typing in right now.

    I’ve just had the same problem come up for me but with 90+ authors/editors/admins all suddenly seeing no editor. Coincidentally we’d just activated CloudFront and after stepping over a few possible things like cross-origin and missing JS I chose to trace the code and found the problem.

    Turns out the problem was down to the UserAgent string being sent to WordPress by CloudFront. If WP doesn’t recognise the string you don’t get a fancy editor. We modified CloudFront such that the UA for admins would be untouched and everything came back. The other option would be a plugin that does the following:

    add_filter( 'user_can_richedit', function( $wp_rich_edit ) {
        if ( !$wp_rich_edit
             && ( get_user_option( 'rich_editing' ) == 'true' || !is_user_logged_in() )
             && isset( $_SERVER[ 'HTTP_USER_AGENT' ] )
             && stripos( $_SERVER[ 'HTTP_USER_AGENT' ], 'amazon cloudfront' ) !== false
        ) {
            return true;
        }
    
        return $wp_rich_edit;
    } );

    From the sound of things the first poster’s problem machine may have a firewall/privacy/av app that’s modifying the UserAgent so you could take the above code and change the “amazon cloudfront” string to match part of your UA and all should be well.

    • This reply was modified 7 months, 2 weeks ago by  Spectacula.

    I had the same problem which appeared only recently, and the only change was the implementation of Cloudflare by the hosting company (pretty much invisible to me). The above post helped with our investigation and for me the fix was adding a ‘page rule’ at Cloudflare which told the cache to ignore the wp-admin URL:
    <site>/wp-admin/*
    [Cache Level] [Ignore Query String]

    This stopped the tinymce errors in browser console, and the visual editor works again!

    According to this site – https://www.medinaminds.com/wordpress-visual-editor-not-showing/ you can ignore the query for the actual tinymce plugin instead.

    mirtillion

    (@mirtillion)

    @mwrycraft, this was a perfect solution. I never imagined that the CloudFlare could be the source of this problem. Thank you very much for your suggestions. 🙂

    To keep it simple I had these symptoms too..

    In the “Users/Your Profile” area
    I just made sure my user fields like ‘nickname’ and first and last name.. were filled out. I also ‘checked’ ~ Disable the visual editor when writing.. and saved the user profile. Then I ‘un-checked’ ~ Disable the visual editor when writing.. and saved again.

    This fixed the issue.. hope this helps someone.
    John

    • This reply was modified 6 months, 4 weeks ago by  studioactiv8.
    • This reply was modified 6 months, 4 weeks ago by  studioactiv8.

    I have simple and sweet solution which i used, i think this problem occur because of https://

    simply install 2 plugin:

    1st CloudFlare Flexible SSL
    2nd SSL Insecure Content Fixer

    Thanks me later 🙂

Viewing 15 replies - 1 through 15 (of 26 total)
  • You must be logged in to reply to this topic.