WordPress.org

Support

Support » Plugins and Hacks » Visual editor not displaying styled text (with CSS in place for it)

Visual editor not displaying styled text (with CSS in place for it)

  • Thank you for this wonderful, time-saving plugin!

    I’m having the same problem described here—the code is applied in the HTML view, but doesn’t appear in the visual view. I’ve tried the solution you outlined in that post, and reloaded the browser cache.

    Here’s exactly what I’ve got:

    Before:
    <span class="jennaspeaking">

    After:
    </span>

    CSS:

    .jennaspeaking {
    font-style: italic;
    color: #333;
    }

    Any help would be wonderful. And thanks again!

    http://wordpress.org/extend/plugins/visual-editor-custom-buttons/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author cyberduck

    @cyberduck

    Ok. If i understand your problem. The button show up but when you press it. No code is added?

    1. Have you tried the button on a empty page?

    2. Have you checked read/write permissions on the plugin folder. When adding a new button, the plugin generates a button.js file in the plugin-folder. There are 5 default empty button.js file when plugin is installed. If you create one button, the button1.js file should not be empty anymore. Open it up to check if it has any code in it. If not, it’s probably has something to do with read/write permisions.

    Nope, sorry. I wasn’t being clear.

    Code is applied, but I don’t see the effects of it in the visual editor.

    I’ve been applying exclusively through the text editor, which is fine, but a little hard on the eyes when doing long stretches of editing.

    Checked the js folder: 7 files for 7 buttons, all with content.

    Thanks!

    Plugin Author cyberduck

    @cyberduck

    Ok. Have a look in the CSS-file in the plugin directory if your CSS is in it. If not, there is an issue with writing permissions. If its there. Clean the cache and try the button again in a clean visual editor.

    Thanks for sticking with me.

    CSS file has my code in it. I started a fresh post in a different browser (normally I’m using Firefox 21, Mac, tried it in mobile Safari) and the problem persists.

    I’d be happy to make you login credentials, if you like.

    Hi guys,

    I’m having the same exact issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Visual editor not displaying styled text (with CSS in place for it)’ is closed to new replies.