WordPress.org

Forums

[resolved] Visual editor no longer working on my installation of wordpress (4 posts)

  1. thedirtybaker
    Member
    Posted 1 year ago #

    Not sure what happened, but I went to add an new post the other day and I found the visual editor to be broken on my installation of WordPress 3.9.1 (at https://3z33.us)

    I tried disabling all plugins, then enabling them one by one, with the same disappointing lack of effect on the visual editor.

    I have tried posting a new post using Firefox and Chromium on Ubuntu Desktop, as well as Firefox and Chrome on Android, all with the same result.

    I can still post plain text with hand typed html, but my installation doesn't really feel like it is running properly without the ability to upload pictures in the browser.

    Any ideas on what could be causing this problem?

  2. thedirtybaker
    Member
    Posted 1 year ago #

    Here is a screenshot of the applicable area I see when I add a new post. Clicking the Add Media button has no effect. I can only type in the composition area if the visual editor is disabled in my profile.

    After enabling script debugging as described here in the codex visiting my site produces this error:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /home/z33us/public_html/wp-includes/functions.php on line 3078

  3. thedirtybaker
    Member
    Posted 1 year ago #

    The Browser Console in Firefox shows the following errors when I attempt to Add New Post:

    SyntaxError: illegal character load-scripts.php:2
    downloadable font: invalid version tag (font-family: "dashicons" style:normal weight:normal stretch:normal src index:0)
    source: https://3z33.us/wp-includes/fonts/dashicons.eot load-styles.php
    downloadable font: rejected by sanitizer (font-family: "dashicons" style:normal weight:normal stretch:normal src index:0)
    source: https://3z33.us/wp-includes/fonts/dashicons.eot load-styles.php
    SyntaxError: illegal character load-scripts.php:1

  4. thedirtybaker
    Member
    Posted 1 year ago #

    My web host informed me that Magic Quotes were responsible for the SyntaxError. Sure enough, placing this php.ini into my wp-admin directory solved my problem:

    `; Magic quotes
    ;

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    ; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
    magic_quotes_runtime = Off

    ; Use Sybase-style magic quotes (escape ' with '' instead of \').
    magic_quotes_sybase = Off`

Topic Closed

This topic has been closed to new replies.

About this Topic