Support » Fixing WordPress » Visual editor missing, buttons not working, white text, HELP!

  • Resolved utopiaphoto



    Seemingly out of the blue I have lost my visual editor and many buttons in my new post area no longer work (editing status, visibility, publish, etc). My text is also white in the text box. I haven’t done any upgrades since installing. I have tried disabling all plugins and reactivating one by one, clearing all cache/cookies, and using other browsers/computers but still that same issue. I’ve read a lot of other posts but haven’t seemed to find a solution.

    The only thing I can think of is I tried a couple new plugins last month but deleted them as they were not what I needed. Could any of these left some code messed up? Is it Jave Script or Jquery things that effect the editor (I’m not even truly sure what they are!)? I really am hoping to avoid a whole new install of WordPress as it took a lot of trial and error customizing my theme, including widgetizing it.

    Any possible solutions gratefully appreciated!

    Thank you!


Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi!!

    I had the same problem few minutes ago.
    My update include Jetpack update too.
    I made update wordpress and jetpack. After that the problem with visual appeared.

    I fix it disabling, in this case, JetPack plugin. It works again.
    I hope this helps.

    (Sorry my bad english)


    Turns out I was somehow missing my entire JS folded from my wp-admin folder! After dropping a new one in with all the files via FTP, everything is back to normal!

    So great!


    I don’t have JetPack, but I have the problem with all blogs on different servers/hosting. I don’t understand the JS folder in the wp-admin folder, what are those files to upload? How to get them?

    Problem solved! Simply install plugin “Use Google Libraries”. JS folders were not missing, so that is not the problem.

    Visual and Text button not working after upgrade.
    Install Google Libraries plugin
    Google Libraries WORKS, thanks to our wonderful tech, Daniel.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Visual editor missing, buttons not working, white text, HELP!’ is closed to new replies.