Support » Fixing WordPress » Visual Editor missing and broken in 3.1

  • Resolved themightyant

    (@themightyant)


    Hi,
    I have seen that others are having similar problems that may or may not be related.

    The Problem

    1. Just upgraded to 3.1 through automatic upgrade on the dashboard
    2. The Visual editor GUI is missing and text appears in white. (see image)
      arcbroken1
    3. Once ‘Visual’ is clicked again text appears but in html (see image)
      arcbroken2
    4. The front end of the website is fine

    What I have tried

    • I have read a lot of similar posts here and gone through the ‘Troubleshooting WordPress 3.1 – Master List’ and tried the following without any luck so far
    • Checked other browsers (Chrome, Firefox, Safari)
    • Disabled and re-enabled visual editor in my profile
    • Deactivated all plugins
    • Switching to the Twenty Ten theme
    • Resetting the plugins folder by FTP (renaming folder, creating a new one and visiting admin page)
    • Disabled the Admin bar
    • Downloaded and re-uploaded a fresh copy of the wo-admin and wp-includes folders
    • Checked I am running PHP 5
    • Upgraded the php memory limit to 64MB through .htaccess, wp-config and memory-bump plugin (shared hosting no access to php.ini)
    • Tried adding the following code to wp-config
      define('CONCATENATE_SCRIPTS', false);

    None of the above worked does anyone have any suggestions?

Viewing 15 replies - 1 through 15 (of 58 total)
  • Moderator t-p

    (@t-p)

    have tried:

    increasing memory available for php.

    -if that does not help, try deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually (one-by-one) to find the culprit.

    -if that does not help, try switching to the default theme (“twentyten”) for a moment by renaming your current theme’s folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

    Hi t-p,
    thanks for the suggestions however as I mentioned in my initial post I have already tried ALL three of these and none of them have worked.
    Just to clarify, in addition to what I mentioned above, I have already tried

    • Increasing the memory available for PHP
    • Deactivating ALL plugins (by renaming the plugins folder and replacing it with an empty one
    • Switched to Twenty Ten theme
    • In addition I tried renaming the themes folder and replaced with an empty one

    None of the above have worked.

    Temporary Fix
    In the meantime, for anyone else who is experiencing the same problem, I have installed the CKeditor (by CKSource) which uses a different visual editor than the default wordPress one. While this works for the moment this is not a fix.

    If anyone else has any suggestions I would love to hear them or if anyone has solved this problem what steps did you take to resolve it.

    Many thanks

    Moderator t-p

    (@t-p)

    In addition I tried renaming the themes folder and replaced with an empty one

    – have you tried the same with the plugins folder

    -also, have you reviewed: Troubleshooting WordPress 3.1 – Master List

    –If the above steps do not resolve the issue, Download WordPress again and replace your copies of everything EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

    Hi t-p, I hope you had a good weekend.

    While I appreciate the suggestions, I have already tried ALL of these as I had mentioned in my first post.
    Yes to plugins, Mater list & reinstalling WordPress manually.

    I should say that I am not new to WordPress I am a Web Developer who has built dozens of WP websites for clients. As such I checked the forums and worked at the problem BEFORE starting this thread as solutions are usually already here. I only posted AFTER I had tried all of the potential solutions I could find without any progress.

    Thank you for trying though.

    Do you have any other WP installs running on the same server? Just want to see if it could be server related.

    Hi Rev. Voodoo,thanks for the prompt response.
    No other WP installs on that server. It is on shared Linux hosting with 123-reg.co.uk I have updated seven other sites with no problem and am hesitating updating another 15 or so until I know what the problem is with this one in case the problem occurs again.

    I may have an insight on this, or at least a description of what seems to be the problem on my instance. Are you using cForms? Even if you’re not, a similar issue may be at the root of your woes. I found that some browsers are choking because my admin pages are https://, but some elements are coming over non-secure connections. Specifically, the cForms icon that appears in the TinyMCE toolbar was being flagged as insecure and not loading, which seemed to gum up the loading of the entire TinyMCE environment, causing the Visual Editor not to display and the text to remain white/HTML.

    Follow-up: If you are using cForms, the easiest way to fix this problem is to go into cForms settings and uncheck Enable TinyMCE & Code editor buttons in the WP Editor Button support section of Global Settings.

    Hi Aaron, thanks for the input.
    I am not running cForms but have looked through my other plugins options to see if there was anything similar. There wasn’t.

    Shouldn’t disabling all plugins (via renaming the Plugins folder) negate the need for this anyway?

    I am going to try and install a fresh blog on the same server to try and ascertain whether it is server specific. I am a little tied up with another website launch today but will report back asap.

    In the meantime if anyone has any further ideas i’d love to hear them.

    Yeah, I was thinking that disabling all of the plugins would have negated any effect like the one I was seeing, but I thought I’d mention it anyway, just to be sure. Sorry this didn’t help you. I guess mine was a rather specific case.

    I am having the same problem as themghtyant. I have followed his/her checklist and there is no resolution to the problem. It occurs in Firefox and IE8.

    Hi Rudha-an,
    Have you tried with other browsers too (eg:Google Chrome) or is this limited to Firefox and IE8?

    Sadly, I haven’t. I don’t use them. I can only speak for Firefox and IE8. I did switch to the Weaver theme, but that isn’t the problem either. Aside from that, I’ve not added anything new. Visual Editor was working fine yesterday.

    Rudha-an,
    you should check with another browser. There were some others on this forum who were saying that it only happened in some. This may or may not differentiate your problem from mine. Good luck

    Hi All, I had been around in circles for ages on this one, until when talking a client through the back end they clicked on ‘Show / hide kitchen sink’ right in front of me.
    It turned out to be as simple as that.
    Hope it helps someone else,

Viewing 15 replies - 1 through 15 (of 58 total)
  • The topic ‘Visual Editor missing and broken in 3.1’ is closed to new replies.