WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor MIA

Visual Editor MIA

  • My visual editor (and HTML editor) buttons have disappeared on all three of the sites I’m working on.

    Two use 3.4.1 and one is running an old version of WordPress 3.3.2.

    All versions I have lost the editor capabilities somewhere between yesterday morning and yesterday evening.

    I’ve searched threads and tried everything (cleared out caches, tried different browsers, reinstalled WordPress, deactivated and reactivated plugins and even deleted some, changed the user settings).

    Is there anything anyone out there can tell me about this? Is this a common occurence? Any help is greatly appreciated!

Viewing 15 replies - 1 through 15 (of 23 total)
  • could you screen shot this for us please..

    has the entire thing disappeared? or not loaded? or partially loaded somewhere else? 🙁

    The sites and all the pages are still there, but when I enter the pages themselves for editing the visual editor is just gone.

    Here is what the page editor now looks like:

    http://www.criptest.com/learning/carole/

    I’m having this same problem. It was confusing for me as well. I can only view one or two of the twenty or so pages in the visual editor. The rest show nothing whatsoever.

    Will Ryan
    Snark Films

    I hope this will be fixed ASAP

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    Try making a backup copy of your wp-config.php file and adding this line

    define( 'CONCATENATE_SCRIPTS', false );

    If that doesn’t work, try the usual troubleshooting 101 steps.

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Give this a read too if you’ve just upgraded to 3.4.[1]. http://wordpress.org/support/topic/troubleshooting-wordpress-34-master-list?replies=4

    Jan:

    Thanks for that – none of it worked. I even uninstalled WordPress and did a fresh install, and it still does not show.

    I’m also trying to run the plugin Ultimate TinyMCE and that doesn’t give me any editing options either. It’s the only plugin I’ve installed.

    Anybody have any other idea what could be causing this? Could it be my OS? I am running Mac OS X Lion V. 10.7.4

    Jess

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    This is the worst topic for me: I’ve never been able to reproduce this problem.

    Have you tried different bowsers on that Mac to see if. It may be your browser?

    Yes – I’ve tried Firefox, Safari and Chrome. Cleared the cache on all of them too. It’s the weirdest thing, especially since it’s happening across my sites and they are using different versions and are on different hosts. Hm.

    I am getting the same errors AND the photon uploader / add image to this post functions are not working properly.. hanging up after selection.. also tags are not being saved,, and other things .like when I click on the “chain” to make a link, nothing happens..

    Same for me. After updating different blogs on different servers to the latest WP 3.4.1, visual editor is dead on all of them, only html, very annoying and impossible to use. Using latest Firefox, latest MAC OS but I think this is not the issue. Checked several other forum entries and none seems to have the answer. Of course the box under My Profile is unchecked…

    “Use Google Libraries” plugin and all problems are solved!

    I have the same problem on one of my sites. It is happening to multiply users using all browsers. Also on PC’s and Macs.

    Can see the tab “visual” but none of the buttons or text in the box.
    can only edit post with HTML tab.

    “Use Google Libraries” did not fix it.

    Any solutions yet?

    Hey all, check and make sure JavaScript is on in your browser. The TinyMCE Editor required JavaScript to run, so if it is off, poof, no editor.

    I did not have that problem, but I read in other posts some people may have the JS folder missing in wp-admin, check this and if missing download WordPress complete package, unzip and look for the JS folder then upload by FTP. I also don’t understand why “Use Google Libraries” worked, but it did on different blogs with different service providers. I suspect the plugin automatic upgrade could be the reason, but no clue really.

    Funny, when I use “Use Google Libraries” the dashboard breaks and also doesn’t solve the problem of the visual editor showing up.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Visual Editor MIA’ is closed to new replies.
Skip to toolbar