Support » Plugin: BuddyPress Docs » Visual editor link problem after 4.5.3 update

  • Resolved Bj123

    (@bj123)


    After the WP 4.5.3 update yesterday the TinyMCE visual editor’s add a link pop up is flickering like crazy on mobile devices (iOS). It seems like it’s constantly going to display:none on and off although I don’t have any custom css in this regard. I guess that’s mainly a problem of the updated wordpress editor but do you have any idea what could cause this and how to solve it? If I set this for example to display: block it stops flickering but then I can’t get the pop up out of the way any more. Before 4.5.3 it worked normal. Thanks.

    https://wordpress.org/plugins/buddypress-docs/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author David Cavins

    (@dcavins)

    Hi bj123-

    Is this true of the TinyMCE as it appears on the post editor in wp-admin, also, or does this behavior only apply to the docs edit screen?

    -David

    Hi David,
    It’s a problem with the WP link feature inside the TinyMCE editor whenever it is present on the screen. It’s the same in all plugins that use the TinyMCE editor. It’s nothing wrong with your BP Docs plugin. I just don’t know who is working on the TinyMCE editor and you seem to be in the wordpress team. Maybe you can pass this on?
    I could resolve this issue by installing the TinyMCE Advanced plugin and replacing the standard WP link pop-up’s with TinyMCE Advanced’s modified link pop up. I like this one simple pop up way better anyway than the unnecessary two step pop-ups in the standard TinyMCE. TinyMCE Advanced seems to work very well in all plugins I have including BP Docs.
    Thanks!

    Plugin Author David Cavins

    (@dcavins)

    I’m going to mark this topic as resolved because the issue is upstream in the WP implementation of TinyMCE. Thanks for your report!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Visual editor link problem after 4.5.3 update’ is closed to new replies.