Support » Fixing WordPress » Visual editor Issues after 3.5 upgrade

  • Resolved NataliePee



    Yesterday I had an automatic upgrade to 3.5, I didn’t do anything manually, and now I cannot edit posts using visual. The icon is there but it won’t allow me to click on it and there are no tools. I am able to add media in the new format though when I do it doesn’t appear.

    My main issue is visual as I am clueless about code.

    I have read through some other forums with similar issues and have taken the following steps but the problem still persists.

    – Cleaned the cache
    – Tried on Firefox and IE (I am using Chrome) so it is not a browser issue.
    – Switched to Twenty Eleven theme and back to my current theme (Bangkok Press)
    -Uninstalled and then re-installed all the plug ins.

    I have read about inserting code in a wp-config.php folder but I don’t have any folders on my computer associated with WP.

    Any info to fix this would be greatly appreciated, as I said I am clueless with code.

Viewing 15 replies - 1 through 15 (of 27 total)
  • Moderator t-p


    -Try adding this to the wp-config.php: define(‘CONCATENATE_SCRIPTS’, false); to the bottom of your wp-config.php file (just before the require_once line). First, make sure that your browser has JavaScript enabled.

    Hi, t-p

    Thanks for the info but unfortunately that didn’t work, however it has changed it somewhat – now there is no option for visual or html(i’m sorry I can’t remember if the second option other than visual was html or something else) and it is just the non visual version. Some of the tool bar has also returned, such as bold, quote, full screen but none of it helpful.

    Still not fixed. Any other suggestions from anyone? I have been reading a lot of similar issues after this upgrade from other users. Am I to assume it is a big that may be fixed by wp?

    Thanks again.

    I have exactly the same problem and have tried the same fixes with no success.

    So many people do according to other threads but nothing seems to be working. No way to contact wordpress directly, I am hoping this is a bug that will be resolved quickly.



    Moderator and Editor Customizer

    1. Deactivate ALL plugins.
    2. Switch to TwentyTwelve theme.
    3. MANUALLY empty and clear your browser cache.

    These first three steps are VERY important in troubleshooting. Especially step 3. If you don’t know how to manually empty your browser cache… Google is your friend!

    Try these steps and let me know.

    Thanks for replying Josh. I tried those steps but still no success unfortunately. Maybe Natalie will have more luck.

    Hey Josh, thanks.

    I actually already took these steps – I did just do them again to make sure, but unfortunately no luck….. still not resolved.

    Got VISUAL editor back following XILZEN suggestion here:

    It’s very easy too!

    Hi becomebecome,

    Thanks for the tip but unfortunately it didn’t work. I have been following a couple of other threads and followed some steps mentioned by others with no luck either.

    I am at a loss and this hasn’t been answered by a moderator in days. Does anyone know another option to contact WP?

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    I am at a loss and this hasn’t been answered by a moderator in days. Does anyone know another option to contact WP?

    This is it, you’ve contacted WordPress by posting on the forum. 😉 Also? Moderators aren’t responsible for providing help. We can of course and it’s cool when anyone (including yourself) provides support but we’re here to moderate the forums.

    <moderator hat>
    I’ve deleted your other posts, please stop posting to other peoples topics as you’ve been doing.

    I know you’re frustrated but your not helping yourself or others when you do that.
    </moderator hat>

    From the top:

    What’s the link to your site? That often can help.

    Switch your theme to Twenty Eleven. Yes, do this, it’s temporary but needs to be done as a troubleshooting step.

    Deactivate all of your plugins. All of them, no exceptions.

    Clear your browser cache and cookies. Many people leave out this step after doing the theme and plugins. Javascript can be cached on your browser so after you do the other steps you must do this one too.

    Log back in and try the visual editor.

    If it did not work (do not leave out a step) then enable the javascript console on your browser.

    Leave everything as it is now, clear the browser cache and cookies and report back to us here (not on another thread) what errors your console shows with Twenty Eleven and all plugins deactivated.

    And if you can confirm or provide a link to a non-working installation then that may help too.

    Hi Jan, thanks for getting back to me.

    I have re-done all these steps again, not missing one out and Javascript is still enabled. No success unfortunately.

    The link for my site is The content is missing as it is still on the Twenty Eleven theme, it is usually Bangkok Press if that helps.

    Thanks again.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    It looks like you’ve got at least the following plugins on your site:


    You are running WP-SuperCache too.

    And the theme is still not Twenty Eleven…

    When the Visual Editor doesn’t work it’s always either Javascript or your web server isn’t sending the files correctly for the browser.

    When it’s not working what does the Javascript console say on your browser? Do you see any errors in your wen server’s error or access log? Your host provider may need to explain to you how to find and access those logs.

    Hi, thanks. I am using those three plugins but they are not activated at present and it is 100% Twenty Eleven, if I could attach a file I would send you a screen shot.

    Really not sure about the files, wouldn’t know where to look but I will contact my host and see, and I have actually already contacted my theme so I will see what they say.

    Thanks, I’ll try these steps.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    but they are not activated at present and it is 100% Twenty Eleven

    You may have a caching issue then. The plugins I referenced came when I loaded up your site. Except for looking at the HTML your server sends I have no access to your installation (don’t want access either) and that’s what I’d gotten back via my browser. 😉

    Oh, OK…when I go to my site now it is basically a blank Twenty Eleven theme with no content, as if it is a new site aside from my menu but with nothing in the pages when you click.

    Also, not sure if you mean my WP account with caching or my machine as the problem is on my laptop I am using now, my work computer and also my playbook.

    I will see what the theme says and check my access log and let you know.
    Thanks 🙂

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Visual editor Issues after 3.5 upgrade’ is closed to new replies.