Support » Fixing WordPress » Visual Editor issue after 3.9.2 update

  • Resolved wingzfly


    Hi all!

    So here’s my problem:

    I’m the webmaster for the site at I was on vacation a couple of weeks ago and the site owner said they were having some issues with the site. I was finally able to log in today on my return and it turns out that the problem is four-fold:

    1) The “Visual” tab in the editor is selected, but there appears to be nothing inside the text box, certainly nothing “visual.” Instead, it’s all HTML in a white font color on a white background, so it appears blank.

    2) I can’t click back and forth between the “visual” and “html” tabs.

    3) None of the editor’s normal formatting buttons show up. (The bold, italics, etc. row is gone.)

    4) I can’t seem to open any of the other pull down menus on the editing pages, meaning I can click the triangle at the top of the “publish” box, for example, but it doesn’t do anything.

    From what I’ve read, it sounds like the problem may be related to TINY MCE, since the dashboard and everything else seems to work and the problems appear to be limited to the editor.

    I’ve tried disabling all the plugins, including renaming the plugin directory, but it doesn’t help.

    I’ve tried changing themes over to the Twenty Fourteen theme and that doesn’t help. I still have those problems on the default theme.

    I’ve tried reinstalling WordPress 3.9.2 manually but that hasn’t helped.

    I’ve also manually reinstalled the latest version of TINY MCE (before I did the full 3.9.2 reinstall) and that didn’t work.

    I’ve tried it on various browsers (IE9, the latest version of Chrome, Safari, and the latest version of Firefox) and on several different computers and the results are the same on each.

    I can’t figure out what else to try, so I’d love some input, ideas, advice, etc.

    Thanks in advance to you all for your help and time.

Viewing 15 replies - 1 through 15 (of 34 total)
  • This sounds exactly like the problem I’m having?


    Moderator James Huff


    Halfelf Minion 🚀

    wingzfly, try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file just below the define('DB_HOST' line.

    ntech21, your problem is probably not related. Your screenshot shows the problem only on a page called “Add New Download Package,” which is not a part of WordPress, so your problem is probably only limited to whatever plugin that is.

    Please open your own thread under that plugin’s support section.

    @MacMaX – Just tried that and it didn’t work, though it was a good suggestion.

    Moderator James Huff


    Halfelf Minion 🚀

    Hm, that’s strange. How did you “manually reinstall TinyMCE”?

    Try downloading WordPress again and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    I downloaded the zip of all the latest TINYMCE WordPress files and then placed them in the wp-includes/js/tinymce directory.

    I’ll try that now, MacManX!

    Moderator James Huff


    Halfelf Minion 🚀

    downloaded the zip of all the latest TINYMCE WordPress files

    Where did you get this from, or do you mean you downloaded the WordPress zip and got the files from that?

    As far as I know, there is no official source of just the TinyMCE files in WordPress (besides Trac and the main WordPress download).

    I found the link to the files (I think they were on the Trac website) on a post I ran across earlier today trying to research the problem. It had all of the official TinyMCE files in various zips (for Joomla, for WP, etc.), including one for WordPress and instructions on how to install them. But I still had the same issue after installing the new TinyMCE files so it didn’t help.

    Moderator James Huff


    Halfelf Minion 🚀

    Yeah, I wouldn’t trust that, the only official source of the TinyMCE files in WordPress is in the WordPress download itself.

    How did it go with deleting and replacing the files mentioned above?

    I think I ended up deleting something I shouldn’t have (though I was being careful…) and the site wouldn’t work anymore. I did a full backup of the site before I started trying to figure this all out so I’m reinstalling everything from that.

    Hi @wingzfly, I think I have found a solution for this issue. The same problem I am having some moment ago and the good news is now it’s solved.

    Do you using Cloudflare?

    Let me know, so then I can reply you the solution.

    Was able to get the site restored to the way it was before I tried manually updating it again, but the original problem persists.

    @abuzaforbg – No, I’m not using Cloudflare on that site, but I’d love to hear the fix!

    Moderator James Huff


    Halfelf Minion 🚀

    Ok, any chance you could try downloading a fresh copy of WordPress from again and replacing every file except the wp-config.php file and the /wp-content/ directory with fresh copies from the download?

    If it crashes the site again, that would be very good to know.

    I was having a similar problem with my WordPress installation until I disabled Magic Quotes with this php.ini in my wp-admin directory:

    `; Magic quotes

    ; Magic quotes for incoming GET/POST/Cookie data.
    magic_quotes_gpc = Off

    ; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
    magic_quotes_runtime = Off

    ; Use Sybase-style magic quotes (escape ‘ with ” instead of \’).
    magic_quotes_sybase = Off`

    Take a look at your browser console see if you have a SyntaxError: illegal character -type error.

    I am also having the same issue.

    All plugins deactivated and I have re installed WP. No luck.

    EDIT: It was my theme…Carry on!

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘Visual Editor issue after 3.9.2 update’ is closed to new replies.