Visual editor is no longer showing after upgrading to 3.3 (44 posts)

  1. kimberlycreates
    Posted 4 years ago #

    I tried disabling plugins and clearing my cache and hitting F5 and CTRL+F5 (multiple times) but didn't want to mess around with my theme. Installed google libraries and voila! The editor works now. Thanks!

  2. giddykipper
    Posted 4 years ago #

    I'm glad this is working for everyone, it being Christmas and all ... but not for me. I can see the HTML and the Visual editors all the time OR the HTML editor only. Has anyone else seen this phenom? AHGR

  3. giddykipper - If it's vanishing back and forth, it's most likely your cache.

  4. giddykipper
    Posted 4 years ago #

    Thanks for your interest, Ipstenu
    It's not vanishing back and forth as such
    When Visual is selected, both visual and HTML editors are visible
    When HTML is selected, only the HTML editor is visible
    In both cases the HTML toolbar sits overlapping the panel beneath and the panel beneath pulls up short, not neatly as before.
    Screenshot available if you say where, and thanks again :)

  5. giddykipper - You have a DIFFERENT issue, so you should make your own topic :) If you want to toss a screenshot up, that's fine.

  6. Nahama
    Posted 4 years ago #

    I Don't know if this is still an open issue but the same thing happened to me a few days ago.
    What worked eventually (after trying almost every suggested solution) was de-activating all my pug-ins.
    Suddenly the "visual" came back to life with all the missing functions.
    I then re-activated my plug-ins and the visual was still there- Hooray!

  7. sjbmaine
    Posted 4 years ago #

    I started this thread. I tried an amazing number of things to try to get my computer to loose the old cache. Yesterday, I opened up my blog and there was the visual editor - just as it should be. Three weeks to clear out that cache seems crazy, but things are finally happy on my end!

  8. krisolin
    Posted 4 years ago #

    I had the same problem when I upgraded to WP 3.3.1 yesterday. Everything else was just fine but my visual editor was all messed up, ie. not working. I tried emptying the cache several times and refreshing with F5, but nothing helped.

    Until I installed the Google Libraries:


    YES! It fixed the problem! Thank you very much for the tip @ipstenu! I will follow you on Twitter now!


  9. Sebaztian
    Posted 4 years ago #

    This is what worked for me:

    Add define('WP_MEMORY_LIMIT', '128M');

    to your config file and try that.

  10. faqvideo
    Posted 4 years ago #

    Navigate to Users => All users => admin => untick "Disable the visual editor when writing" on the top.

  11. lornaweightman
    Posted 4 years ago #

    Tried google libraries, deleted caches and pressed f5 loads, but nothing! same problem exists!

  12. Rich-r
    Posted 4 years ago #

    What finally worked for me was I pressed ctrl and f5 at the same time and my editor came back.


  13. aliput
    Posted 3 years ago #

    OK. I've discovered that this is only happening to me on laptops. How many of you are using laptops to update your sites?
    On a desktop machine the Visual/HTML buttons load. However, on a laptop not only are the buttons missing but the code is as well!
    Around line 240 in the source code should be the aTags for both buttons.
    However, on my laptop this code is missing!.
    I tried it on another 3 laptops (two were PCs, my other two are macs) - all with exactly the same issue. All the usual tests have been tried out including the suggestions here but even two computers (one a laptop/one a desktop) running on the same network both using ethernet or WiFi (tested both) respond with the desktop machine serving the buttons and the laptop not.
    Any ideas?

  14. aliput
    Posted 3 years ago #

    Having done some more extensive research - I believe the problem lies with the version of system software running on the laptops.
    For example the mac laptop is using 10.6.8 and no browser shows the Visual/HTML buttons in WordPress 3.4.1. However, they are there for all WP 3.3.x iterations.
    While Safari cannot be upgraded past 5.7.x on Mac OS 10.6.8 Firefox can be upgraded to the latest browser. This shows that it can't be the version of browser which is causing the problem but must be a system issue.

Topic Closed

This topic has been closed to new replies.

About this Topic