Support » Fixing WordPress » Visual editor is no longer showing after upgrading to 3.3

  • I’ve just upgraded to 3.3 from 3.2.1 on two different web sites. On each of these sites I’ve lost the visual editor. I do not see the tabs for “visual” and for “html”. All I have is the html pane.

    I have tried the sites on two different computers. I have cleared my cache. I’ve done a hard refresh. I’ve switched to the twentyeleven theme. I disabled all plugins. I’ve shutdown my satellite internet and restarted (you never know). None of these efforts seem to be working.

    I suspect that this is not a WordPress issue, but I am stumped. Any suggestions would be very welcome!

Viewing 15 replies - 16 through 30 (of 43 total)
  • robthecomputerguy, can you tell me more about hotfix .8? I’m not familiar with this – where to get it, etc. A quick google search left me confused on this.

    Thank you Buzzdeisgner.

    Curiously, I went to a computer that I’ve never used to work on my sites before and checked them. They work absolutely beautifully – visual editor showing just as it should, so I know this is a cache thing. The Use Google Libraries did nothing for me. I’ll give the hotfix a run.

    I think (and therefore could be wrong) it’s crucially important to seriously clear out your cache, and make sure you delete any cached files for your site (W3, SuperCache, Cloudflare) if it makes use of that.

    The existence of the cache could prevent the fix from showing properly.

    After the hotfix, did it still fail on multiple browsers? I’m not seeing anyone on my end where the hotfix didn’t solve their problem.

    (Except when they had an adblocker installed.)

    I know all browsers have cache clearing options, but I’ve had any given one fail me at one time or another.

    Safari, on both Mac & Windows, has a nice “Reset Safari” function that just starts the whole thing over, clearing out everything. That usually clears up cache problems for me.

    The hotfix didn’t do the trick.

    I know this is a caching given the successful functioning on another computer (that has the same software/browser, etc as the computers I’m having issues on).

    Are there any special tricks in Firefox to lose the cache that I may not know about? I’ve done the obvious Clear Cache including the entire history and the CTRL/F5 – numerous times.

    🙁

    I have also the same problem with Visual editor, plus that I can’t wee the text since they became white letters in white background (only in edit mode)

    Here’s something the same but different –
    when I have the Visual Editor selected, the HTML editor is there as well, it doesn’t close. Does this ring a bell with anyone? I, too, have disabled plugins and tried the vanilla theme route. Not life threatening but tedious – all help welcomed with a Christmassy kiss!

    I got the same problem but… I found also that my VirusBarrier X6 (I got a Mac) was the problem!!
    With full protection activated doesn’t let me see visual (and plugins too) activated!

    Because I don’t want to disable it everytime I want to post something, do someone know what is exactly to be authorized on the VirusBarrier?

    Edited: I have found that Hidden Information, and exactly Hidden information of computer and browser, HAS NOT TO BE ACTIVATED.

    I think it will work for other Internet Security Suites…

    Before jumping through hoops, try the above mentioned.

    1. Go to your posts and pick any post and ‘edit’.
    2. Press F5 three or four times (after clearing the cache).

    blogger2020, started with that all the way up in the very first post above.

    I have since totally shut down my antivirus. Cleared the cache and hard refreshed. Multiple times. Nada.

    So far on my laptop I’ve gotten the visual editor to work in Chrome – not in IE or Firefox. My primary desktop I’ve not gotten the visual editor to show in IE, Firefox, Chrome or Safari.

    Consequently, on my husband’s computer from which I have never edited my blogs, I got the visual editor to show up with no trouble.

    I hate cache.

    I have two sites on the same server. After upgrading both to 3.3 one is OK and one has the same problems described above – and its not related to cache on my computer as my client in a different city is having the exact same issue with one of the two sites. Editing and using F5 have made no difference.
    The site that is OK is in a subdirectory, while the problem site is in the public_html (main) directory.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    What happens if you install http://wordpress.org/extend/plugins/use-google-libraries/

    If THAT works, then it IS your cache. Your browser isn’t letting go of the cached JS files (happened to me and I had to go in to my documents and manually delete the cache folder entirely).

    @ipstenu
    Thanks a lot. This solution, with the google plugin worked fine with me

    I tried disabling plugins and clearing my cache and hitting F5 and CTRL+F5 (multiple times) but didn’t want to mess around with my theme. Installed google libraries and voila! The editor works now. Thanks!

Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘Visual editor is no longer showing after upgrading to 3.3’ is closed to new replies.