Support » Fixing WordPress » Visual editor is no longer showing after upgrading to 3.3

  • I’ve just upgraded to 3.3 from 3.2.1 on two different web sites. On each of these sites I’ve lost the visual editor. I do not see the tabs for “visual” and for “html”. All I have is the html pane.

    I have tried the sites on two different computers. I have cleared my cache. I’ve done a hard refresh. I’ve switched to the twentyeleven theme. I disabled all plugins. I’ve shutdown my satellite internet and restarted (you never know). None of these efforts seem to be working.

    I suspect that this is not a WordPress issue, but I am stumped. Any suggestions would be very welcome!

Viewing 15 replies - 1 through 15 (of 43 total)
  • Moderator kmessinger

    (@kmessinger)

    Read the sticky above particularly the part about json and javascript.

    esmi

    (@esmi)

    Forum Moderator

    I have a similar problem with losing the visual editor on two WP installations. I can see the Visual and HTML tabs but only the HTML tab / pane is active. I can’t switch to the Visual tab.

    The first time I tried to edit a post the editor was on the Visual tab but the pane was blank except for some red underlines for misspelled words. I switched to the HTML tab to see what was happening and now I can’t get back to Visual tab.

    I also deactivated all plugins and switched to the twentyeleven theme. No difference.

    Thanks for suggestions as well!!

    esmi

    (@esmi)

    Forum Moderator

    @lewatson: It is considered impolite to interrupt another poster’s thread. Please post a new topic.

    Yes, I’ve worked through the list and passed the json/javascript bug test. That doesn’t appear to be the issue. The only thing I have not done is a manual update. I’d be tempted to try this if it were not for the fact that it’s happening on two different sites.

    Moderator kmessinger

    (@kmessinger)

    Basically, the only thing that can cause this is a javascript conflict. But you might try replacing the wp-admin and wp-includes folders with fresh copies to rule out a corrupted file.

    I deleted the wp-admin and wp-include folders and then uploaded fresh 3.3 folders. This did not solve my visual editor issue on at least one of my sites (I’ve only done it on one site so far).

    I created an entirely new WordPress site install and I’ve got the same issue in this brand new site – no visual editor. This is the case in multiple browsers and on different computers.

    Still stumped.

    Try this. I was able to get me visual editor back with the following:

    1) Switch theme to Twenty Eleven
    2) Edit a post (displays as white pane with red underlines)
    3) Clear cache (press F5)

    Visual editor, tabs and buttons returned at this point in edit post mode.

    4) Switch back to original theme.
    5) Edit post. (all returns to normal, do the happy dance!)

    I did not have to deactivate the plugins for this to work.

    Do you have an ad blocker or content blocker of any type installed on your browser? It seems to be a guaranteed cause of the buttons not working.

    I could also see a safe browsing filter internet thingy causing a problem?

    lewatson, I jumped through your series of hoops on one of my sites and it seemed to do the trick – only after step 5 I had to CTRL/F5 a couple of times before I could do the happy dance.

    What your scenario added to what I’d done before was to edit a post while in the Twenty Eleven theme before switching it back to my theme. Silly, but it worked. Thanks for posting!

    I also had the same issue in my two blogs. For the first one, I tried lewatson’s 5-step approach, and it worked!

    For the second site, I tried a shorter route. I simply went to the Edit Post mode without changing themes. I pressed F5 three or four times (after clearing the cache). Voila! It also worked!

    I confess I’m at a total loss here. I was so excited last night when I got one site on one computer to show the visual editor following lewatson’s instructions.

    Despite jumping through these hoops I have not been able to get the second site to show the visual editor or either site on my desktop. I don’t have anything fancy running here – Firefox as the principle browser, Windows 7, Avast anti-virus with no additional ad or popup blockers. I just seems like my computers will not give up this cache.

    I’m afraid to update my other sites to 3.3 until I can figure out a sure fire way to get the cache cleared. Ugh.

    Changing themes and jumping through coding hoops should not be a resolution. I had one Plugin button/feature disappear (phpBay) and have yet to resolve the issue.

    I’m using the Arthemia theme (FYI) but the normal visual editor stayed in place as normal.

    @sjbmaine did you try the fixes listed for “use google libraries” and the hotfix .8?

    The “use google libraries” plugin seems to solve a lot of people’s problems.

    I’ve got the same problem. If anybody use cloudflare follow 3 steps:

    1)Go to cloudflare settings: Caching Level –> choose basic
    2)turn on development mode
    3)empty cache

    Should help.

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Visual editor is no longer showing after upgrading to 3.3’ is closed to new replies.