Support » Fixing WordPress » Visual Editor in 3.1 disappeared

  • Resolved


    Visual editor really dissapear in WP 3.1

    Plugins reactivating don´t help.
    Reupload of folders (wp-admin, wp-includes) don´t help.
    Don´t work in Firefox 3.6.13, Chrome 10.0.648.82 beta

    Tested on 5 WP sites… (1 site is ok, 4 without visual editor)


Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    – increasing the memory available to PHP:

    Problem was in plugins…
    Seem, that more plugins are incompatible with visual editor in admin…

    Okay. Same problem. The visual editor font is suddenly white, which means the screen comes up appearing to be blank. I am seeing code on the visual side, and NO style buttons. On the html side, I am seeing style buttons.

    I have disabled all plug-ins, checked – no diff.

    Haven’t the faintest idea how to reset plug-ins by FTP. I just reset them on the dashboard.

    I am self-hosted, have NEVER had a problem like this before. I am running a bastard child of twenty ten.

    I had the same problem while upgrading a company blog site. I had to get my hands dirty by going into code level of WordPress and started debugging. I did a quick fix to get it working ultimately. Pls take a copy of your file before you do so if it doesn’t work you can always replace it back. Please note that I did this after me upgrading it to 3.1 but you may try it out with others if you have same problem.

    – Under ‘wp-includes’ directory open ‘general_templates.php’. Look for ‘function user_can_richedit()’ and replace the whole function with following code. I think the line numbers will be somewhere from 1734 to 1750.

    <strong>  function user_can_richedit() {
                    global $wp_rich_edit, $pagenow, $is_iphone;
                    if ( !isset( $wp_rich_edit) ) {
                                    if ( get_user_option( 'rich_editing' ) == 'true' &&
                                                    !$is_iphone && // this includes all Safari mobile browsers
                                                    ( ( preg_match( '!AppleWebKit/(\d+)!', $_SERVER['HTTP_USER_AGENT'], $match ) && intval($match[1]) >= 420 ) ||
                                                                    !preg_match( '!opera[ /][2-8]|konqueror|safari!i', $_SERVER['HTTP_USER_AGENT'] ) )
                                                                    && 'comment.php' != $pagenow ) {
                                                    $wp_rich_edit = true;
                                    } else {
                                                    $wp_rich_edit = false;
    // My code as a fix
    if ( get_user_option( 'rich_editing' ) == 'true'  )
     $wp_rich_edit = true;
    return  $wp_rich_edit;
    // return apply_filters('user_can_richedit', $wp_rich_edit);

    Please make sure you would test it properly as I don’t know whether it would have any other effect to other parts of the WP or any other functionality. As per my requirement this worked well and I didn’t really dig behind actual root cause due to lack of time.

    Sorry I also one thing I missed to mention is that having done above you can use the WP user profile functionality where you could enable/disable Visual editing for indivisual user. It is under Users – Edit user profile and then untick “Disable the visual editor when writing”

    Seeing same problem on a StudioPress theme running on a Hostgator site with wordpress 3.1.

    Tried disabling visual editor on user profile, saving, then re-enabling(unchecking) and saving.

    Weirdly, the show hide kitchen sink and the more buttons showed up on visual editor (nothing else)

    I tried everything. All the recommendations. I finally went back to the older version, and am very discouraged. Sooner or later, I’m going to have to upgrade again, and nothing will work. I’m with Netfirms. Maybe their migration will change something. But I doubt it. This thing really is weird. It hits everybody differently. Nothing I did even brought back the buttons. They keep telling us to try the same things over and over and I keep telling them I’ve done those things. Then they tell me to do them again, as though nobody has read the comments. Except for one guy. Who yelled at me for posting about it. And he got his way – I just went away. Problem solved – for him.

    I am having the visual editor buttons blank out, on sub-domains. Main blogs is still ok. (bluehost is host) On FF, chrome, safari, ie8. Sometimes other graphics elements in the editor also disappearing. This is a new problem, it appears to be with 3.1. But clean reinstalls of earlier versions are doing the same now. It is a real problem.

    Well I am surprise and it sounds really wiered as these are standard software package and if works for someone then why not for others. Logically it means (may well be) some other factors (like server environment and platform) contributing to the issue. May be you guys should give full access rights (777) to the entire installation directory and see if it works. It’s just a thought.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Visual Editor in 3.1 disappeared’ is closed to new replies.