WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor in 2.5

Visual Editor in 2.5

  • thelazygeisha
    Member

    @thelazygeisha

    Is anyone else having an issue with the visual editor in WP 2.5?

    When I attempt to insert an image or a link, the dialog window pops up but it’s blank — no place to insert links or other info, just a blank square.

    Not sure if this is a setting (doubtful) and I don’t think it’s a browser issue.

    Any help or suggestions is appreciated.

    Thanks,

    – nina

    Edit: In HTML mode the dialog boxes function.

Viewing 15 replies - 46 through 60 (of 90 total)
  • Niksterg you would have begin_gzip.php and end_gzip.php in your root directory if it was. Your .htaccess file would have this entry too ..

    php_value auto_prepend_file /hsphere/local/home/wwwuser/xxx.com/begin_gzip.php
    php_value auto_append_file /hsphere/local/home/wwwuser/xxx.com/end_gzip.php

    rebeltech81
    Member

    @rebeltech81

    I’m having the same problem as Niksterg11. Here’s a screenshot.

    I can create and edit posts and then publish them with no prolbem, but the visual editor remains messed up.

    This is a clean install of WP 2.5 and I have not activated any plugins.

    I’ve tried the “simple” stuff, i.e. cleared browse cache, made sure “use visual editor” was checked, deleted and re-installed wordpress totally, then delete/re-upload just the wp-includes folder, then just the tinymce folder, etc.

    The site runs on Linux with Apache, PHP 5.23. However the editor works like a champ for another site running on IIS 5.1, PHP 4.4.7.

    Using the Firebug extension in Firefox, when I navigate to the create new post page, it indicates an error with tiny_mce_config.php stating “illegal error”. When I click for more info, the Firebug console displays a bunch of text garbage. And if I navigate to tiny_mce_config.php via my web browser, I’m treated to some more text garbage. On the working WP 2.5 install on the other site, I get plain text of the javascript for that page.

    Any thoughts, anybody?

    rebeltech81
    Member

    @rebeltech81

    In reference to Mellco’s post on ob_gzhandler

    I tried this one-liner php script:

    ob_start("ob_gzhandler");

    and got this error:
    Warning: ob_start() [ref.outcontrol]: output handler ‘ob_gzhandler’ cannot be used twice in /home/southern/public_html/tm/gzip.php on line 3

    On my other site where the editor is working, the above script returns no errors/warnings.

    Clearing my Firefox cache worked for me under XP. I’ll have to wait until I get home to try it on OSX

    Andrew Ozz
    WordPress Dev

    @azaozz

    To summarize the most common problems and solutions for the visual editor:

    1. Compression is enabled on the server. If it’s set properly (in php.ini) the compressor for TinyMCE would detect it and not try to compress the js. To check for double compression: with Firefox, go to [your-site]/wp-includes/js/tinymce/tiny_mce_config.php. Should be a large text (js) file, starting with “var tinyMCEPreInit = …” and last line starting with “tinyMCE.init({mode:”none”,…”.

    If it’s not – edit tiny_mce_config.php, looking for
    'compress' => true,
    change to
    'compress' => false,

    or if preferred, download this small plugin that will disable caching and compression when active:
    http://www.laptoptips.ca/wpd/wp-content/img/testing-tinymce-3.zip

    2. Link and Image pop-ups are blank, don’t work or have JavaScript errors. This is usually caused by caching. Could be the browser’s cache, could be a proxy or network cache at your Internet provider or somewhere between your computer and your web site.

    When a pop-up is opened in TinyMCE, it downloads separate js and css files from the server. These files are usually cached, as they don’t change often. Unfortunately some network caches check for newer files less frequently, so it may be 2-3 days before they are all refreshed.

    Another possibility is if you’ve ever used SSL (https://…) to access your site and still have shortcuts with https in them. Generally your browser will be redirected to the proper url by the server, but TinyMCE gets this information from the browser, it may follow the wrong link and never find the files for the pop-up.

    I have the same issue in 2.5.

    Visual editor nor HTML editor work when “use visual editor” is turned on. If I shut the option down, I can see the regular html editor.

    -> Both my sites upgraded from 2.3.x (same version) and they’re on the same hosting account.
    -> One of the sites refuses to display the editors, the other works fine.

    – IE6 shows both working.
    – Firefox 2.0.0.13 shows one working and the other fails.

    What I tried:
    * clearing browser cache.
    * deactivating plugins.
    * clearing wp-content/cache.
    * uploading 2.5 source files again in WP-includes and WP-Admin.

    None of it worked.

    Ah, I figured out what did work for me.

    I did not need to do a clean install, but if I replace all files by the files of Release Candidate 1 (RC1) and then overwrite them again by the official release, my visual/html editor starts working.

    CerpinTaxt
    Member

    @cerpintaxt

    Yea.. I did the same thing as feles, but I only copied the directory TinyMCE from RC1.

    And it worked!!

    rebeltech81
    Member

    @rebeltech81

    Unfortunately, azaozz’s, feles’s, and CerpinTaxt’s solutions don’t work for me.

    Any other thoughts?

    groovyKimo
    Member

    @groovykimo

    Well, on my part it’s clearly the compression thingy – it’s reproducable.

    @rebeltech: Did you shift-F5? I needed to for the wysiwyg to come up.

    I’m on a small shared hosting (http://www.rubas.net), but I think it’s properly configured (maybe a bit savy – but till now I had no problems), since the Admin is quite competent.

    I can ask him for details if someone tells me what he needs to know (global php.ini or whatever).

    nope, sadly those dont work for me either. I cant get to the visual editor at all. Only the html editor.

    Andrew Ozz
    WordPress Dev

    @azaozz

    GroovyKimo, try the “testing-tinymce-3” plugin linked in my previous post. It disables compression and server side caching in TinyMCE.

    May want to try uncommenting the last line too, so the editor is refreshed every time it loads. This could solve some network cache issues.

    algorithmbetting
    Member

    @algorithmbetting

    my visual editor error is fixed:

    i had tiny mce plugin installed and acitivated after upgrading to 2.5.

    in 2.5 its preinstalled so you need to deavtivate the plugin.

    now all is fine.

    Changing
    'compress' => true, to 'compress' => false, fixed it for me on an upgrade from 2.3.1 to 2.5.

    (Hey, where’s the preview button on this thing?)

    rebeltech81
    Member

    @rebeltech81

    @groovykimo. Yep, tried that.

    Being the goober that I am, I just realized I uploaded azaozz’s plugin to tinymce’s plugin folder instead the wordpress plugin folder.

    [smacking my forehead]

    I’ll give it a go again this evening.

Viewing 15 replies - 46 through 60 (of 90 total)
  • The topic ‘Visual Editor in 2.5’ is closed to new replies.