Visual Editor in 2.5 (91 posts)

  1. Mellco
    Posted 8 years ago #

    Thanks that did not work for me. This is the error I am getting.

    tinyMCE is not defined
    Line 73

    tinyMCE is not defined
    go("content")editor.js (line 73)
    onclick(click clientX=0, clientY=0)post-new.php (line 1)
    [Break on this error] var ed = tinyMCE.get(id);

  2. minedart
    Posted 8 years ago #

    Just installed 2.5 and I can't see the WYSISYG Visual Editor icons, i.e. bold, italic, add image, etc.

    Though I tried to deactivate plugins and reactivate them, but it did not work.

    How solving this issue?

  3. elfreakz
    Posted 8 years ago #

  4. _bebe
    Posted 8 years ago #

    @ elfreakz
    i tried deactivating and activating the plugins - didn't work
    i tried using Safari - didn't work
    i tried changing the chmods (sp lol?) - didn't work
    i tried re-installing EVERYTHING etc - didn't work

    grrrr i don't use the Rich Editor, but it still bothers me that it doesn't work. Another thing is... when I go to type my entry, you CAN NOT read what i'm typing. the font color is white...

  5. robin.muilwijk
    Posted 8 years ago #


    I just upgraded and had the same problems with FireFox, blank popups when adding links and images. Clearing the cache helped, I got the popups functioning again.

  6. sn0wman
    Posted 8 years ago #

    "maybe this help =>
    http://el.freakzter.com/2008/03/31/fix-visual-editor-in-wordpress-25/ "

    Thank you for the tip, but it didn't work for me.

  7. facibus
    Posted 8 years ago #

    ...and all of the above are errors new to 2.5.

    No, they're not. Lots of people had similar problems with 2.3, 2.2, and 2.1. Essentially, it's some kind of issue with your browser or installation. Why? Well, two reasons... a) it works fine for me in Firefox and b) it's always some kind of server problem. Usually it's because the webserver doesn't much like ajax calls for some reason.

    Sorry, I should have said "...and all of the above are errors new to 2.5 for me, I've been using WordPress for 18 months now and have never had this problem" :)

    So... is there a formal mechanism for reporting these as bugs such that they get fixed? The "you the user are the problem" Jedi Mind Trick just doesn't cut it with me, I've been around too long :)

    Every other application that makes AJAX calls seems to be working OK today, including some others in WP2.5. Next excuse? :)

    Cheers, Andrew

  8. Niksterg11
    Posted 8 years ago #

    Here's my situation:
    I can't get the visual editor to work, all I see are the HTML tag buttons that would normally be there if I had the visual editor turned off. I do see two tabs that should allow me to switch between Visual and HTML; the default is Visual, so it's highlighted but like I said, I only see HTML buttons.

    I've tried reinstalling WP 2x. I've deactivated my plugins, cleared the cache, deleted and reinstalled TinyMCE.

    Any suggestions or common problems?

  9. _bebe
    Posted 8 years ago #

    @ Niksterg11
    i don't see any buttons whatsoever! >.<;;;

  10. inercia
    Posted 8 years ago #

    I have the same problem..

  11. quietcat
    Posted 8 years ago #

    Under Users, "Your profile" check the box in Visual Editor to enable it.

  12. Niksterg11
    Posted 8 years ago #

    tried that twice. it wasn't unchecked to begin with, so it shouldn't be happening.

  13. Mellco
    Posted 8 years ago #


    I am rolling back to 2.3.3 until this is resolved.

    Better is the enemy of good....

  14. groovyKimo
    Posted 8 years ago #

    When I run WP 2.5 local on my machine with WAMP, the editor works fine. An exact copy (WP and database) runs on my webhost and there tinymce is broken.

    So it could be some kind of server issue. None of the above solutions worked for me...

  15. Mellco
    Posted 8 years ago #

    BTW the last time I fixed this it was a gzip setting in tinyMCE in the tiny_mce_gzip.php file. The problem is that this file is now empty in 2.5.

    Just curious, do the people having this problem have gzip compresion turned on using ob_gzhandler for php? On the site I am having this problem with we have this turned on. The site that does not use the php gzip does not have this issue.

  16. Niksterg11
    Posted 8 years ago #

    here's what my php.ini says:
    ; You can redirect all of the output of your scripts to a function. For
    ; example, if you set output_handler to "ob_gzhandler", output will be
    ; transparently compressed for browsers that support gzip or deflate encoding.
    ; Setting an output handler automatically turns on output buffering.
    output_handler =

    I don't think anything is turned on.

  17. Mellco
    Posted 8 years ago #

    Niksterg you would have begin_gzip.php and end_gzip.php in your root directory if it was. Your .htaccess file would have this entry too ..

    php_value auto_prepend_file /hsphere/local/home/wwwuser/xxx.com/begin_gzip.php
    php_value auto_append_file /hsphere/local/home/wwwuser/xxx.com/end_gzip.php

  18. rebeltech81
    Posted 8 years ago #

    I'm having the same problem as Niksterg11. Here's a screenshot.

    I can create and edit posts and then publish them with no prolbem, but the visual editor remains messed up.

    This is a clean install of WP 2.5 and I have not activated any plugins.

    I've tried the "simple" stuff, i.e. cleared browse cache, made sure "use visual editor" was checked, deleted and re-installed wordpress totally, then delete/re-upload just the wp-includes folder, then just the tinymce folder, etc.

    The site runs on Linux with Apache, PHP 5.23. However the editor works like a champ for another site running on IIS 5.1, PHP 4.4.7.

    Using the Firebug extension in Firefox, when I navigate to the create new post page, it indicates an error with tiny_mce_config.php stating "illegal error". When I click for more info, the Firebug console displays a bunch of text garbage. And if I navigate to tiny_mce_config.php via my web browser, I'm treated to some more text garbage. On the working WP 2.5 install on the other site, I get plain text of the javascript for that page.

    Any thoughts, anybody?

  19. rebeltech81
    Posted 8 years ago #

    In reference to Mellco's post on ob_gzhandler

    I tried this one-liner php script:


    and got this error:
    Warning: ob_start() [ref.outcontrol]: output handler 'ob_gzhandler' cannot be used twice in /home/southern/public_html/tm/gzip.php on line 3

    On my other site where the editor is working, the above script returns no errors/warnings.

  20. rutty
    Posted 8 years ago #

    Clearing my Firefox cache worked for me under XP. I'll have to wait until I get home to try it on OSX

  21. Andrew Ozz
    WordPress Dev
    Posted 8 years ago #

    To summarize the most common problems and solutions for the visual editor:

    1. Compression is enabled on the server. If it's set properly (in php.ini) the compressor for TinyMCE would detect it and not try to compress the js. To check for double compression: with Firefox, go to [your-site]/wp-includes/js/tinymce/tiny_mce_config.php. Should be a large text (js) file, starting with "var tinyMCEPreInit = ..." and last line starting with "tinyMCE.init({mode:"none",...".

    If it's not - edit tiny_mce_config.php, looking for
    'compress' => true,
    change to
    'compress' => false,

    or if preferred, download this small plugin that will disable caching and compression when active:

    2. Link and Image pop-ups are blank, don't work or have JavaScript errors. This is usually caused by caching. Could be the browser's cache, could be a proxy or network cache at your Internet provider or somewhere between your computer and your web site.

    When a pop-up is opened in TinyMCE, it downloads separate js and css files from the server. These files are usually cached, as they don't change often. Unfortunately some network caches check for newer files less frequently, so it may be 2-3 days before they are all refreshed.

    Another possibility is if you've ever used SSL (https://...) to access your site and still have shortcuts with https in them. Generally your browser will be redirected to the proper url by the server, but TinyMCE gets this information from the browser, it may follow the wrong link and never find the files for the pop-up.

  22. feles
    Posted 8 years ago #

    I have the same issue in 2.5.

    Visual editor nor HTML editor work when "use visual editor" is turned on. If I shut the option down, I can see the regular html editor.

    -> Both my sites upgraded from 2.3.x (same version) and they're on the same hosting account.
    -> One of the sites refuses to display the editors, the other works fine.

    - IE6 shows both working.
    - Firefox shows one working and the other fails.

    What I tried:
    * clearing browser cache.
    * deactivating plugins.
    * clearing wp-content/cache.
    * uploading 2.5 source files again in WP-includes and WP-Admin.

    None of it worked.

  23. feles
    Posted 8 years ago #

    Ah, I figured out what did work for me.

    I did not need to do a clean install, but if I replace all files by the files of Release Candidate 1 (RC1) and then overwrite them again by the official release, my visual/html editor starts working.

  24. CerpinTaxt
    Posted 8 years ago #

    Yea.. I did the same thing as feles, but I only copied the directory TinyMCE from RC1.

    And it worked!!

  25. rebeltech81
    Posted 8 years ago #

    Unfortunately, azaozz's, feles's, and CerpinTaxt's solutions don't work for me.

    Any other thoughts?

  26. groovyKimo
    Posted 8 years ago #

    Well, on my part it's clearly the compression thingy - it's reproducable.

    @rebeltech: Did you shift-F5? I needed to for the wysiwyg to come up.

    I'm on a small shared hosting (http://www.rubas.net), but I think it's properly configured (maybe a bit savy - but till now I had no problems), since the Admin is quite competent.

    I can ask him for details if someone tells me what he needs to know (global php.ini or whatever).

  27. merideth
    Posted 8 years ago #

    nope, sadly those dont work for me either. I cant get to the visual editor at all. Only the html editor.

  28. Andrew Ozz
    WordPress Dev
    Posted 8 years ago #

    GroovyKimo, try the "testing-tinymce-3" plugin linked in my previous post. It disables compression and server side caching in TinyMCE.

    May want to try uncommenting the last line too, so the editor is refreshed every time it loads. This could solve some network cache issues.

  29. algorithmbetting
    Posted 8 years ago #

    my visual editor error is fixed:

    i had tiny mce plugin installed and acitivated after upgrading to 2.5.

    in 2.5 its preinstalled so you need to deavtivate the plugin.

    now all is fine.

  30. chaz6
    Posted 8 years ago #

    'compress' => true, to 'compress' => false, fixed it for me on an upgrade from 2.3.1 to 2.5.

    (Hey, where's the preview button on this thing?)

Topic Closed

This topic has been closed to new replies.

About this Topic