Support » How-To and Troubleshooting » Visual Editor in 2.5

Visual Editor in 2.5

  • Is anyone else having an issue with the visual editor in WP 2.5?

    When I attempt to insert an image or a link, the dialog window pops up but it’s blank — no place to insert links or other info, just a blank square.

    Not sure if this is a setting (doubtful) and I don’t think it’s a browser issue.

    Any help or suggestions is appreciated.


    – nina

    Edit: In HTML mode the dialog boxes function.

Viewing 15 replies - 1 through 15 (of 90 total)
  • It does seem to be a browser issue… just checked on another machine and it works fine. ugh!

    In which browser you had the problem and in which was it fixed?

    This one works for me

    Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20080311 Firefox/

    Yes, I have some problem with you.
    I use Mozilla Firefox.

    Yes, I have some problem with you.

    I hope wordpress team don’t fix me to Firefox.

    Also have the same problem, using Firefox.

    I’m having the same problem using FF



    Automattic Happiness Engineer

    This might sound minor, but clear your browser cache and see if that takes care of it as was found in this thread:


    same problem FF
    āļībut OK with Safari 3.1(525.13)



    Automattic Happiness Engineer

    That’s rich. Safari used to be the bast**d stepchild.

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Works fine for me in FF and Safari for Windows (latest beta). Might want to double check the permissions on all the WordPress files. I did have a minor javascript issue when upgrading, fixing permissions to 644 corrected it. Old version of the WP-Amazon plugin also broke parts of the editor for me, so plugins can break that as well.

    Moderator Andrew Ozz


    WordPress Dev

    Most likely the browser is trying to use cached files from 2.3. Trying to right-click in the popup and selecting Refresh or This Frame->Reload while holding down Ctrl/Shift usually fixes it straight away.


    I use FireFox under OSX – the visual editor seems to have a number of issues that any amount of cache-clearing and refreshing don’t seem to be helping.
    – the insert link popup is blank
    – the insert image popup (from Add Media Add an image) has the same “specified file failed upload test” issue that was mentioned in another thread.
    – insert image popup (from Add Media Add an image) is resizing images to not more than 300 pixels wide
    – the edit image information popup (icon in the main editor toolbar) is blank
    – on edit posts seem to be losing linefeeds in the rich editor.

    Permissions are the same as they have always been, and should have been. I’ve used this interface in various blogs a couple of hundred times in the last 12 months or so, and all of the above are errors new to 2.5.

    Screenshots of some of the above at http://onblogging.com.au/2008/03/30/wordpress-25-its-here-its-queer-it-wants-another-beer/
    (please delete the URL if it contravenes forum rules)

    Cheers, Andrew


    I should have added – I am unable to replicate any of the above errors in Opera 9.24 under OSX except for the “specified file failed upload test” one.

    Under Opera, there is an additional issue – the insert image popup (from Add Media Add an image) does not allow me to insert an image into a post at all – the Gallery tab shows the image after the “upload test” error, but does not contain an “Insert image into post” button.

    Cheers, Andrew

    I cannot switch to visual editor. My text editor is always in HTML mode, what happened?

Viewing 15 replies - 1 through 15 (of 90 total)
  • The topic ‘Visual Editor in 2.5’ is closed to new replies.