WordPress.org

Support

Support » How-To and Troubleshooting » Visual Editor Doesn’t Work

Visual Editor Doesn’t Work

  • have the same problem some people are having… ever since 2.3 (and upgrades to this) and now I’ve upgraded to 2.5, still the same problem, no plugins, no themes, tried almost everything that all the forum threads say… so i don’t know…

    also just because it works for most people (and it works fine in the other 20 wordpress installations i have) still on this one it just doesn’t work, and since the only thing that i haven’t messed with is the database, i think something is not as it should in there, maybe from some old plugin, because i tried everything from deleting everything and installing everything from scratch… and still it doesn’t work

    here is a screenshot:
    http://img246.imageshack.us/img246/6191/wordpress25yc8.jpg

Viewing 15 replies - 1 through 15 (of 34 total)
  • no one?

    I am having a similar problem with wordpress 2.5’s visual editor. my plugins and themes still work.
    but i can not use the visual editor and the buttons for bold, italic, links, etc… are missing.

    i have circled what is missing in this image.

    Dear forum,
    Now I have met with the same problem. And I’ve found at:

    /wp-includes/js/tinymce/langs/wp-langs.php

    Firebug for Firefox tells me that this script is crashed
    if I use the visual editor. And nothing helps when I hard-code
    to replace all of $langage variables with ‘en’, and add

    define (‘WPLANG’, ‘en’);

    line in wp-config.php as well…

    If something works everywhere else and you upgraded and only on a single instance it does not work and it is script related, please do the following:

    * deactivate your browsers cache
    * deactivate javascript in your browser
    * shift-reload the page that does not work
    * wait until everything has been loaded
    * re-activate javascript
    * shift-reload that page that did not work before again
    * the page should work now as intended
    * re-activate your browsers cache
    * you should be able to use that blog as all the others

    If not, this was not a caching issue. That means, on of the currently installed (or ever has been installed and then deleted plugins) is not compatible with your current version. Or some of you files are modified and lead to that error.

    I’m having the same problem.. this happened right after I installed a fresh wp 2.5 on my hosting.. I test the same version on my pc and it works. What makes it not working on my hoster?

    I have disabled all plugins and it’s still not working

    follow ur guide above. didn’t work

    i deactivated all plugins except akismet, still no change in most gecko-based browsers and midori web browser. but in konqueror the buttons work somewhat.

    a fresh wordpress2.5RC1 functions perfectly.

    So did it work as long as the browsers cache was disabled?

    Thanks hakre,
    It works by the following steps.

    1. Set the cache volume to 0 MB, turn off JavaScript in Firefox, and then set the user preference NOT to use the visual editor.
    2. Close the browser and start again.
    3. See the entry post page and check JavaScript is disabled.
    4. Go to the user preference and turn on (to be enable) the visual editor.
    5. And go back the entry post page.
    lightspeed
    Member

    @lightspeed

    Regarding the visual editor for 2.5, I can’t even see it. My Write Window options end with the “Add Media” buttons. How does one turn on or find the visual editor? Argh!

    Thank you.

    lightspeed
    Member

    @lightspeed

    Well, there ya be, there ya be … I found the answer in another thread, which is that one must go to one’s profile and turn ON the Visual Editor. *sigh* To do so is SO non-intuitive. WP People – please move this option to the actual Write Post area…please?

    Anyway, back to the grind.

    Well these problems can get mixed up with updates a lot. Basically the User does have to have the Visual Editor Option enabled – otherwise there is no visual editor.

    Beyond that setting, partial wordpress upgrades often fail because the upgrader does not validly upgrade his or her wordpress installation. And even if he or she did, you can run into caching problems.

    To use the visual editor you need to have the option set and you need to have javascript enabled.

    turkeypants
    Member

    @turkeypants

    For me, I think the problem occurred during the svn switch to 2.5. Looking into the wp-includes/js/tinymce/ directory showed a couple versions or tiny_mce.js. One was tiny_mce.js.r7627. So I renamed the old tiny_mce.js to tiny_mce.js.old and then renamed tiny_mce.js.r7627 to tiny_mce.js and refreshed. That fixed the problem for me.

    Andrew Ozz
    WordPress Dev

    @azaozz

    There are some step-by-step instructions how to try to fix this here:
    http://wordpress.org/support/topic/165449

    If it still doesn’t work after going through all steps, notice the first js error when loading the write page (best done in Firefox with Firebug) and post it here. That will make it a lot easier for someone to help.

    My problem is a tad different from what most of you guys report. I can see the Editor without a problem and can also switch between raw and WYSIWYG mode but the frame of the post box itself is screwed up. It is larger than it should be (both in FF and IE in latest versions) and is overlapping and hiding a part of the options right next to the write post box. This is only cosmetics but way worse is, I can’t see any options for font, size and colors anymore. Where are they? See the screenshot to see what I mean.

    http://img413.imageshack.us/img413/1892/wpmp2.jpg

    Additional Steps:

    1. Clear wp-content/uploads/js_cache
    2. Check if there is a Desktop Firewall. Whitelist your Blog

    Started to collect some Stuff in the Codex Wiki.

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘Visual Editor Doesn’t Work’ is closed to new replies.