Support » Plugin: Wiki » Visual editor does not work, attempts to load multiple times

  • Resolved Jeremy Malcolm


    The visual editor does not work. See:

    I had a thread about this on the wpmu forums, but the response there was “it must just be a theme or plugin conflict”. So I contacted the guys who had been working on the theme and some other development for me, and they just came back and said it’s not just a theme or plugin conflict.

    They said that the problem is that the visual editor code tries to load itself multiple times all over the page. You can actually see this if you click “edit”. There are half a dozen (empty) visual editors everywhere. And none of them work.

    They weren’t able to fix it and suggested I come back to the wiki developers.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @jeremy Malcolm,

    Thank you for your question.

    I have just checked it on my test site with WordPress default theme Twenty Twelve and it worked fine.

    I have also checked it on your site and found it is displaying following errors in browser JavaScript console.

    Uncaught TypeError: Cannot call method 'add' of undefined
    Uncaught TypeError: Cannot read property 'canvas' of undefined

    You can also check it in Chrome go to “View -> Developer -> Javascript Console” and in Firefox you can go to “Tools -> Web Developer -> Console”

    I think it is conflicting with the theme. Can you just check it using WordPress default theme and let me know whether it works or not?

    Best Regards,

    Here is the “visual” editor under the 2011 theme: still not working, though at least there aren’t multiple editors loading all over the screen.

    Any ideas?

    J K


    Hi there Jeremy,

    Hope your well today and thanks for the additional information.

    On your site with your current theme, there’s this error.

    TypeError: is undefined

    As it also doesn’t work with the 2011 theme, could you test for a plugin conflict please? You can do this by disabling all other plugins and then testing, if it works, re-enable one by one till it stops working again.

    Also do you have any custom code you’ve added at all to your functions.php or perhaps the wiki plugin itself?


    Kind Regards

    Hey there.

    We haven’t heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. 🙂

    Hope you have a fantastic day!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Visual editor does not work, attempts to load multiple times’ is closed to new replies.