Support » Fixing WordPress » Visual Editor disappearing

  • Hello,

    I am working on a new site (site link here), and I realized that the visual editor isn’t working right now. I can only edit in html. When I go to the Visual tab, the text is there, but it is white. When I highlight the area, I can see the text. Also, it is in html code. The edit bar options also disappears. In other words, when I load the page to edit, I see the text and the edit options bar, and then it reverts to the html tab.

    I deleted the only plugin I had installed, I updated to 3.05. The only other thing that can be affecting this is that I changed “moved” the site to a new directory. I copied the files from a “files” folder to a “site” folder as per the directions in the WordPress Codex.

    I also did some additional troubleshooting I found on the forum, but to no avail. Any clue?

    Thanks,
    Antonella

Viewing 15 replies - 1 through 15 (of 17 total)
  • I found another post at http://wordpress.org/support/topic/visual-editor-not-working-9?replies=3 and I tried ALL of the options. Still doesn’t work. And I don’t have the option disabled in the profile either.

    Short of scrapping the whole database and starting from scratch, does anyone else have any other suggestions before I do just that?

    Thanks.

    Same problem here under WP 3.1 & on mac safari/firefox. Tried all the main work arounds & still no fix. The visual editor appears when starting to load a page then it disappears once the page is completely loaded. I tried to edit the same WP page on PC & the visual editor is fine. Is it browser/OS related??

    I never did get it to work. Since the site was new, I scrapped the database and started from scratch.

    I have started having the same issue on all 3 of my sites, which run 2 different themes. All have been upgraded to 3.1. I was questioning my theme developer and hosting company also but looks like the issue is pointing to WordPress. I am about to start deactivating plugins. Hopefully get some answers from WordPress soon.

    I scrapped the data base & rewrote the wp-config file. It meant re-writing all the content aswell. That eliminated the problem for me.
    I also mirrored the site on another server with the same plugins & theme and the site worked fine. So pretty sure it’s nothing to do with the plugins.

    I have the same problem on three sites I am running all have been built on 3.1.1.

    Was working one minutes then the next time I logged in was all missing has anyone found a fix to the visual editor working again?

    Moderator kmessinger

    (@kmessinger)

    Go here to make sure java is working with your browser. My IE8 has the habit of turning java off every so often.

    Disable all plugins and switch to the twentyten theme. Most of the time the problems in visual editor are java based and caused by one or more plugins.

    Every time! Why is WP so insistent on these constant updates that rarely add any benefit, but instead make my life harder.

    Have they heard of beta testing?

    esmi

    (@esmi)

    Forum Moderator

    Um – that would be the 2+ months of beta testing that preceded the release, yes? Did you get involved?

    Great point! I absolutely should.

    I guess, I’m just having one of those days where progress seems like regress, and the world seems backwards.

    I should have chosen my words better.

    esmi

    (@esmi)

    Forum Moderator

    Given that there are over 8,000 plugins and 800 themes hosted just on wordpress.org alone, it’s not possible to test against every possible combination. But theme and plugin developers do have plenty of notice about updates and can test their plugins/themes on the alpha/beta versions for weeks/months before an update is released. Problem is that many developers don’t bother to do so and/or keep their plugins/themes updated.

    Z_Everson

    (@z_everson)

    Same problem here, only it’s for a new site and I haven’t even installed any plugins yet. And I’m using the same theme (Woo Theme’s VibrantCMS) on a different site with no problems. Problem exists in both Safari 5.0.5 and Firefox 4.0.1.

    Moderator kmessinger

    (@kmessinger)

    Z_Everson

    Same problem here

    What problem? Of the problems above not all are the same. Pls start a new thread and explain exactly what is happening. http://codex.wordpress.org/Forum_Welcome

    Z_Everson

    (@z_everson)

    What problem? Of the problems above not all are the same. Pls start a new thread and explain exactly what is happening. http://codex.wordpress.org/Forum_Welcome

    Same problem that’s described in this thread’s title (“Visual Editor disappearing”) and every post thereafter.

    Moderator kmessinger

    (@kmessinger)

    Z_Everson Every volunteer here would like to help but the crystal balls got recalled. Just jumping into a thread, especially an old one will not give you good results.

    Visual Editor disappearing – post title

    the visual editor isn’t working right now. I can only edit in html. When I go to the Visual tab, the text is there, but it is white. -OP

    The visual editor appears when starting to load a page then it disappears once the page is completely loaded. -1st strap hanger

    Was working one minutes then the next time I logged in was all missing. -3rd strap hanger

    Same problem here, only it’s for a new site and I haven’t even installed any plugins yet. -you

    If you want some assistance with your problem start a new thead about your problem. Provide detail like version, (the OP was using version 3.0.5), browser, any steps you have tried to correct the problem.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Visual Editor disappearing’ is closed to new replies.