Support » Networking WordPress » Visual editor disabled after 3.1 upgrade

  • Resolved Jesse


    I upgraded my 3.05 to 3.1 this morning and have seen a few funky bugs since then. I’d really appreciate a bit of help, or a nudge in the right direction.

    It’s consistent across all the sites on my install, and I’m suspecting a permissions issue, but haven’t nailed it down.

    I’ve tried renaming the plugins and mu-plugins folders on the off-chance that a plugin was causing the issue, but that didn’t alleviate it. I also checked my user settings to ensure that I didn’t have the visual editor disabled.

    Here is a screenshot of the visual editor

    and the html editor
    (separate image)

    Lastly (and this may or may not be unrelated), I seem to have lost the ability to embed an image gallery in a post. The button simply doesn’t exist.

    Thanks in advance for any help anybody can offer.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Have you tried:

    – working through the solutions suggested in Troubleshooting WordPress 3.1 – Master List

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Also consider a manual upgrade. Yours may be incomplete.



    Thanks for the replies.

    I’m going through the troubleshooting list now, but as I mentioned, I renamed the plugin directories, effectively removing them ALL. One of the sites is running Twenty Ten, and that’s suffering from the same problem.

    If the master list doesn’t hide some amazing nugget of fix-ness, I’ll have to try a manual upgrade, then switch over to debug mode (I really don’t want to have to do that with our live production server).

    I saw that just a couple weeks ago on a pre 3.1 install. Went to the user’s profile enabled Rich Text Editing, saved, Disabled, saved, Enabled and poof it came back to normal.

    Don’t know what happened. But this was how I “burped” it.



    Very interesting. Switching to twenty-ten seemed to solve the problem for most of the sites, but a few (seemingly random) sites weren’t fixed. I tried disabling and enabling Rich Text Editing, but that didn’t have an effect in this case. The symptoms aren’t user-specific, though.

    I have one theme that isn’t functioning properly (still): Newscast. It also had issues with its built-in Lightbox (that wasn’t difficult to disable, and just use a Lightbox plugin instead), but I’m still trying to find the issue with the editor. I’ll consider this solved, and follow-up on the theme issue on their forum.

    Thanks for the help, everyone!

    Do you have any of these plugins enabled?
    – TinyMCE Advanced
    – TinyMCE Excerpt
    – TimThumb meets TinyMCE?

    If so, deactivate them AND move them out of the plugins folder (deactivating alone does not work).

    This worked for me in restoring any sort of visual editor.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    move them out of the plugins folder

    rename the plugins folder. it’s easier & faster. 😉

    Guys – I’m self-hosted. Can’t find an activate RTF editing in my user profile???? Starting to feel a little panic about this.

    I like it when things don’t push my tech savvy too much. Sigh.

    Still have the problem. Tried everything. Can’t somebody who knows this program help?

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Yeah, we did.

    Did you deactivate all your plugins?
    Did you switch to the default theme?

    Did you look at this screenshot?

    Specifically the first option where it says:

    “disable the visual editor when writing”

    Is that box UNchecked?

    Deactivate – yes. Including going to the server, renaming the folder, the whole nine yards.

    Yes, I switched to the default theme. This is happening to all my sites, no matter what theme.

    I’m not sure why I should look at it – I use it. There doesn’t seem to be anything unexpected about it. Oh – I see. Yeah. I’ve switched it on and off. And on and off. And emptied the cache and restarted the computer. And added code people on the other six threads suggested. The really odd thing is that for one minute, the visual editor snapped itself on. Then off again. Haven’t seen it since. That was in the first four days.

    The visual editor screen is white when I open a post. If I select the field, I can see that the font is white, but that there is copy there. However, it’s html encoded. And there are no editing buttons. If I switch to the HTML side, I see the same copy, html encoded. There are basic buttons (for bold, italics, etc) on that side). If I switch back to visual, the font has gone black, but everything is still encoded.

    I would love to do the “Rich Text Editing” thing, but I can’t find the place where he did it. Some people have suggested that I check my version of PhP, which i was going to do last night. But I decided to do one more re-install manually – which I did on my laptop. But it seems that the download of 3.1 had been made on my other computer. So what I ended up re-installing was 3.0.1 –

    My visual editor then was happy as a clam. So I am shut out of 3.1 if I want to use it, evidently. I am hosted on a linux server, if that helps. I use Safari on a Mac.

    It’s just really frustrating to be 90 percent user, then run into something like this. I’d love to upgrade again, but no visual editor (and I don’t want to use that less pleasant plug-in some people have given up and gone to) just slows everything down drastically. I use a lot of images and caption them. Which requires previewing and refreshing at every change.

    Everything on the Master List trouble shooting thing i have tried. And as I say – even the code things I have tried. Why would it have popped in like that just for that one tiny amount of time and never do it again? I am kind of freaked out.

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Why would it have popped in like that just for that one tiny amount of time and never do it again?

    your host / caching / plugins.

    Also, you’re posting in a thread marked “resolved” which means the OP fixed it. And you’re in the multisite section and it looks like you have a single site.

    I understand it’s really really frustrating and you probably want to beat your computer into oblivion.

    I do not think it is a bug in core. It’s something specific to your setup.

    I have multiple sites. Only one of them is really very active. The OP. I do. I want to beat it. But in the other threads there were so many other people having the same exact problems I have been having – and they haven’t been answered either. So either we all have something in common in our set up, or there’s still a problem. I’ve NEVER had problems with this program before. So I don’t understand what could be suddenly wrong in my set-up – when it’s exactly the same before the install and after.

    I’ll never post here again. Sigh. Because it’s resolved and all. But can you tell me where the rich editing thing is?

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    I have multiple sites. Only one of them is really very active.

    But this section of the forums is for the multsite *feature*. Not if you have multiple installs. Sometimes this makes a difference in the answer you get, and the answers you see.

    The one thing I have seen that consistently knocks out the visual editor is javascript incompatibilities.

    But can you tell me where the rich editing thing is?

    I did. Did you look at the screenshot in the link I posted?

    And… there’s a sitcky posted in the troubleshooting section.

    Note where it says:

    If you’re using FireFox, upgrade. There ARE issues with FF 3 and TinyMCE (which powers WP’s visual editor).

    As for link info not auto-completing, the devs are aware and are looking into this. No fix yet.

    Also remember: switching between editors is the second fastest way to drive you batty 🙂 Don’t jump between visual and HTML editors.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Visual editor disabled after 3.1 upgrade’ is closed to new replies.