Support » Fixing WordPress » Visual Editor Broken – 4.5

  • Upgraded to 4.5 and it seems to have broken the visual editor on posts and pages. I can’t insert hyperlinks, save drafts or publish posts. None of my content gets saved when doing either of the last two, and when switching to Text tab I lose everything as well.

    Entering content into Text seems to work though.

    This is the error message I get in console window when I load the visual tab.

    JQMIGRATE: Migrate is installed, version 1.4.0
    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.5:1 Uncaught Error: no such method ‘instance’

    Any help would be greatly sought after.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Try a new browser, clear your browser caches, and if you use any form of caching plugins, flush them as well. If you use CloudFlare, flush any caches on that service.

    Basically, find all forms of caches affecting your site and clear them.

    I tried all of that and I see get nothing. Any other thoughts?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Any other thoughts?

    Yes. You missed something.

    What you are describing is a problem with caching. Your browser is still getting the old Javascript files and not the new ones. So, either your upgrade is incomplete somehow, or you have caches serving you old JS files. That’s the answer, basically. Finding the problem is trickier.

    Alternatively, you have a plugin or code in a theme that is interfering. Disable plugins, try the default theme, see if the behavior persists.

    Its has been beoken for me as well. The error i debugged is tince.js file missmatch. None of my staff can work due to edtitor

    Still broken

    Have you upgraded to 4.5.1?

    Yes the update does not fix the issue with tinyMCE being broke.

    Folks, I have spent hours and hours searching and trying out all the suggestions on the forum but no success. I thought I had some bright moments and tried to install other editors but without any success. Until this morning… I found this plugin called “Disable Visual Editor WYSIWYG”. After that I reactivated my TinyMCE and yoo-hoo… there TinyMCE was back again! It is a work around (and you won’t have the WP’s Visual Editor), but it worked as text can be edited again!!! I assume other editors might work as well. Success!

    What’s happening on this front? I can’t work unless my visual editor works. on 4.5.2 with Gridlocked 2 theme. Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Visual Editor Broken – 4.5’ is closed to new replies.