Support » Plugin: MediaCore Chooser » visual editor breaks when mediacore activated

  • Resolved Anointed


    Ran into 2 issues.
    1. when I installed it the folder created was mediacore-wp-plugin which caused a number of js errors for missing files as the plugin is looking for a folder called mediacore. I simply renamed the plugin folder and this solved the issue.

    *There are functions you can use in WP where you do not have to hardcode in the name of your plugin folder which would have solved the problem to begin with. I don’t have the snippet handy right now, but will post it when I do.

    2. When I activate the plugin then the visual editor breaks. I see no buttons in the visual editor when creating or editing a post.

    Deactivating the plugin solves the problem… which of course is not really a solution.

    ***Turns out it is something in WordPress 3.4 breaking the plugin. My demo of 3.3.1 works just fine. Would be nice to have a fix though as all my production sites run trunk.

Viewing 1 replies (of 1 total)
  • Plugin Author MediaCore


    Hi Anointed,

    Thanks for your feedback. Could you tell us where you downloaded the plugin from? We were using the mediacore-wp-plugin directory for development, but the public version should just be mediacore. Will look into this.

    We communicated with one other user about the plugin being broken in 3.4. We discovered in the newest release, the WordPress devs are working on Tiny MCE integration. Because of this, the plugin is periodically broken (It was broken on 3.4 for a while, and after they pushed some updates it worked fine). It appears they have made changes again, so until 3.4 is a final release (published and recommended for download on, we will not fully support it. Hopefully they finish the changes to Tiny MCE soon, so we can get these bugs fixed. We apologize for the inconvenience.

Viewing 1 replies (of 1 total)
  • The topic ‘visual editor breaks when mediacore activated’ is closed to new replies.