WordPress.org

Forums

[resolved] WordPress 2.8: Visual editor (articles and pages) is gone (78 posts)

  1. volvoxsoft
    Member
    Posted 5 years ago #

    Upgrading to WordPress 2.8 (from 2.7+) i have lost the visual editor. No visual icons are showing and it is impossible to write in the edit box.

    My wordpress dashboard is a mix of french and english language since version 2.5. I never had problem before version 2.8.

    What can be wrong?
    Any idea???

    THANKS to help me.

  2. oneandsix
    Member
    Posted 5 years ago #

    My blog is 100% english and I've got the same problem! When I type in the edit box, or when writing a new post -- everything is white. I have to highlight the text to see it.

  3. oneandsix
    Member
    Posted 5 years ago #

    [NEVERMIND]
    I actually just fixed it.

    Go to Tools>Upgrade and Re-Upgrade. Fixed it for me.
    [NEVERMIND]

    It doesn't work in Firefox, but does in Chrome.

  4. xphunt3r
    Member
    Posted 5 years ago #

    I too lost the visual editor. I tried oneandsix trick but no success. Anybody know serious solution for this

  5. volvoxsoft
    Member
    Posted 5 years ago #

    Same for me here. Visual Editor is dead on Firefox 3. It is OK using Chrome. In fact, the whole WordPress is best and faster using Chrome. And with Chrome, i have recovered the flash image uploader gone on Firefox.

  6. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    If it works in one browser try refreshing the other.. Works ok in all browsers here, from IE6 to Firefox 3.5-nightly.

  7. volvoxsoft
    Member
    Posted 5 years ago #

    YES - OK - Visual Editor finally came back under Firefox. Everything is nice now. RESOLVED FOR ME. Thanks.

  8. xphunt3r
    Member
    Posted 5 years ago #

    these is two option visual and html while going to write new post. I found every tools in html option but there is no any tool in visual. I check in firefox, chrome, and flock.

  9. xphunt3r
    Member
    Posted 5 years ago #

    its now ok for me too....................

  10. volvoxsoft
    Member
    Posted 5 years ago #

    I guess this is it. Resolved.

  11. csseur3
    Member
    Posted 5 years ago #

    i lost the visual editor in WP 2.8 with FF 3.0.10

  12. Stetolo
    Member
    Posted 5 years ago #

    Me too..
    How to solve?
    Browser: FF 3.0.10

  13. jhyoung
    Member
    Posted 5 years ago #

    I have also lost the visual editor in wp 2.8 with firefox... first appears as a blank screen (which is very alarming!) then appears as copy of html version

    I see some refs above to this being resolved, but can't see suggestions as to what to do?

  14. eddie2009
    Member
    Posted 5 years ago #

    Edit:- The Error Came back after re opening the editor :( will continue to search for a fix before downgrading i think. I seem to have intermittent errors when i follow the below "gears" details but not sure now.

    I too have just encountered I feel i have a little more to add.

    I had above mentioned problem tried refresh page, turn off super cache, open in IE8, FF3.10 both with no visual editor buttons.

    I then went to the Turbo Gears setting page located in the Tools ==> tools section i had too different but confirming encounters here.

    In Linux apache2 based web server the gears section did a rescan with out any real need to do anything numbers were in the red and auto scanned. I then went to edit a post and my buttons were back.

    In a Windows IIS based site the gears section did not want to auto scan for me so i had to go to the tools menu in the browser i was in and disable gears i then went to edit a post and again the buttons were back. i then went back to the gears setting and enabled it again with no problems.

    I study web design and regularly have problems with caching i hope this helps one person if anyone else can confirm or deny this would be great. Thanks!..
    Press on lol

  15. Stetolo
    Member
    Posted 5 years ago #

    The problem was Google Gears!
    Remove your site from Google Gears' settings and it works!

  16. malexandria
    Member
    Posted 5 years ago #

    Actually, that's not the case I'm not using Google Gears and the Visual Editor doesn't work. But the FCK Plugin works fine.

  17. thatruth2006
    Member
    Posted 5 years ago #

    Having the same problem with FF 3.0.10 on my site, the visual editor is just gone, this is not resolved. It's not Google gears cause I turned that off because there was a problem with 2.8 and it causing my browser to crash when I went to upload stuff when the AJAX screen popped up.

  18. benspun
    Member
    Posted 5 years ago #

    I had the same problem (icons not showing up in FCK Editor) after an upgrade to WordPress v2.8).

    I followed the advice of oneandsix (above) and re-upgraded WordPress v2.8 by going to Tools -> Upgrade and Re-Upgrade, and now it works fine.

    I now works for me on Firefox v2.0.0.20, Firefox v3.0.10 and IE v7.

  19. eddie2009
    Member
    Posted 5 years ago #

    Thanks to all who responded since i posted up there i still feel it is a cache problem as after following my steps again i seem to have resolved the issue's. I haven't bothered to re enable google gears yet, but have the super cache plug in back at On and all buttons appear again.. Pheww.

  20. thatruth2006
    Member
    Posted 5 years ago #

    Whew, I dumped the turned off WP-Super Cache, dumped the cache in wordpress and in the browser, logged back in and it worked. Now going to turn Super-Cache back on and see if it works. Crisis Averted.

  21. The Secret Cash Builder
    Member
    Posted 5 years ago #

    Please help...

    I already upgraded to 2.8 and I no longer have the visual editior.

    I'm trying to re-update to see if it will fix this as mentioned above but I get this message: Could not copy file: /public_html/blog/wp-content/upgrade/wordpress-2.8/wordpress/wp-comments-post.php

    and the re-update fails.

    Any idea why?

  22. malexandria
    Member
    Posted 5 years ago #

    Just use Dean's FCK Editor Plugin until they acknowledge the problem and fix this

  23. The Secret Cash Builder
    Member
    Posted 5 years ago #

    I tried it did not work either?

  24. Andrew
    Member
    Posted 5 years ago #

    In Firefox, I went to Tools > Clear Private Data and cleaned out my Firefox cache. This did the trick from me.

  25. antiquemommy
    Member
    Posted 5 years ago #

    I have cleared cache and done all mentioned above and I still have no visual editor. I don't have Google Gears. I have the problem in both IE and Firefox. I did have some error messages in the FF error console related to tiny mce, so I think it might be related to that.

  26. mku
    Member
    Posted 5 years ago #

    clea ache in firefox worked for me also. My editor toolbar is back

  27. antiquemommy
    Member
    Posted 5 years ago #

    I downloaded and installed Chrome and the visual editor works fine in that browser. I then checked FF again, and it works there again, but I couldn't tell you how or who fixed it.

  28. Andrew
    Member
    Posted 5 years ago #

    I should clarify... this is the actual process that worked for me:

    In the WP Dashboard:
    Tools > Upgrade > Re-install Automatically

    THEN...

    In Firefox:
    Tools > Clear Private Data > Clear Cache

    Then, refresh the Dashboard. At that point, once you go to edit a post or page, the editor should show up.

  29. Guzman
    Member
    Posted 5 years ago #

    I just upgraded to the new 2.8, and nothing displays AT ALL, not my theme and not my admin page. What can I do the resolve this matter.

  30. davidallred
    Member
    Posted 5 years ago #

    I did the exact same steps that AndrewD300 took and it fixed it for me as well!

Topic Closed

This topic has been closed to new replies.

About this Topic