WordPress.org

Forums

Magic Fields 2
[resolved] Visual Editor and MF2 Problem in multiline field (9 posts)

  1. Xiou
    Member
    Posted 2 years ago #

    I am using the last version of WordPress, 3.5.1 and Magic Fields 2 but the visual editor is buggy.

    Any solution ?

    http://wordpress.org/extend/plugins/magic-fields-2/

  2. Xiou
    Member
    Posted 2 years ago #

    I "solved" this problem by using markdown editor (in MF2) instead of multiline if it could help someone.

  3. shmk
    Member
    Posted 2 years ago #

    I confirm that the multiline editor on 3.5.1 brake the wordpress tinymce editor and it works "buggy".

    I can't use the markdown editor because I need advanced functions like the image upload that only multiline editor has.

    Anyone has a fix for it?

  4. nicasi
    Member
    Posted 1 year ago #

    hi there,

    apparently this happens if you hide the editor from a certain post type (post, page or custom). wordpress doesn't load tinymce then.

    the solution posted by InteliWISE here worked for me:
    http://wordpress.org/support/topic/tiny-mce-editor-not-appearing-in-magic-fields-2

  5. Riccardo
    Member
    Posted 1 year ago #

    On my WordPress the problem was that a function of Magic Fields 2 had the same name of a WordPress function.

    I renamed the function mce_escape() and all its calls to mce_escape2() on "magic-fields-2\admin\mf_tiny_mce_langs.php" and the editor is back on track :)

  6. bvansomeren
    Member
    Posted 1 year ago #

    Having the same problem as well. Ended up doing something similar

  7. nikosantis
    Member
    Posted 1 year ago #

    i solved: how?

    in folder wordpress: wp-includes/js/tinymce/langs/wp-langs.php theline 9 says // deprecated, not used but the "function mce_escape($text) {
    return esc_js($text);
    }" isnt commented. So i commented and, work now!! jojo, try

  8. S3nd41
    Member
    Posted 1 year ago #

    Tried both Riccardo and nikosantis solutions and still I can't see TinyMCE on my multiline fields. I'm using WordPress 3.9 and the latest version of MF2, please advise. Thanks!

  9. lboullo0
    Member
    Posted 1 year ago #

    I'm facing the same problem with Wordpres 3.9, MF2 and TinyMCE 4.0.1. I also tried the proposed solutions but neither worked.
    Why is it marked as resolved?
    Thank in advance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Magic Fields 2
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic