WordPress.org

Support

Support » Alpha/Beta » Visual Editing Tools Not Showing

Visual Editing Tools Not Showing

  • mseliga

    @mseliga

    This happened with beta 2 as well. I tired a reinstall of wp-include and wp-admin, I deactivated all plugins..not sure what else to try. The only tools that show are the embed buttons for images, audio, video, and media.

Viewing 15 replies - 16 through 30 (of 35 total)
  • mseliga

    @mseliga

    @familiar Ok a added that plugin. I’m still getting nothing. I don’t have this kimili plugin either. The current plugins I have running are Twitter Tools, Paranoid911, NextGen Gallery, and WP Digg. I cleared the firefox cache, refreshed my page multiple times. Still no go.

    mseliga

    @mseliga

    @familiar I changed the line from

    $initarray['plugins'] = 'safari,inlinepopups,wordpress';

    to

    $initarray['plugins'] = '';

    I see a flash of the editor for a second before it goes away.

    Familiar

    @familiar

    OK, so you see the editor for a second now, before it disappears. Interesting. Is this with my test plugin enabled, and all your others disabled?

    mseliga

    @mseliga

    @familiar. I have your plugin activated right now and all my others deactivated. Shows for a sec, then disappears.

    Familiar

    @familiar

    Sounds like a Javascript problem — it’s too bad it wasn’t caused by one of the scripts. There is more than one place where it might be failing; trying to guess where over the internet is painful. TinyMCE can be a really finicky thing.

    mseliga

    @mseliga

    @familiar I don’t suppose updating Java would help. Seems to easy though.

    EDIT

    For no reason I tired it in IE to make sure it wasn’t just Firefox. It’s present over there to.

    graphics-coop

    @graphics-coop

    @mseliga: Java and Javascript are two very different things. The TinyMCE problem does seem to be Javascript related.

    It has plagued our users for months on WordPress 2.6 – 2.6.3 (haven’t got round to 2.6.5 yet and haven’t tried the 2.7 beta).

    Our workaround is to switch to the default theme, go to the editor, then change back to our working theme and go back to the editor, which then usually loads OK. The problem keeps recurring. Maybe it’s something in our edited theme?

    mseliga

    @mseliga

    @graphics-ccop Which themes are you talking about?

    graphics-coop

    @graphics-coop

    @mseliga: We’ve built/adapted a few themes for various WordPress-based websites that we are working on.

    If we run into the visual editor problem, we switch to the WordPress default theme, then back to again. This temporarily fixes it.

    mseliga

    @mseliga

    I just tired a awitch back to the defualt. It still didn’t work.

    graphics-coop

    @graphics-coop

    @mseliga: It only work for us if we switch to default then go to the editor before switching back. Sorry if it doesn’t help you.

    mseliga

    @mseliga

    Ok, so the consensus seem to be that it’s a javascript error? What file does the editor sit in? I figure I’ll try and replace that again.

    bobdavidson

    @bobdavidson

    Been discussing this problem on a different thread… just in case someone is reading and uses FileZilla – the problem is with the upload (weird I know)… something about file/tree structures… Anyway, if you download the 3.6.1 RC1 version from here: http://filezilla-project.org/download.php?type=client&beta=1
    …and rewrite over your old install…things should be back to normal (I had to reselect “use visual editor” out of my user account and refresh a couple of times by the way)

    Just in case…

    Bob

    I concur that disabling the Kimli Flash embed plugin solves the problem. My issue has cleared.

    THANK YOU FORUM MEMBERS! YAY TEAM!

    seocoalition

    @seocoalition

    …and rewrite over your old install…things should be back to normal (I had to reselect “use visual editor” out of my user account and refresh a couple of times by the way)

    I had been using FileZilla 3.1.5.1 when I uploaded the files.

    I re-uploaded the files through my Dreamweaver CS3 and sure enough the tinyMCE came back up after a ctrl-F5…

    Thanks for the adbvice BobDavidson

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘Visual Editing Tools Not Showing’ is closed to new replies.
Skip to toolbar