WordPress.org

Support

Support » Alpha/Beta » Visual Editing Tools Not Showing

Visual Editing Tools Not Showing

  • mseliga

    @mseliga

    This happened with beta 2 as well. I tired a reinstall of wp-include and wp-admin, I deactivated all plugins..not sure what else to try. The only tools that show are the embed buttons for images, audio, video, and media.

Viewing 15 replies - 1 through 15 (of 35 total)
  • Jen

    @jenmylo

    Community Organizer

    The upload buttons are not part of the Visual Editor, and display in HTML mode as well. I know this probably sounds like an obvious question, but is the “disable Visual Editor” box checked in your Profile?

    mseliga

    @mseliga

    No it’s enabled. I’m running it on xtreemhost, but I don’t think that would cause any problems. 2.6 worked fine. Are there any files in wp-content that I could try and replace with “clean” ones without messing everything up?

    infected

    @infected

    Same here. No visual editor or quicktag editor available. 🙁

    beachbum

    @beachbum

    im only getting the html editor.

    minoofar

    @minoofar

    I am having the same problem. The visual editor never shows up. Even when I spoof as another browser or use another browser (I use Safari on Mac and Windows) on Mac or Windows, the visual editor fails to show up. I just upgraded to today’s nightly build, and still nothing. When I click on the visual editor tab, I get a non-functional page. Upon reloading, the page reverts to html editor.

    Which is fine, but I like the convenience of the visual editor.

    Payam

    mseliga

    @mseliga

    Oh yeah, forgot to add that bit by minoofar. Clicking on the “visual” to change the editor type essentially crashes the editor, requiring a refresh.

    mseliga

    @mseliga

    BUMP
    Any new ideas/thoughts on this?

    minoofar

    @minoofar

    None. I just upgraded, and the symptoms are still there. I’m wondering if this is a feature that they have disabled until its integration is complete. I wish they would say something about it.

    mseliga

    @mseliga

    What did you upgrade to? Is a Beta 3 out?

    EDIT

    Beta 4

    minoofar

    @minoofar

    This problem has been solved. Problem is with kimili flash plugin.
    http://wordpress.org/support/topic/215600?replies=2

    Familiar

    @familiar

    @minoofar: The first post here mentions that he has tried a clean install with no plug-ins.

    @mseliga: I am going to suggest something I suggested in another thread for speeding up post page load-times. Install the following stripped TinyMCE install, and let me know if it makes any difference. It sounds to me like the TinyMCE init is not working for you. One of the frustrating things about TinyMCE is it’s caching mechanism. Anyway, here’s the code, it won’t do anything except strip all extraneous TinyMCE features. Clear your cache and refresh a few times after installing the plugin:

    <?php
        /*	Plugin Name: Stripped TinyMCE
        	Plugin URI: http://www.wearefamiliar.com/
        	Description: Stripped TinyMCE
        	Version: 1.0
        	Author: Familiar
        	Author URI: http://www.wearefamiliar.com/
        	Tags: wordpress tinymce
    
        	-- Released under GPL --
    
    	Copyright 2008 Familiar
    
    	This program is free software; you can redistribute it and/or modify
    	it under the terms of the GNU General Public License as published by
    	the Free Software Foundation; either version 2 of the License, or
    	(at your option) any later version.
    
    	This program is distributed in the hope that it will be useful,
    	but WITHOUT ANY WARRANTY; without even the implied warranty of
    	MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    	GNU General Public License for more details.
    
    	You should have received a copy of the GNU General Public License
    	along with this program; if not, write to the Free Software
    	Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
    
    	-- A word of caution --
    
    	As TinyMCE is the primary editor for WordPress, losing necessary
    	functionality is not fun.  So unless you know what you're doing, don't
    	change this code.
    	*/
    
    	add_filter('mce_buttons', 'familiar_mce_buttons', 0);
    	add_filter('mce_buttons_2', 'familiar_mce_buttons_2', 0);
    
    	add_filter('htmledit_pre', 'familiar_mce_htmledit', 999);
    
    	add_filter('tiny_mce_before_init', 'familiar_mce_before_init', 0);    
    
    	function familiar_mce_buttons($buttons) {
    		$buttons = array('bold', 'italic', 'strikethrough', '|', 'bullist', 'numlist', '|', 'blockquote', '|', 'justifyleft', '|', 'link', 'unlink', '|', 'wp_more', '|', 'wp_adv', '|', 'removeformat', 'code');
    		return $buttons;
    	}
    
    	function familiar_mce_buttons_2($buttons_2) {
    		$buttons_2 = array('undo', 'redo', '|', 'cut', 'copy', 'paste', '|', 'help');
    		return $buttons_2;
    	}
    
    	/* Strip unnecessary plugins */
    
    	function familiar_mce_before_init($initarray) {
    		$initarray['plugins'] = 'safari,inlinepopups,wordpress';
    		$initarray['spellchecker_languages'] = '';
    		return $initarray;
    	}
    
    	function familiar_mce_htmledit($c) {
    		$c = preg_replace( array('/&amp;/','/</','/>/'), array('&','<','>'), $c );
    		$c = wpautop($c);
    		$c = htmlspecialchars($c, ENT_NOQUOTES);
    		return $c;
    	}
    ?>
    minoofar

    @minoofar

    Well, the symptoms were identical, FWIW. I have yet to use Kimili. So, I will just live it disabled until it is fixed. I will try to give the tinymce code above a try.

    Familiar

    @familiar

    @minoofar: Yes, try re-activating Kimili, then activating my plug-in, and see if your visual editor comes back. Could be one of the TinyMCE plug-ins not behaving with Kimili. I have left three plug-ins loading, which – aside from the Safari fixes – are both essential to TinyMCE working well with WordPress. But for the sake of testing, you could remove those as well by changing this line:

    $initarray['plugins'] = 'safari,inlinepopups,wordpress';

    to this:

    $initarray['plugins'] = '';
    minoofar

    @minoofar

    @familiar: no can do. Tinymce breaks as soon as I activate kimili. Where do I find this line of code?

    Familiar

    @familiar

    It’s here:
    http://www.wearefamiliar.com/imageshare/65a3bb1acedd290c4a18632ed2f6aaef.png

    Just below the “strip plug-ins” comment.

    EDIT: OK I am looking at the Kimili code for you. He has it add the plug-in before init. The code above may remove his plug-in entirely. If it does, try this:

    $plugins['kfe'] = WP_PLUGIN_URL.'/kimili-flash-embed/kfe/editor_plugin_tmce3.js';
    $initarray['plugins'] = 'kfe';

    This should load only his plugin, which he defines as ‘kfe’ in his code.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Visual Editing Tools Not Showing’ is closed to new replies.
Skip to toolbar