WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Visual edit tab does not work

[Resolved] Visual edit tab does not work

  • I installed yesterday WP 3.0 and it was working fine. Today I cannot edit my Posts. The Visual tab editor does not work.

    Can you give me a hand. Thank you.
    José

Viewing 11 replies - 1 through 11 (of 11 total)
  • Look in your user setting and make sure “disable visual editor” isn’t checked.

    Thank you hatefulcrawdad. The “disable visual editor” isn’t checked.

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    – increasing the available memory?
    http://wordpress.org/extend/plugins/memory-bump/
    http://wordpress.org/support/topic/253495#post-1017842

    – reviewing http://wordpress.org/support/topic/411649

    Thank you Esmi.

    During the last 2 hours I have been following all your step-by-step instructions above. Now:

    – all plugins are deactivated.

    – default theme is switched.

    – I reset the plugin folder to an empty one. And later to the original.

    – re-uploaded the wp-admin and wp-includes folders from wordpress-3.0-latest (now in the Dashboard it appears “You are using WordPress 3.0.1-alpha-15359.”)

    – installed and activated memory-bump plugin.

    – increased the available memory adding this line to my wp-config.php file:
    /** Increasing memory allocated to PHP */
    define(‘WP_MEMORY_LIMIT’, ‘256M’);

    But still not working. I am desperate. What else can I do ?. As it is a new account (I created it yesterday), can I send you my /wp-admin/ login details for you to see and check, please ??

    Thank you again.

    Esmi. I have found the solution. Everything is working now. I am going to activate the plugins and see if everything keeps working.

    What did I do ? I followed VISUALALE advise:
    Download your wp-config.php and add this line of code at the bottom of the file before the “require_once” line.

    define(‘CONCATENATE_SCRIPTS’, false );

    Esmi. Is there any problem with including that line of code ?

    Should I leave the PHP memory limit at 256M ?

    Should I un-install memory-bump plugin ?

    I appreciate your advise. Thank you.

    esmi

    @esmi

    Forum Moderator

    Is there any problem with including that line of code ?

    No. In fact that was going to be my next suggestion.

    Should I leave the PHP memory limit at 256M ?

    It won’t have any negative impact on your site if you leave it set at 256M

    Should I un-install memory-bump plugin ?

    You could do. It wasn’t needed apparently and I’m all in favour of using as few plugins as possible.

    @josefranc
    Wow It work for me thanks!!!

    I just wanted to thank folks in this thread. it just helped me tons.

    Same here – define(‘CONCATENATE_SCRIPTS’, false ); made the visual editor work again. Just wondering (because I’m no geek and no native English speaker): What does concatenate mean and actuelly do???

    Anyways – thanks for the solution!

    @gfra
    My mother language is Spanish.
    But with my limited knowledge of English, I think that Concatenate means putting one thing after another, like the rings in a chain.

    Thank you!..it worked for me also, however the quick edit and the image editor doesn’t work. I get a blank page when I add images but I can see the preview page. Even tried deactivating all plugins with no luck.

    Any solution much appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Visual edit tab does not work’ is closed to new replies.
Skip to toolbar