Support » Fixing WordPress » Visual content not loaded on a page with too many images

  • Hello there,

    I have a customized WordPress installation that’s running as a website.
    One of the pages should have small pictures of the staff, with more than 50 pictures.
    They have all been uploaded to the media gallery, so I can add them to the page using the WYSISYG editor.

    If I add +/- 30 images to the page, the page is loaded with no problem.
    Although, if I add all of them, the page is loaded as blank.

    I verified at the database, and, actually, the content there is right, it contains the full HTML code with all the images that I added in the editor, but when it loads, it returns “null”.

    Even the updating proccess of the page is affected.

    Let me explain in steps:

    1. Browse to Pages page;
    2. Select the Staff page, EDIT option;
    3. VISUAL window comes empty. I write my whole page, including all the pictures from the media gallery;
    4. Hit UPDATE PAGE, the page loads again, returning the empty visual window;
    5. Browse to the public view of the page, no content is displayed;
    6. I connect to the database and query the page content, it’s all there.

    I’m running 2.7.1 version, but I’m facing this issue from a long time.

    The server admins are saying that it’s a WordPress problem.

    Can anyone help me?

    Thanks in advance.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi Calil,

    This may be some kind of bug or limitation in WordPress, or it may be a problem with the Visual Editor dealing with the HTML. Although it would be cumbersome, might you try adding your pictures in the HTML, rather than the Visual, editor, and seeing if it works? At least that way you could eliminate the possibility of it being an image number limitation problem.

    Sorry that I don’t have any better suggestions!

    All the best,

    Rory. 🙂

    Hey Rory,

    Thanks for your attention.
    I forgot to mention that I already tried it. Also, when I thought it could be some kind of limitation on the number of images, I started removing one by one and checking if the page worked.
    When I had around 30 images (sorry, but I’m not sure), the page loaded fine.


    Guys, seriously, this problem is really pissing me off.
    If anyone can help I would appreciate.


    I am having the same problem too. Has anyone found a solution? I’ve tried the solution of adding the inline php execution fix found in this thread: and it worked for maybe 3 or 4 more images and then deleted all my content in the visual editor and html views. (Luckily WordPress 2.7 has the page restores…)

    I only want to display 26 thumbnails, I really didn’t think it would become this much of a chore…

    hey ahollier, thanks for passing by
    actually, i’m still facing this issue. I’m creating a lab WP installation in another server to see whether it’s an infra or a WP problem.

    That might be an idea for me to check out too. I have access to two different host servers and a local web server in my home so I’ll try it out on the other host server and my local one to see if I have the same issues.
    This is such an odd problem and it seems to have been going on for the past couple of versions of WordPress and one would think that they would have fixed it by now if it was purely a WordPress issue. But many people are also having the same problem too. And I haven’t been able to find any decent solutions as of yet either. I’m still searching though and I’ll let you know if I discover anything.
    I can usually find a fix for a problem that I’m having with wordpress fairly quickly, there’s usually a forum somewhere, but this one really has me stumped. It seems common, but at the same time it also seems like there is little attention paid to the issue.

    Well, I tried it on my local server and I’m still having the same issue…
    I used the same version of wordpress and even the same pictures. And if I go over 10 thumbnails (with captions) I lose everything in the visual and html editors as well as having no page content display on the page. The content is in the database (I’m looking at it right now). Sigh…
    In my PHP settings (I’ll list everything that may seem relevant):
    max_execution_time = 60
    memory_limit=32M (increased to 128M with no effect)
    post_max_size=64M (tried increasing to 128M with no effect)
    realpath_cache_size=16K (tried 1M with no effect)

    So, I’m thinking this is some sort of WordPress issue exclusively. I’m going to try a few more things, but I’m really stumped.

    hey pal, I did the same test here.
    I copied all the files from the client’s web server and uploaded to my hosting service (just, of course, changing URLs and wp-config), but the problem continues.

    Just as you said, if you query for the post with phpMyAdmin (or any other DB management tool), you’ll see that the content, actually, is at the DB, but neither HTML or visual editors show then, just like when you browse for the page.

    Let’s put things like this:
    – we have a big content;
    – we are able to insert/update it to the DB;
    – we are unable to load it from the DB when browsing pages (admin or public).

    It could be, what, a DB timeout?!
    If it was only a problem to load the thumbnails, at least the text should be displayed, but it’s not the case.

    If it wasn’t for our recent tests (on other servers), I would say it’s a DB problem, but now… it’s hard to come to a diagnostic.

    Just FYI:
    – Client’s web server: MySQL 5.0.26-Max
    – My hosting service: 5.1.30-community-log

    I’m losing my religion down here.

    FWIW, I’ve hit this same problem on a post with only 9 photos in it, and not a great deal of text either. I have a workaround that will get me by for small posts:

    1. trim the post to the point where I can see it, with some of the photos, in preview-mode
    2. view the page-source of the preview, and copy the HTML for the caption/images loaded so far.
    3. In wordpress (visual editor disabled), I then replace the caption tags with the html cut from the previewed page
    4. now I can add more images as usual.

    Tedious, and painful for large posts, but it does at least allow me to add a few more images to my simple posts.

    Hello everybody,

    After a good research and some meetings with the infra people, we changed the pcre.backtrack_limit value to 1000000 and it solved the problem.
    So, looks like it’s just a PHP5 config issue.

    How would I make that change? I am having the same problem but have no idea where to find that setting to fix it.

    Any help would be greatly appreciated!


    Hello Phil,

    It’s somewhere in the php.ini file, which is the PHP configuration file.
    It must be in the PHP root directory (not the website directory).

    If you don’t manage the server, you’ll need to ask the IT/Sys admin team to make this modification.

    Sorry for the unsure information.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Visual content not loaded on a page with too many images’ is closed to new replies.