Support » Fixing WordPress » Visual Composer not working since WP 5.0.1

  • Resolved skoelman

    (@skoelman)


    Hi,

    I just updatet WP to v5.0.1. I am currently building a website, using the SweetCake theme from Themeforest. To edit pages, this theme uses Visual Website composer, for backend as well as frontend editing.

    Since I updatet to 5.0.1, Visual Composer is nog working in the backend editor anymore. I can only use the new, fancy block editor from WordPress.

    I already searched in several settings but couldn’t find a solution yet.

    Anyone experienced the same problems and/or has a solution?

    Thanks in advance!

    • This topic was modified 3 years, 9 months ago by skoelman.
Viewing 15 replies - 1 through 15 (of 31 total)
  • Moderator t-p

    (@t-p)

    First off, please check your user profile. The visual editor being disabled there will give the code editor only.

    Thread Starter skoelman

    (@skoelman)

    Visual Composer is activated and enabled for the pages section (and others, but pages is the most important for now).

    After adjusting some settings, Visual Composer is visible again on the backend editor. However, the elements are not visible and the WP editor seems the be on top of Visual Composer in some way.

    The whole editor seems to be messed up…

    Moderator t-p

    (@t-p)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Thread Starter skoelman

    (@skoelman)

    Thanks for your fast replies!

    It seems there is a conflict between Visual Composer (VC from here) and the default, new block editor.

    I can disable the classic editor in the VC settings and set the VC as default editor, this seems to have no effect however. The classic editor remains visible, with the VC editor directly beneath it. However, there are no elements present…

    Moderator t-p

    (@t-p)

    Are you using Visual Composer from http://support.wpbakery.com/?

    Thread Starter skoelman

    (@skoelman)

    As far as I know, yes. The about section says I use VP 4.11

    It was included in the theme, therefore, I have no premium license or whatsoever. If I click on FAQ links in the WP backend, I end op on the wpbakery support page. However, there is also a VP support page. I find it somewhat confusing…

    Hi there,

    I had this same problem. Then I remembered there was this announcement. You can download the classic editor plugin (https://wordpress.org/plugins/classic-editor/). Install it and all your problems go away. It disables the Gutenberg editor that comes with WP 5.0.

    Good luck

    Moderator t-p

    (@t-p)

    For pro or commercial product support please contact the author directly on their site.

    Visual Composer: http://support.wpbakery.com/
    Your theme: contact your theme developer

    Commercial products are not supported in these forums.

    Thread Starter skoelman

    (@skoelman)

    Dionne,

    Thank you so much, that did the trick! Exactly the answer I was looking for!!

    Cheers!

    You’re welcome!

    This might be related to your issue:

    Backwards Compatibility Breaks in 5.0.1

    Hi there,

    I had this same problem. Then I remembered there was this announcement. You can download the classic editor plugin (https://wordpress.org/plugins/classic-editor/). Install it and all your problems go away. It disables the Gutenberg editor that comes with WP 5.0.

    Good luck

    SERIOUSLY I NEVER SIGN IN ANYWHERE TO COMMENT.

    THIS. WAS. LIFE SAVING.

    THANK YOU SO MUCH!

    The Classic Editor plugin worked for me too! Fast and easy.

    Thanks @skoelman for creating this thread and big thanks to @dionnekathleen and @rkdharecha for the fix.

    First install “Classic Editor” after that Visual Composer Works Fine.

    Thanks a lot @dionne!!
    You probably saved us a lot of time!

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘Visual Composer not working since WP 5.0.1’ is closed to new replies.